summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Peres2015-07-18 20:57:10 +0300
committerMartin Peres2015-07-18 20:57:10 +0300
commit692c744d84eb73b343ac20bdaf74fb3d4c396ec2 (patch)
tree02fa365c950d46dd218639a032efa1c2a1a04b27
downloadaur-692c744d84eb73b343ac20bdaf74fb3d4c396ec2.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..146b1d16f937
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = nouveau-fw
+ pkgdesc = This package provides video & pgraph firmwares for all NVIDIA chipsets that need them
+ pkgver = 325.15
+ pkgrel = 1
+ url = http://nouveau.freedesktop.org/wiki/
+ arch = any
+ license = custom
+ makedepends = python2
+ source = https://raw.github.com/imirkin/re-vp2/master/extract_firmware.py
+ source = http://us.download.nvidia.com/XFree86/Linux-x86/325.15/NVIDIA-Linux-x86-325.15.run
+ md5sums = SKIP
+ md5sums = 528fc538584de6446384b9cec3099d6c
+ sha256sums = SKIP
+ sha256sums = 3d790e4bfed24641f7cc76879144ab5d52b12271012ba381b0d33aa1a2e08775
+
+pkgname = nouveau-fw
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..38f270867199
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Martin Peres <martin.peres[at]free[dot]fr>
+# Contributor: Timothée Ravier <tim[at]siosm[dot]fr>
+
+pkgname=nouveau-fw
+pkgver=325.15
+pkgrel=1
+pkgdesc="This package provides video & pgraph firmwares for all NVIDIA chipsets that need them"
+url='http://nouveau.freedesktop.org/wiki/'
+arch=('any')
+license=('custom')
+makedepends=('python2')
+source=("https://raw.github.com/imirkin/re-vp2/master/extract_firmware.py"
+ "http://us.download.nvidia.com/XFree86/Linux-x86/${pkgver}/NVIDIA-Linux-x86-${pkgver}.run")
+md5sums=('SKIP'
+ '528fc538584de6446384b9cec3099d6c')
+sha256sums=('SKIP'
+ '3d790e4bfed24641f7cc76879144ab5d52b12271012ba381b0d33aa1a2e08775')
+
+build() {
+ sh NVIDIA-Linux-x86-${pkgver}.run --extract-only
+ python2 extract_firmware.py
+}
+
+package() {
+ install -dm 0755 "${pkgdir}"/usr/lib/firmware/nouveau/
+ cp -a nv* vuc-* "${pkgdir}"/usr/lib/firmware/nouveau/
+}
+
+# vim:set ts=2 sw=2 et: