summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBoria1382023-05-15 23:30:42 +0600
committerBoria1382023-05-15 23:30:42 +0600
commit93739c76957de64c3010a28e53bd42aecb413eac (patch)
treeca520ac95e0df045e50c805f6c32586fcd45f468
parent692c744d84eb73b343ac20bdaf74fb3d4c396ec2 (diff)
downloadaur-93739c76957de64c3010a28e53bd42aecb413eac.tar.gz
Update to latest version with python 3
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
2 files changed, 16 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 146b1d16f937..f2b56ed28539 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = nouveau-fw
pkgdesc = This package provides video & pgraph firmwares for all NVIDIA chipsets that need them
- pkgver = 325.15
+ pkgver = 340.108
pkgrel = 1
url = http://nouveau.freedesktop.org/wiki/
arch = any
license = custom
- makedepends = python2
- source = https://raw.github.com/imirkin/re-vp2/master/extract_firmware.py
- source = http://us.download.nvidia.com/XFree86/Linux-x86/325.15/NVIDIA-Linux-x86-325.15.run
+ makedepends = python3
+ source = https://raw.githubusercontent.com/envytools/firmware/master/extract_firmware.py
+ source = http://us.download.nvidia.com/XFree86/Linux-x86_64/340.108/NVIDIA-Linux-x86_64-340.108.run
md5sums = SKIP
- md5sums = 528fc538584de6446384b9cec3099d6c
+ md5sums = SKIP
+ sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 3d790e4bfed24641f7cc76879144ab5d52b12271012ba381b0d33aa1a2e08775
pkgname = nouveau-fw
-
diff --git a/PKGBUILD b/PKGBUILD
index 38f270867199..1136cb7ca01f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,25 @@
-# Maintainer: Martin Peres <martin.peres[at]free[dot]fr>
+# Maintainer: Boris Yumankulov <boriabloger[at]protonmail[dot]com>
+# Contributor: Martin Peres <martin.peres[at]free[dot]fr>
# Contributor: Timothée Ravier <tim[at]siosm[dot]fr>
pkgname=nouveau-fw
-pkgver=325.15
+pkgver=340.108
pkgrel=1
pkgdesc="This package provides video & pgraph firmwares for all NVIDIA chipsets that need them"
url='http://nouveau.freedesktop.org/wiki/'
arch=('any')
license=('custom')
-makedepends=('python2')
-source=("https://raw.github.com/imirkin/re-vp2/master/extract_firmware.py"
- "http://us.download.nvidia.com/XFree86/Linux-x86/${pkgver}/NVIDIA-Linux-x86-${pkgver}.run")
+makedepends=('python3')
+source=("https://raw.githubusercontent.com/envytools/firmware/master/extract_firmware.py"
+"http://us.download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}.run")
md5sums=('SKIP'
- '528fc538584de6446384b9cec3099d6c')
+ 'SKIP')
sha256sums=('SKIP'
- '3d790e4bfed24641f7cc76879144ab5d52b12271012ba381b0d33aa1a2e08775')
+ 'SKIP')
build() {
- sh NVIDIA-Linux-x86-${pkgver}.run --extract-only
- python2 extract_firmware.py
+ sh NVIDIA-Linux-x86_64-${pkgver}.run --extract-only
+ python3 extract_firmware.py
}
package() {