summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Englund2016-08-13 01:14:47 +0200
committerTom Englund2016-08-13 01:14:47 +0200
commit0630e8768029ffdd0a75c3b8a59db27c3a454e0b (patch)
treedddc48d43c3568686f3c4e3fd7f46abd975665a5
downloadaur-0630e8768029ffdd0a75c3b8a59db27c3a454e0b.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD31
-rw-r--r--nouveau-kepler.install24
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4f6b76f1208e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = nouveau-kepler
+ pkgdesc = nouveau from karolherbst repo with kepler reclocking patches
+ pkgver = 20160731
+ pkgrel = 1
+ url = https://github.com/karolherbst/nouveau
+ install = nouveau-kepler.install
+ arch = i686
+ arch = x86_64
+ makedepends = git
+ makedepends = make
+ makedepends = linux-headers>=4.7
+ depends = linux>=4.7
+ provides = nouveau
+ source = git+https://github.com/karolherbst/nouveau.git#branch=stable_reclocking_kepler_v5
+ md5sums = SKIP
+
+pkgname = nouveau-kepler
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0d0c4730e102
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+pkgname=nouveau-kepler
+pkgver=20160731
+pkgrel=1
+pkgdesc="nouveau from karolherbst repo with kepler reclocking patches"
+arch=('i686' 'x86_64')
+url="https://github.com/karolherbst/nouveau"
+depends=('linux>=4.7')
+makedepends=('git' 'make' 'linux-headers>=4.7')
+provides=('nouveau')
+source=("git+https://github.com/karolherbst/nouveau.git#branch=stable_reclocking_kepler_v5")
+md5sums=('SKIP')
+install=nouveau-kepler.install
+
+kernel="$(uname -r)"
+
+pkgver() {
+ cd "${srcdir}/nouveau/drm"
+ git log -1 --format='%cd' --date=short | tr -d -- '-'
+}
+
+build() {
+ cd "${srcdir}/nouveau/drm"
+ make
+}
+
+package() {
+ cd "${srcdir}/nouveau/drm/nouveau/"
+
+ install -D -m644 "nouveau.ko" \
+ "${pkgdir}/usr/lib/modules/${kernel}/kernel/drivers/gpu/drm/nouveau/nouveau.ko"
+}
diff --git a/nouveau-kepler.install b/nouveau-kepler.install
new file mode 100644
index 000000000000..999682a08cbd
--- /dev/null
+++ b/nouveau-kepler.install
@@ -0,0 +1,24 @@
+post_install() {
+ wat
+}
+
+post_upgrade() {
+ wat
+}
+
+function wat() {
+ echo "removing linux provided nouveau.ko.gz and running depmod -A"
+ kernel="$(uname -r)"
+
+ if [ -f "/usr/lib/modules/${kernel}/kernel/drivers/gpu/drm/nouveau/nouveau.ko.gz" ]; then
+ rm "/usr/lib/modules/${kernel}/kernel/drivers/gpu/drm/nouveau/nouveau.ko.gz"
+ fi
+
+ depmod -A
+
+ echo "you can now reboot and use the new nouveau.ko"
+}
+
+post_remove() {
+ echo "you now have no nouveau.ko at all, reinstall your kernel to get default back."
+}