summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Birks2020-07-29 18:25:45 -0400
committerDavid Birks2020-07-29 18:25:45 -0400
commit8b05eb6b176963bf1b503323105ce35118489dd2 (patch)
treed85ddd753f3a3958f7ac4f39465039bde03a86f1
downloadaur-8b05eb6b176963bf1b503323105ce35118489dd2.tar.gz
Initial commit of 1.0.0
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD28
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a4f848a4f705
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = nova
+ pkgdesc = A cli tool to find outdated Helm charts running in your Kubernetes cluster
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/FairwindsOps/nova
+ arch = x86_64
+ license = Apache
+ makedepends = go
+ source = nova-1.0.0.tar.gz::https://github.com/FairwindsOps/nova/archive/1.0.0.tar.gz
+ sha256sums = 7c2a498ffa914165bca73ba12983c16f0d714f8bd1041f7c009efc944cebc271
+
+pkgname = nova
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cf9e6049c80e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.pkg.tar*
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9070af2cfa4d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: David Birks <david@birks.dev>
+
+pkgname=nova
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='A cli tool to find outdated Helm charts running in your Kubernetes cluster'
+arch=(x86_64)
+url='https://github.com/FairwindsOps/nova'
+license=(Apache)
+makedepends=(go)
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=('7c2a498ffa914165bca73ba12983c16f0d714f8bd1041f7c009efc944cebc271')
+
+build() {
+ cd Nova-$pkgver
+
+ go build \
+ -trimpath \
+ -buildmode=pie \
+ -mod=readonly \
+ -modcacherw \
+ -ldflags "-extldflags \"${LDFLAGS}\"" \
+ .
+}
+
+package() {
+ install -Dm 755 "$srcdir"/Nova-$pkgver/$pkgname "$pkgdir"/usr/bin/$pkgname
+}