summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2024-04-29 14:02:53 +0300
committerCaleb Maclennan2024-04-29 14:02:53 +0300
commit90c046d0e09107e0d4e0834b5314df2a76782d67 (patch)
treea031904f00f9ea3d6650a1587ba9672151ba038d
parent369f39dfa301bc999b4962e3bd180e35b2ea2b3b (diff)
downloadaur-90c046d0e09107e0d4e0834b5314df2a76782d67.tar.gz
upgpkg: novel-cli 0.7.6-1
upstream release
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
2 files changed, 30 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6ae5bdfa56df..dfb4a4af1f43 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,22 @@
pkgbase = novel-cli
pkgdesc = tool for downloading novels from the web, manipulating text, and generating EPUBs
- pkgver = 0.3.1
- pkgrel = 2
+ pkgver = 0.7.6
+ pkgrel = 1
url = https://github.com/novel-rs/cli
arch = x86_64
- license = Apache
+ license = Apache-2.0
license = MIT
- makedepends = rust>=1.70.0
+ checkdepends = mdbook
+ checkdepends = pandoc
makedepends = clang
makedepends = cmake
+ makedepends = rust
makedepends = sqlite
depends = gcc-libs
- source = https://github.com/novel-rs/cli/archive/0.3.1/cli-0.3.1.tar.gz
- sha256sums = 01dca1b084488b455d8355bbfeea783d68b8a795d7166c82f0eef70daaa5e7e7
+ depends = glibc
+ depends = opencc
+ options = !lto
+ source = https://github.com/novel-rs/cli/archive/0.7.6/cli-0.7.6.tar.gz
+ sha256sums = db4a0cb8911732c37fde9982c5f6d4e862ebb6a8ea28da3514c6bb7cebb20c6a
pkgname = novel-cli
diff --git a/PKGBUILD b/PKGBUILD
index c0de5e5588a5..0e44b5f6817c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,44 @@
# Maintainer: Caleb Maclennan <caleb@alerque.com>
pkgname=novel-cli
-pkgver=0.3.1
-pkgrel=2
+pkgver=0.7.6
+pkgrel=1
pkgdesc='tool for downloading novels from the web, manipulating text, and generating EPUBs'
arch=(x86_64)
url='https://github.com/novel-rs/cli'
-license=(Apache MIT)
-depends=(gcc-libs)
-makedepends=("rust>=1.70.0"
- clang
+license=(Apache-2.0 MIT)
+depends=(gcc-libs
+ glibc
+ opencc)
+makedepends=(clang
cmake
+ rust
sqlite)
+checkdepends=(mdbook
+ pandoc)
+options=(!lto)
_archive="cli-$pkgver"
source=("$url/archive/$pkgver/$_archive.tar.gz")
-sha256sums=('01dca1b084488b455d8355bbfeea783d68b8a795d7166c82f0eef70daaa5e7e7')
+sha256sums=('db4a0cb8911732c37fde9982c5f6d4e862ebb6a8ea28da3514c6bb7cebb20c6a')
prepare() {
cd "$_archive"
- cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+ cargo fetch --locked --target "$(rustc -vV | sed -n 's/host: //p')"
}
-build() {
+_srcenv() {
cd "$_archive"
- CFLAGS+=" -ffat-lto-objects"
export RUSTUP_TOOLCHAIN=stable
export CARGO_TARGET_DIR=target
+}
+
+build() {
+ _srcenv
cargo build --frozen --release --all-features
}
check() {
- cd "$_archive"
- CFLAGS+=" -ffat-lto-objects"
- export RUSTUP_TOOLCHAIN=stable
+ _srcenv
cargo test --frozen --all-features
}