summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2023-06-02 16:58:28 +0300
committerCaleb Maclennan2023-06-02 16:58:28 +0300
commite79159b39972028ecbe1487484900ec29a0e268a (patch)
tree05466156dfc0f2c69d6750b8f2b6b8729b3d02e4
parent222129f9212306d57a631477c6161f62c3b2e137 (diff)
downloadaur-e79159b39972028ecbe1487484900ec29a0e268a.tar.gz
Use rustup until Arch updates to 1.70.0
...undocumented upstream minimum Rust version.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD16
2 files changed, 13 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c0aa5d485f6e..6fd871640cb4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = novel-cli
- pkgdesc = tool for downloading novels from the web, manipulating text, and generating EPUB
+ pkgdesc = tool for downloading novels from the web, manipulating text, and generating EPUBs
pkgver = 0.3.1
- pkgrel = 0
+ pkgrel = 1
url = https://github.com/novel-rs/cli
arch = x86_64
license = Apache
license = MIT
- makedepends = cargo
+ makedepends = rustup
makedepends = clang
makedepends = cmake
+ makedepends = sqlite
depends = gcc-libs
source = https://github.com/novel-rs/cli/archive/0.3.1/cli-0.3.1.tar.gz
sha256sums = 01dca1b084488b455d8355bbfeea783d68b8a795d7166c82f0eef70daaa5e7e7
diff --git a/PKGBUILD b/PKGBUILD
index aac2318bc454..c78fdd5fa791 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,35 +2,37 @@
pkgname=novel-cli
pkgver=0.3.1
-pkgrel=0
-pkgdesc='tool for downloading novels from the web, manipulating text, and generating EPUB '
+pkgrel=1
+pkgdesc='tool for downloading novels from the web, manipulating text, and generating EPUBs'
arch=(x86_64)
url='https://github.com/novel-rs/cli'
license=(Apache MIT)
depends=(gcc-libs)
-makedepends=(cargo
+makedepends=(rustup
clang
- cmake)
+ cmake
+ sqlite)
_archive="cli-$pkgver"
source=("$url/archive/$pkgver/$_archive.tar.gz")
sha256sums=('01dca1b084488b455d8355bbfeea783d68b8a795d7166c82f0eef70daaa5e7e7')
prepare() {
cd "$_archive"
- cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+ rustup toolchain install stable
+ cargo +stable fetch --locked --target "$CARCH-unknown-linux-gnu"
}
build() {
cd "$_archive"
export RUSTUP_TOOLCHAIN=stable
export CARGO_TARGET_DIR=target
- cargo build --frozen --release --all-features
+ cargo +stable build --frozen --release --all-features
}
check() {
cd "$_archive"
export RUSTUP_TOOLCHAIN=stable
- cargo test --frozen --all-features
+ cargo +stable test --frozen --all-features
}
package() {