summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorÉtienne Deparis2017-12-26 22:40:31 +0100
committerÉtienne Deparis2017-12-26 22:40:31 +0100
commit31615575097a75b2da13990b1acd284a5e07ed9d (patch)
tree05abd785a2f7f28cbe05d9c7ea30241e31ebc373
downloadaur-31615575097a75b2da13990b1acd284a5e07ed9d.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1d13bda954aa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by makepkg 5.0.2
+# Tue Dec 26 21:40:08 UTC 2017
+pkgbase = novprog
+ pkgdesc = A tool to graph your progress in writing a NaNoWriMo style novel
+ pkgver = 3.1.2
+ pkgrel = 1
+ url = https://gottcode.org/novprog/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = qt5-base
+ depends = hicolor-icon-theme
+ source = https://gottcode.org/novprog/novprog-3.1.2-src.tar.bz2
+ sha256sums = dfeb30b040f4971178cf2780f244914a14bb64f5da4bf048c04661af951c3371
+
+pkgname = novprog
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..74b6c5490fc0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Étienne Deparis <etienne@depar.is>
+
+pkgname=novprog
+pkgver=3.1.2
+pkgrel=1
+pkgdesc="A tool to graph your progress in writing a NaNoWriMo style novel"
+arch=('i686' 'x86_64')
+url="https://gottcode.org/novprog/"
+license=('GPL3')
+depends=('qt5-base' 'hicolor-icon-theme')
+source=("https://gottcode.org/novprog/novprog-${pkgver}-src.tar.bz2")
+sha256sums=('dfeb30b040f4971178cf2780f244914a14bb64f5da4bf048c04661af951c3371')
+
+prepare() {
+ cd $pkgname-$pkgver
+ sed -i 1,3d novprog.pro
+}
+
+build() {
+ cd $pkgname-$pkgver
+ qmake PREFIX="${pkgdir}/usr"
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make install
+}