summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArtyom Aleksyuk2017-06-18 02:44:40 +0300
committerArtyom Aleksyuk2017-06-18 02:44:40 +0300
commitbeee4b0996f101f1d2ac757c8000dadef49c5757 (patch)
tree8b5fb5ba1199e5db40d078ef4010724996511303
downloadaur-beee4b0996f101f1d2ac757c8000dadef49c5757.tar.gz
First version
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD46
-rw-r--r--noxbit.install8
-rw-r--r--noxbit.service19
-rw-r--r--noxbit.sysusers1
5 files changed, 108 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1f23a509d3e1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+pkgbase = noxbit
+ pkgdesc = Live Video Streaming technology based on BitTorrent protocol
+ pkgver = 20170618
+ pkgrel = 1
+ url = https://noxbit.com/
+ install = noxbit.install
+ arch = i686
+ arch = x86_64
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = custom
+ options = !strip
+ backup = opt/noxbit/noxbit.cfg
+ source = noxbit.sysusers
+ source = noxbit.service
+ sha256sums = fb84aa86b9bef64365e16efa7090504a03cebb3fd1eb02f3e021114eca3c9070
+ sha256sums = a9ed99ba5fc696965acbe35803a43637ddff54ce4a09fcb8905d8205d4ea244a
+ source_i686 = http://download.noxbit.com/i386/noxbit-pa-x86-i386.tar.gz
+ sha256sums_i686 = SKIP
+ source_x86_64 = http://download.noxbit.com/noxbit-pa-x86-64.tar.gz
+ sha256sums_x86_64 = SKIP
+ source_arm = http://download.noxbit.com/ARMel/noxbit-pa-ARMel-32.tar.gz
+ sha256sums_arm = SKIP
+ source_armv6h = http://download.noxbit.com/ARMhf/noxbit-pa-ARMhf-32.tar.gz
+ sha256sums_armv6h = SKIP
+ source_armv7h = http://download.noxbit.com/ARMhf/noxbit-pa-ARMhf-32.tar.gz
+ sha256sums_armv7h = SKIP
+ source_aarch64 = http://download.noxbit.com/AArch64/noxbit-pa-ARM-64.tar.gz
+ sha256sums_aarch64 = SKIP
+
+pkgname = noxbit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..265cc7f459aa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Artyom Aleksyuk <artyom.h31@gmail.com>
+
+pkgname=noxbit
+pkgver=20170618
+pkgrel=1
+pkgdesc='Live Video Streaming technology based on BitTorrent protocol'
+arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
+url='https://noxbit.com/'
+license=('custom')
+options=('!strip')
+depends=()
+install=noxbit.install
+backup=("opt/noxbit/noxbit.cfg")
+source=("noxbit.sysusers"
+ "noxbit.service")
+source_i686=("http://download.noxbit.com/i386/noxbit-pa-x86-i386.tar.gz")
+source_x86_64=("http://download.noxbit.com/noxbit-pa-x86-64.tar.gz")
+source_arm=("http://download.noxbit.com/ARMel/noxbit-pa-ARMel-32.tar.gz")
+source_armv6h=("http://download.noxbit.com/ARMhf/noxbit-pa-ARMhf-32.tar.gz")
+source_armv7h=("http://download.noxbit.com/ARMhf/noxbit-pa-ARMhf-32.tar.gz")
+source_aarch64=("http://download.noxbit.com/AArch64/noxbit-pa-ARM-64.tar.gz")
+sha256sums=('fb84aa86b9bef64365e16efa7090504a03cebb3fd1eb02f3e021114eca3c9070'
+ 'a9ed99ba5fc696965acbe35803a43637ddff54ce4a09fcb8905d8205d4ea244a')
+sha256sums_i686=('SKIP') # Changes too ofter
+sha256sums_x86_64=('SKIP')
+sha256sums_arm=('SKIP')
+sha256sums_armv6h=('SKIP')
+sha256sums_armv7h=('SKIP')
+sha256sums_aarch64=('SKIP')
+
+pkgver() {
+ local _source_name=source_$CARCH
+ local _date_text=$(curl --silent --head ${!_source_name} | tr -d '\r' | sed -En 's/^Date: (.*)/\1/p')
+ date -d"$_date_text" +%Y%m%d
+}
+
+package() {
+ # Install
+ install -dm0755 "$pkgdir"/opt/noxbit
+ install -Dm0755 {STM-Agent,STM-Downloader,STM-Hypervisor} "${pkgdir}"/opt/noxbit
+ install -Dm0644 noxbit.cfg "${pkgdir}"/opt/noxbit
+
+ # Additional files
+ install -Dm0644 "$srcdir"/noxbit.sysusers "$pkgdir"/usr/lib/sysusers.d/noxbit.conf
+ install -Dm0644 "$srcdir"/noxbit.service "$pkgdir"/usr/lib/systemd/system/noxbit.service
+} \ No newline at end of file
diff --git a/noxbit.install b/noxbit.install
new file mode 100644
index 000000000000..59ea922a3beb
--- /dev/null
+++ b/noxbit.install
@@ -0,0 +1,8 @@
+post_install() {
+ echo "Remember to edit /opt/noxbit/noxbit.cfg file with your UID and password"
+ echo "Please edit noxbit.service if you want to place the cache directory outside of /tmp"
+}
+
+post_upgrade() {
+ post_install
+}
diff --git a/noxbit.service b/noxbit.service
new file mode 100644
index 000000000000..07a63364fd7d
--- /dev/null
+++ b/noxbit.service
@@ -0,0 +1,19 @@
+[Unit]
+Description=Noxbit, the Live Video Streaming tool
+After=network.target
+
+[Service]
+Type=simple
+User=noxbit
+Group=noxbit
+ExecStart=/opt/noxbit/STM-Hypervisor -config=/opt/noxbit/noxbit.cfg
+Restart=on-failure
+RestartSec=5
+ProtectHome=true
+ProtectSystem=strict
+PrivateUsers=true
+ReadWritePaths=/tmp
+ProtectKernelModules=true
+
+[Install]
+WantedBy=multi-user.target
diff --git a/noxbit.sysusers b/noxbit.sysusers
new file mode 100644
index 000000000000..a98dc525ad09
--- /dev/null
+++ b/noxbit.sysusers
@@ -0,0 +1 @@
+u noxbit - "Noxbit"