summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArtyom Aleksyuk2017-06-24 20:22:56 +0300
committerArtyom Aleksyuk2017-06-24 20:22:56 +0300
commitc297f84d623d2f1049428250b708819bf92f0b49 (patch)
treea2b0489f9e79c45d2b0f7042520a15b2977746ed
parentbeee4b0996f101f1d2ac757c8000dadef49c5757 (diff)
downloadaur-c297f84d623d2f1049428250b708819bf92f0b49.tar.gz
Fixed pkgver function
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f23a509d3e1..73080a5408fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = noxbit
pkgdesc = Live Video Streaming technology based on BitTorrent protocol
- pkgver = 20170618
+ pkgver = 20170614
pkgrel = 1
url = https://noxbit.com/
install = noxbit.install
diff --git a/PKGBUILD b/PKGBUILD
index 265cc7f459aa..faf7c61aeff8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Artyom Aleksyuk <artyom.h31@gmail.com>
pkgname=noxbit
-pkgver=20170618
+pkgver=20170614
pkgrel=1
pkgdesc='Live Video Streaming technology based on BitTorrent protocol'
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
@@ -30,7 +30,7 @@ sha256sums_aarch64=('SKIP')
pkgver() {
local _source_name=source_$CARCH
- local _date_text=$(curl --silent --head ${!_source_name} | tr -d '\r' | sed -En 's/^Date: (.*)/\1/p')
+ local _date_text=$(curl --silent --head ${!_source_name} | tr -d '\r' | sed -En 's/^Last-Modified: (.*)/\1/p')
date -d"$_date_text" +%Y%m%d
}
@@ -43,4 +43,4 @@ package() {
# Additional files
install -Dm0644 "$srcdir"/noxbit.sysusers "$pkgdir"/usr/lib/sysusers.d/noxbit.conf
install -Dm0644 "$srcdir"/noxbit.service "$pkgdir"/usr/lib/systemd/system/noxbit.service
-} \ No newline at end of file
+}