summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Löthberg2014-02-26 17:35:03 +0100
committerJohannes Löthberg2015-06-08 12:21:09 +0200
commit3a35d17325063b88191a79fe6239166dcec93efb (patch)
tree10fce5518633e513b4d5de39c3b15d322a3c8917
downloadaur-3a35d17325063b88191a79fe6239166dcec93efb.tar.gz
np1-mps{,-git}: Added new packages.
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD27
-rw-r--r--np1-mps-git.install9
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c528e9d6ae46
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by makepkg 4.2.1
+# Mon Jun 1 13:54:11 UTC 2015
+pkgbase = np1-mps-git
+ pkgdesc = Terminal based YouTube jukebox with playlist management
+ pkgver = git
+ pkgrel = 1
+ url = https://github.com/np1/mps
+ install = np1-mps-git.install
+ arch = any
+ license = GPL3
+ depends = python
+ optdepends = mpv: Alternative to mplayer for playback
+ optdepends = mplayer: Alternative to mpv for playback
+ conflicts = np1-mps
+ source = git+https://github.com/np1/mps.git
+ source = np1-mps-git.install
+ md5sums = SKIP
+ md5sums = 26c08fc68ce960f1cc3a7f3f9157fa27
+
+pkgname = np1-mps-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7438c73a21b7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Johannes Löthberg <johannes@kyriasis.com>
+
+pkgname=np1-mps-git
+pkgver=git
+pkgrel=1
+pkgdesc="Terminal based YouTube jukebox with playlist management"
+arch=('any')
+url='https://github.com/np1/mps'
+license=('GPL3')
+depends=('python')
+optdepends=('mpv: Alternative to mplayer for playback'
+ 'mplayer: Alternative to mpv for playback')
+conflicts=('np1-mps')
+install=np1-mps-git.install
+source=('git+https://github.com/np1/mps.git' 'np1-mps-git.install')
+md5sums=('SKIP'
+ '26c08fc68ce960f1cc3a7f3f9157fa27')
+
+pkgver() {
+ cd mps
+ git describe --tags --long | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+package() {
+ cd mps
+ python setup.py install --root="$pkgdir" --optimize=1
+}
diff --git a/np1-mps-git.install b/np1-mps-git.install
new file mode 100644
index 000000000000..cb5c5fcffe9b
--- /dev/null
+++ b/np1-mps-git.install
@@ -0,0 +1,9 @@
+post_install () {
+ printf "==> Remember to install either mpv or mplayer for playback support.\n"
+ printf "==> For mpv playback run these commands inside mps:\n"
+ printf "set player mpv\nset playerargs --really-quiet --no-video\n"
+}
+
+post_upgrade () {
+ post_install $1
+}