summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2018-01-07 17:33:58 +0100
committerBartłomiej Piotrowski2018-01-07 17:33:58 +0100
commit3870e5d43f532380193258d98eea19c45924c4e1 (patch)
tree9224e55dc6085b81f9b8e8a5e240851b099a1aeb
parent83a625abaf3f4c1e42996d36d07314fe0526bcdb (diff)
downloadaur-3870e5d43f532380193258d98eea19c45924c4e1.tar.gz
Import from official repositories
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD48
2 files changed, 35 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 05fe84f4d282..fa6456dfbb70 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = npapi-vlc
pkgdesc = The modern VLC Mozilla (NPAPI) plugin
- pkgver = 2.2.1
- pkgrel = 1
- url = http://git.videolan.org/?p=npapi-vlc.git;a=summary
- arch = i686
+ pkgver = 2.2.5
+ pkgrel = 2
+ url = https://code.videolan.org/videolan/npapi-vlc
arch = x86_64
- makedepends = gtk2
+ license = GPL
+ makedepends = git
makedepends = npapi-sdk
+ depends = gtk2
depends = vlc
- options = !libtool
- source = git://git.videolan.org/npapi-vlc.git#tag=2.2.1
+ source = git+https://code.videolan.org/videolan/npapi-vlc.git#tag=2.2.5
+ source = git+https://code.videolan.org/videolan/libvlcpp.git
+ md5sums = SKIP
md5sums = SKIP
pkgname = npapi-vlc
diff --git a/PKGBUILD b/PKGBUILD
index d4e3a765f0aa..8b189129a469 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,41 @@
-# Maintainer: Det <nimetonmaili g-mail>
+# $Id: PKGBUILD 266875 2017-11-15 14:29:11Z foutrelis $
+
+# Maintainer: Timothy Redaelli <timothy.redaelli@gmail.com>
+# Contributor: Det <nimetonmaili g-mail>
# Contributor: Hugo Osvaldo Barrera <hugo@barrera.io>
pkgname=npapi-vlc
-pkgver=2.2.1
-pkgrel=1
+pkgver=2.2.5
+pkgrel=2
pkgdesc="The modern VLC Mozilla (NPAPI) plugin"
-arch=('i686' 'x86_64')
-url="http://git.videolan.org/?p=$pkgname.git;a=summary"
-depends=('vlc')
-makedepends=('gtk2' 'npapi-sdk')
-options=('!libtool')
+arch=('x86_64')
+url="https://code.videolan.org/videolan/npapi-vlc"
+license=('GPL')
+depends=('gtk2' 'vlc')
+makedepends=('git' 'npapi-sdk')
# This package uses version tags from Git, because there are no official releases
-source=(git://git.videolan.org/$pkgname.git#tag=$pkgver)
-md5sums=('SKIP')
+source=("git+https://code.videolan.org/videolan/$pkgname.git#tag=$pkgver"
+ "git+https://code.videolan.org/videolan/libvlcpp.git")
+md5sums=('SKIP'
+ 'SKIP')
+
+prepare() {
+ cd "$pkgname"
+ git submodule init
+ git config submodule.vlcpp.url "$srcdir/libvlcpp"
+ git submodule update
+}
build() {
- cd $pkgname
-
- msg2 "Starting autogen.sh..."
- sh ./autogen.sh
+ cd "$pkgname"
- msg2 "Starting configure..."
+ ./autogen.sh
./configure --prefix=/usr
-
- msg2 "Starting make..."
make
}
package() {
- cd $pkgname
+ cd "$pkgname"
- msg2 "Starting make install..."
make DESTDIR="$pkgdir" install
-
- install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
-} \ No newline at end of file
+}