summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDet2015-06-14 04:13:28 +0300
committerDet2015-06-14 04:14:15 +0300
commit459ff89913a779c8e04fbf7e961734f35c60d086 (patch)
tree041d16974db6c2e1a74b6ce4cbc2285789696696
downloadaur-459ff89913a779c8e04fbf7e961734f35c60d086.tar.gz
Initial import: 2.2.1.95.r1444.gd5accd8-1
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD49
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7d3f69bd2217
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = npapi-vlc-git
+ pkgdesc = The modern VLC Mozilla (NPAPI) plugin
+ pkgver = 2.2.1.95.r1444.gd5accd8
+ pkgrel = 1
+ url = http://git.videolan.org/?p=npapi-vlc.git;a=summary
+ arch = i686
+ arch = x86_64
+ license = LGPL-2.1
+ makedepends = git
+ makedepends = gtk2
+ makedepends = npapi-sdk
+ depends = vlc
+ provides = npapi-vlc=2.2.1.95.r1444.gd5accd8
+ conflicts = npapi-vlc
+ options = !libtool
+ source = git://git.videolan.org/npapi-vlc.git
+ md5sums = SKIP
+
+pkgname = npapi-vlc-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7c4e74223ae0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Det <nimetonmaili g-mail>
+# Contributor: Pimper (M0Rf30)
+
+_pkgname=npapi-vlc
+pkgname=$_pkgname-git
+pkgver=2.2.1.95.r1444.gd5accd8
+pkgrel=1
+pkgdesc="The modern VLC Mozilla (NPAPI) plugin"
+arch=('i686' 'x86_64')
+url="http://git.videolan.org/?p=$_pkgname.git;a=summary"
+license=('LGPL-2.1')
+depends=('vlc')
+makedepends=('git' 'gtk2' 'npapi-sdk')
+provides=("$_pkgname=$pkgver")
+conflicts=("$_pkgname")
+options=('!libtool')
+source=("git://git.videolan.org/$_pkgname.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+
+ echo $(git describe | cut -d "-" -f1-2 | tr - .).r$(git rev-list HEAD --count).$(git describe | cut -d "-" -f3)
+}
+
+build() {
+ cd $_pkgname
+
+ msg2 "Updating sources..."
+ git submodule update --init
+
+ msg2 "Starting autogen.sh..."
+ sh ./autogen.sh
+
+ msg2 "Starting configure..."
+ ./configure --prefix=/usr
+
+ msg2 "Starting make..."
+ make
+}
+
+package() {
+ cd $_pkgname
+
+ msg2 "Starting make install..."
+ make DESTDIR="$pkgdir" install
+
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$_pkgname/COPYING"
+} \ No newline at end of file