summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBalló György2017-02-19 23:35:19 +0000
committerBalló György2017-02-19 23:35:19 +0000
commitf503d178b0025ad7df89242b928cdf79a8cdbfb6 (patch)
tree5290b3f51e7e9792d18f52a7dcf5a0f9a1fa5b49
downloadaur-f503d178b0025ad7df89242b928cdf79a8cdbfb6.tar.gz
upgpkg: npapi-vlc-gtk3 2.2.5-1
Add npapi-vlc-gtk3
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD47
-rw-r--r--gtk3-port.patch49
3 files changed, 119 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4687c1cc22ec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = npapi-vlc-gtk3
+ pkgdesc = The modern VLC Epiphany (NPAPI) plugin (GTK3 version)
+ pkgver = 2.2.5
+ pkgrel = 1
+ url = https://code.videolan.org/videolan/npapi-vlc
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = npapi-sdk
+ depends = gtk3
+ depends = vlc
+ provides = npapi-vlc
+ conflicts = npapi-vlc
+ source = git+https://code.videolan.org/videolan/npapi-vlc.git#tag=2.2.5
+ source = git+https://code.videolan.org/videolan/libvlcpp.git
+ source = gtk3-port.patch
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = 31278df3a741294806b04ba21cfa13b7
+
+pkgname = npapi-vlc-gtk3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f2cfb490fd0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Contributor: Timothy Redaelli <timothy.redaelli@gmail.com>
+# Contributor: Det <nimetonmaili g-mail>
+# Contributor: Hugo Osvaldo Barrera <hugo@barrera.io>
+
+pkgname=npapi-vlc-gtk3
+_pkgname=npapi-vlc
+pkgver=2.2.5
+pkgrel=1
+pkgdesc="The modern VLC Epiphany (NPAPI) plugin (GTK3 version)"
+arch=('i686' 'x86_64')
+url="https://code.videolan.org/videolan/npapi-vlc"
+license=('GPL')
+depends=('gtk3' 'vlc')
+makedepends=('git' 'npapi-sdk')
+conflicts=($_pkgname)
+provides=($_pkgname)
+# This package uses version tags from Git, because there are no official releases
+source=("git+https://code.videolan.org/videolan/$_pkgname.git#tag=$pkgver"
+ "git+https://code.videolan.org/videolan/libvlcpp.git"
+ 'gtk3-port.patch')
+md5sums=('SKIP'
+ 'SKIP'
+ '31278df3a741294806b04ba21cfa13b7')
+
+prepare() {
+ cd "$_pkgname"
+ git submodule init
+ git config submodule.vlcpp.url "$srcdir/libvlcpp"
+ git submodule update
+
+ # GTK3 port
+ patch -Np1 -i ../gtk3-port.patch
+}
+
+build() {
+ cd "$_pkgname"
+
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$_pkgname"
+
+ make DESTDIR="$pkgdir" install
+}
diff --git a/gtk3-port.patch b/gtk3-port.patch
new file mode 100644
index 000000000000..30de5a2c1b50
--- /dev/null
+++ b/gtk3-port.patch
@@ -0,0 +1,49 @@
+diff -Naur npapi-vlc.orig/configure.ac npapi-vlc/configure.ac
+--- npapi-vlc.orig/configure.ac 2017-02-19 21:44:15.033366000 +0100
++++ npapi-vlc/configure.ac 2017-02-19 23:35:06.944545510 +0100
+@@ -266,7 +266,7 @@
+ ])
+ AS_IF([ test "x$with_gtk" != "xno" ],
+ [
+- PKG_CHECK_MODULES(GTK, [gtk+-2.0], [gtk_found=yes])
++ PKG_CHECK_MODULES(GTK, [gtk+-3.0], [gtk_found=yes])
+ ])
+ ])
+ AS_IF([ test "x$gtk_found" = "xyes" ],
+diff -Naur npapi-vlc.orig/npapi/Makefile.am npapi-vlc/npapi/Makefile.am
+--- npapi-vlc.orig/npapi/Makefile.am 2017-02-19 21:44:15.033366000 +0100
++++ npapi-vlc/npapi/Makefile.am 2017-02-19 23:34:52.350909959 +0100
+@@ -11,7 +11,7 @@
+ npapi-sdk/npruntime.h \
+ npapi-sdk/nptypes.h
+
+-npvlcdir = $(libdir)/mozilla/plugins
++npvlcdir = $(libdir)/epiphany/plugins
+
+ AM_CPPFLAGS = $(LIBVLC_CFLAGS) -Inpapi-sdk $(MOZILLA_CFLAGS) -I$(top_srcdir)/vlcpp
+
+diff -Naur npapi-vlc.orig/npapi/vlcplugin_gtk.cpp npapi-vlc/npapi/vlcplugin_gtk.cpp
+--- npapi-vlc.orig/npapi/vlcplugin_gtk.cpp 2017-02-19 21:44:15.040033000 +0100
++++ npapi-vlc/npapi/vlcplugin_gtk.cpp 2017-02-19 23:35:05.074506668 +0100
+@@ -32,8 +32,8 @@
+
+ static uint32_t get_xid(GtkWidget *widget)
+ {
+- GdkDrawable *video_drawable = gtk_widget_get_window(widget);
+- return (uint32_t)gdk_x11_drawable_get_xid(video_drawable);
++ GdkWindow *video_drawable = gtk_widget_get_window(widget);
++ return (uint32_t)gdk_x11_window_get_xid(video_drawable);
+ }
+
+ VlcPluginGtk::VlcPluginGtk(NPP instance, NPuint16_t mode) :
+diff -Naur npapi-vlc.orig/npapi/vlcplugin_gtk.h npapi-vlc/npapi/vlcplugin_gtk.h
+--- npapi-vlc.orig/npapi/vlcplugin_gtk.h 2017-02-19 21:44:15.040033000 +0100
++++ npapi-vlc/npapi/vlcplugin_gtk.h 2017-02-19 23:35:03.274469313 +0100
+@@ -27,6 +27,7 @@
+ #include "vlcplugin_base.h"
+
+ #include <gtk/gtk.h>
++#include <gtk/gtkx.h>
+ #include <mutex>
+ #include <X11/Xlib.h>
+