summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Rawlinson2022-05-05 02:16:22 +0000
committerGeorge Rawlinson2022-05-05 02:16:22 +0000
commit7a389c47ef5dd87f45e8675de59957b494c40bf4 (patch)
treeee871d0d91d510151c0c86d7d487841b504d5e4e
downloadaur-7a389c47ef5dd87f45e8675de59957b494c40bf4.tar.gz
addpkg: npt 1.1.1-1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD36
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..58f12b3f2560
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = npt
+ pkgdesc = ANSI Common Lisp implementation
+ pkgver = 1.1.1
+ pkgrel = 1
+ url = https://github.com/nptcl/npt
+ arch = x86_64
+ license = Unlicense
+ makedepends = git
+ depends = glibc
+ source = npt::git+https://github.com/nptcl/npt#commit=55cff1db7e6f12f7e87e8ab26393792d33734d62
+ b2sums = SKIP
+
+pkgname = npt
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9e2848ee4b10
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: George Rawlinson <grawlinson@archlinux.org>
+
+pkgname=npt
+pkgver=1.1.1
+pkgrel=1
+pkgdesc='ANSI Common Lisp implementation'
+arch=('x86_64')
+url='https://github.com/nptcl/npt'
+license=('Unlicense')
+depends=('glibc')
+makedepends=('git')
+_commit='55cff1db7e6f12f7e87e8ab26393792d33734d62'
+source=("$pkgname::git+$url#commit=$_commit")
+b2sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+
+ git describe --tags | sed 's/^v//'
+}
+
+build() {
+ cd "$pkgname"
+
+ ./bootstrap.sh
+
+ ./configure --prefix=/usr
+
+ make
+}
+
+package() {
+ cd "$pkgname"
+
+ make install DESTDIR="$pkgdir"
+}