summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn ShaggyTwoDope Jenkins2015-07-08 01:16:17 -0700
committerJohn ShaggyTwoDope Jenkins2015-07-08 01:16:17 -0700
commitc811e8b50e100aa9df31a8ddb00bb0df94684a27 (patch)
treeb3b3bc6f41671395e4fc1fa74c4e354c6ea9774a
downloadaur-c811e8b50e100aa9df31a8ddb00bb0df94684a27.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7cdab3b7e7eb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = npyscreen-git
+ pkgdesc = A python widget library and application framework
+ pkgver = r480.d286599
+ pkgrel = 1
+ url = https://github.com/npcole/npyscreen
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = python
+ depends = python-setuptools
+ conflicts = python-npyscreen
+ source = git+https://github.com/npcole/npyscreen.git
+ sha256sums = SKIP
+
+pkgname = npyscreen-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d67cfaff9219
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: John Jenkins twodopeshaggy@gmail.com
+
+pkgname=npyscreen-git
+pkgver=r480.d286599
+pkgrel=1
+pkgdesc="A python widget library and application framework"
+arch=('any')
+url="https://github.com/npcole/npyscreen"
+license=('GPL3')
+makedepends=('git')
+conflicts=('python-npyscreen')
+depends=('python' 'python-setuptools')
+source=('git+https://github.com/npcole/npyscreen.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/npyscreen"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/npyscreen"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}