summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn ShaggyTwoDope Jenkins2015-08-27 12:28:22 -0700
committerJohn ShaggyTwoDope Jenkins2015-08-27 12:28:22 -0700
commit9cc8454f2dbb34aa4cc5a810b54df4d0f9b2e730 (patch)
tree4b931a254e785af2a921e208214487644493f496
downloadaur-9cc8454f2dbb34aa4cc5a810b54df4d0f9b2e730.tar.gz
init commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3a43eb3c500d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = nq-git
+ pkgdesc = Unix command line queue utility
+ pkgver = r68.0eae839
+ pkgrel = 1
+ url = https://github.com/chneukirchen/nq
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = make
+ source = nq-git::git+https://github.com/chneukirchen/nq.git
+ md5sums = SKIP
+
+pkgname = nq-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fec2e63281e2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: John "ShaggyTwoDope" Jenkins <twodopeshaggy at gmail dot com>
+pkgname=nq-git
+pkgver=r68.0eae839
+pkgrel=1
+pkgdesc="Unix command line queue utility"
+arch=('i686' 'x86_64')
+url="https://github.com/chneukirchen/nq"
+license=('GPL')
+makedepends=('make')
+
+source=("${pkgname}::git+https://github.com/chneukirchen/nq.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ make all
+}
+
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir/" install
+}
+