summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLennard Fleischer2015-11-23 16:21:19 +0100
committerLennard Fleischer2015-11-23 16:21:19 +0100
commitab7ce74b39ff171d279cea3277a1c870eacb1494 (patch)
treea169bbc549ce8e9138f7d26a5abfc68b15833dfe
downloadaur-ab7ce74b39ff171d279cea3277a1c870eacb1494.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD31
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..19fa535d4245
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = nqc
+ pkgdesc = Not Quite C is a simple language with a C-like syntax that can be used to program Lego's RCX programmable brick (from the Mindstorms set).
+ pkgver = 3.1.r6
+ pkgrel = 1
+ url = http://bricxcc.sourceforge.net/nqc/
+ arch = i686
+ arch = x86_64
+ license = custom:MPL
+ source = http://bricxcc.sourceforge.net/nqc/${pkgname}-${pkgver}.tgz
+ md5sums = 2ed4b2728ab6f0d21723a466996ce91b
+
+pkgname = nqc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..771621f95329
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Christian Hesse <arch@eworm.de>
+# Contributor: speps <speps at aur dot archlinux dot org>
+
+pkgname=nqc
+pkgver=3.1.r6
+pkgrel=1
+pkgdesc="Not Quite C is a simple language with a C-like syntax that can be used to program Lego's RCX programmable brick (from the Mindstorms set)."
+arch=('i686' 'x86_64')
+url='http://bricxcc.sourceforge.net/nqc/'
+license=('custom:MPL')
+dependends=('gcc' 'glibc')
+source=('http://bricxcc.sourceforge.net/nqc/${pkgname}-${pkgver}.tgz')
+md5sums=('2ed4b2728ab6f0d21723a466996ce91b')
+
+build() {
+
+ rm -f compiler/parse.cpp compiler/parse.tab.h
+ rm -f compiler/lexer.cpp
+ rm -f bin/*
+ rm -f */*.o
+ rm -f compiler/rcx1_nqh.h compiler/rcx2_nqh.h
+ rm -f rcxlib/rcxnub.h
+ make
+
+}
+
+package() {
+ mkdir -p ${pkgdir}/usr/bin/
+ cp -r bin/* ${pkgdir}/usr/bin/
+}
+