summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeonid Gnezdilov2016-06-23 14:40:00 +0300
committerLeonid Gnezdilov2016-06-23 14:40:00 +0300
commit4b3b5bd983020f02407bb8598139bbe9912d8a64 (patch)
tree1735552bee8f5714e1ab7f0dddd9d8df77f3a7d2
downloadaur-4b3b5bd983020f02407bb8598139bbe9912d8a64.tar.gz
New version
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD53
-rw-r--r--nrclient.install3
-rw-r--r--nrclient.service12
4 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8cc8e0670941
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by mksrcinfo v8
+# Thu Jun 23 11:35:35 UTC 2016
+pkgbase = nrclient2-free
+ pkgdesc = NeoRouter is a cross-platform zero-configuration VPN solution
+ pkgver = 2.3.1.4360
+ pkgrel = 1
+ url = http://www.neorouter.com/
+ install = nrclient.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = rpmextract
+ provides = nrclient
+ provides = nrclient-free
+ provides = nrclient2-free
+ conflicts = nrclient
+ conflicts = nrclient-free
+ options = !strip
+ source = http://download.neorouter.com/Downloads/NRFree/Update_2.3.1.4360/Linux/CentOS/nrclient-2.3.1.4360-free-centos-i386.rpm
+ source = nrclient.service
+ md5sums = 81b4c36a9c1178086f59bf5d62b4527c
+ md5sums = 051c0ba7598249e035368f8ecb6ea44d
+
+pkgname = nrclient2-free
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..523d23b5297c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Contributor: leonid <comdir@infonix.info>
+pkgname=nrclient2-free
+pkgver=2.3.1.4360
+pkgrel=1
+pkgdesc="NeoRouter is a cross-platform zero-configuration VPN solution"
+url="http://www.neorouter.com/"
+license=('custom')
+arch=('i686' 'x86_64')
+conflicts=('nrclient' 'nrclient-free')
+provides=('nrclient' 'nrclient-free' 'nrclient2-free')
+options=('!strip')
+depends=()
+makedepends=('rpmextract')
+install=nrclient.install
+source=('http://download.neorouter.com/Downloads/NRFree/Update_2.3.1.4360/Linux/CentOS/nrclient-2.3.1.4360-free-centos-i386.rpm' 'nrclient.service')
+md5sums=('81b4c36a9c1178086f59bf5d62b4527c'
+'051c0ba7598249e035368f8ecb6ea44d')
+if test "$CARCH" == x86_64; then
+source=('http://download.neorouter.com/Downloads/NRFree/Update_2.3.1.4360/Linux/CentOS/nrclient-2.3.1.4360-free-centos-x86_64.rpm' 'nrclient.service')
+md5sums=('736946473cc4038e3a8b2274012f483e'
+'051c0ba7598249e035368f8ecb6ea44d')
+fi
+
+build() {
+case ${CARCH} in
+i686)
+cd $srcdir/
+rpmextract.sh $startdir/src/nrclient-2.3.1.4360-free-centos-i386.rpm
+rm $startdir/src/nrclient-2.3.1.4360-free-centos-i386.rpm
+;;
+x86_64)
+cd $srcdir/
+rpmextract.sh $startdir/src/nrclient-2.3.1.4360-free-centos-x86_64.rpm
+rm $startdir/src/nrclient-2.3.1.4360-free-centos-x86_64.rpm
+;;
+esac
+}
+
+package() {
+cd $srcdir/
+
+msg2 "Installing bin files..."
+mkdir -p "$pkgdir/usr/bin"
+cp usr/bin/* "$pkgdir/usr/bin"
+
+msg2 "Installing readme files..."
+mkdir -p "$pkgdir/usr/local/ZebraNetworkSystems/NeoRouter/"
+cp usr/local/ZebraNetworkSystems/NeoRouter/* "$pkgdir/usr/local/ZebraNetworkSystems/NeoRouter/"
+
+msg2 "Installing systemd service..."
+mkdir -p "$pkgdir/usr/lib/systemd/system"
+cp $startdir/nrclient.service "$pkgdir/usr/lib/systemd/system"
+} \ No newline at end of file
diff --git a/nrclient.install b/nrclient.install
new file mode 100644
index 000000000000..80a4aebd7101
--- /dev/null
+++ b/nrclient.install
@@ -0,0 +1,3 @@
+post_install() {
+ echo ">>>--------------"
+}
diff --git a/nrclient.service b/nrclient.service
new file mode 100644
index 000000000000..18d6d3e48aae
--- /dev/null
+++ b/nrclient.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=NeoRouter Client
+After=network.target
+
+[Service]
+Type=simple
+WorkingDirectory=/usr/local/ZebraNetworkSystems/NeoRouter
+ExecStart=/usr/bin/nrservice
+Restart=always
+
+[Install]
+WantedBy=multi-user.target