summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkumen2019-10-31 20:17:38 +0100
committerkumen2019-10-31 20:17:38 +0100
commit9dcd4b56d75b4f6970c89f146006c8b18e118b7a (patch)
treeb6f92bdef242ce74babe012c4a1fe6e383f4961f
downloadaur-9dcd4b56d75b4f6970c89f146006c8b18e118b7a.tar.gz
Initial commit of version 3.2.0
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD49
-rw-r--r--nrfconnect-appimage.desktop12
4 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..86dda29fc2a3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = nrfconnect-appimage
+ pkgdesc = Cross-platform development software for Bluetooth Low Energy and cIoT
+ pkgver = 3.2.0
+ pkgrel = 1
+ url = https://www.nordicsemi.com/Software-and-Tools/Development-Tools/nRF-Connect-for-desktop/
+ arch = x86_64
+ license = Commercial
+ optdepends = jlink-software-and-documentation
+ options = !strip
+ source = https://www.nordicsemi.com/-/media/Software-and-other-downloads/Desktop-software/nRF-Connect-for-Desktop/3-2-0/nrfconnect320x8664.AppImage
+ source = nrfconnect-appimage.desktop
+ sha256sums = f7ab05dca3b57a75c388010308f9a5fff7aeb0978d752ebe8ad1d5222e94b5f1
+ sha256sums = b8ef1267458c372e430c33ae2e1b141418e31cb41fd727cc2a44ed055ccfe7d3
+
+pkgname = nrfconnect-appimage
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8bcbbe1057b4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+
+*.zip
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..65cee6b5bf59
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: kumen
+pkgname="nrfconnect-appimage"
+pkgver=3.2.0
+pkgrel=1
+pkgdesc="Cross-platform development software for Bluetooth Low Energy and cIoT"
+arch=("x86_64")
+depends=()
+optdepends=('jlink-software-and-documentation')
+conflicts=()
+url="https://www.nordicsemi.com/Software-and-Tools/Development-Tools/nRF-Connect-for-desktop/"
+license=('Commercial')
+options=(!strip)
+
+_file_name="nrfconnect320x8664.AppImage"
+
+
+source=("https://www.nordicsemi.com/-/media/Software-and-other-downloads/Desktop-software/nRF-Connect-for-Desktop/3-2-0/${_file_name}"
+ $pkgname.desktop)
+sha256sums=('f7ab05dca3b57a75c388010308f9a5fff7aeb0978d752ebe8ad1d5222e94b5f1'
+ 'b8ef1267458c372e430c33ae2e1b141418e31cb41fd727cc2a44ed055ccfe7d3')
+
+prepare(){
+ # mark as executable
+ chmod +x "${srcdir}/${_file_name}"
+
+ # extract
+ ${srcdir}/${_file_name} --appimage-extract
+}
+
+package() {
+ # install the main files.
+ install -d -m755 "${pkgdir}/opt/${pkgname}"
+ cp -Rr "${srcdir}/squashfs-root/"* "${pkgdir}/opt/${pkgname}"
+
+ msg2 'Installing desktop shortcuts'
+ install -Dm644 "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+
+ # fix file permissions - all files as 644 - directories as 755
+ find "${pkgdir}/"{opt,usr} -type d -exec chmod 755 {} \;
+ find "${pkgdir}/"{opt,usr} -type f -exec chmod 644 {} \;
+
+ chmod +x "${pkgdir}/opt/${pkgname}/nrfconnect"
+ install -d -m755 "${pkgdir}/usr/bin"
+ ln -sr "${pkgdir}/opt/${pkgname}/nrfconnect" "${pkgdir}/usr/bin/nrfconnect"
+}
+
+#
+# makepkg --printsrcinfo > .SRCINFO
+#
diff --git a/nrfconnect-appimage.desktop b/nrfconnect-appimage.desktop
new file mode 100644
index 000000000000..8a34bab8d864
--- /dev/null
+++ b/nrfconnect-appimage.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Name=nRF Connect
+Comment=nRF Connect for PC 3.2.0
+GenericName=nRF Connect
+Exec=/opt/nrfconnect-appimage/nrfconnect %F
+Icon=/opt/nrfconnect-appimage/usr/share/icons/hicolor/0x0/apps/nrfconnect.png
+Path=/opt/nrfconnect-appimage/
+Terminal=false
+Type=Application
+StartupWMClass=nRF Connect
+StartupNotify=true
+Categories=Development