summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergej Pupykin2017-10-03 11:27:14 +0300
committerFranck Duriez2019-09-13 13:37:15 +0200
commiteb27a0bb622260b97c0333f0ea7f6098f502781f (patch)
treed5b62e785d14a62c8b79c33fecc2dee8a12559e6
downloadaur-eb27a0bb622260b97c0333f0ea7f6098f502781f.tar.gz
init
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e6588cc7fbaa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = nrfutil
+ pkgdesc = nrfutil command line utility and the nordicsemi library
+ pkgver = 5.2.0
+ pkgrel = 1
+ url = https://github.com/NordicSemiconductor/pc-nrfutil
+ arch = any
+ license = MIT
+ depends = python2
+ options = !emptydirs
+ source = nrfutil-5.2.0.tar.gz::https://github.com/NordicSemiconductor/pc-nrfutil/archive/v5.2.0.tar.gz
+ sha256sums = SKIP
+
+pkgname = nrfutil
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f373a5252aa1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Franck Lucien Duriez <franck.lucien.duriez@gmail.com>
+
+pkgname=nrfutil
+pkgver=5.2.0
+pkgrel=1
+pkgdesc="nrfutil command line utility and the nordicsemi library"
+arch=('any')
+url="https://github.com/NordicSemiconductor/pc-nrfutil"
+license=('MIT')
+depends=('python2')
+options=(!emptydirs)
+source=("$pkgname-$pkgver.tar.gz::https://github.com/NordicSemiconductor/pc-nrfutil/archive/v$pkgver.tar.gz")
+sha256sums=(SKIP)
+
+build() {
+ cd "$srcdir/pc-$pkgname-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/pc-$pkgname-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}