summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergio Correia2016-08-03 10:36:18 -0400
committerSergio Correia2016-08-03 10:36:49 -0400
commit6c64b6551a6d66e35905dd7214da91b2d4948f86 (patch)
treed5e2b102f595723a9c3a70575c6a0dbab9017501
parent0a5110ff5c122eb42f46dc2ba1551ad0e427530b (diff)
downloadaur-6c64b6551a6d66e35905dd7214da91b2d4948f86.tar.gz
Update gcc compile fix
Use unsigned for the array, instead of casting. Bump to 2.35-7.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rw-r--r--ns-2.35-gcc-compile-errors.patch56
3 files changed, 44 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 881bb67cb61e..025567ede5a9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by makepkg 5.0.1
+# Wed Aug 3 14:35:31 UTC 2016
pkgbase = ns
pkgdesc = Discrete event simulator targeted at networking research
pkgver = 2.35
- pkgrel = 6
+ pkgrel = 7
url = http://www.isi.edu/nsnam/ns/
arch = i686
arch = x86_64
@@ -20,7 +22,7 @@ pkgbase = ns
sha256sums = aedba646d1bc4d716031f9ea996e6d99c9bb227e7647138cccf39bdd6c069c3a
sha256sums = 7aa4a22492f2be37c81fcdc813972a6bde105e183a013d7b814a56f7bcef872c
sha256sums = 4d02ff0cf1c79d67c440c788d7163c7c873a6e4e2970bab3319cbe29f9b20c14
- sha256sums = efbbe60f2be7f3daf28eec60437d6d2fc24e8b934e24d6b4b35cbc5a270f88c0
+ sha256sums = d3a6e6bcc22ca9aa8f8901774eb58a4df3f2f4d6856a260561568a5a6d9f600e
pkgname = ns
diff --git a/PKGBUILD b/PKGBUILD
index 80f23ed82f4d..3cd7307f9b2e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=ns
pkgver=2.35
-pkgrel=6
+pkgrel=7
pkgdesc="Discrete event simulator targeted at networking research"
url="http://www.isi.edu/nsnam/ns/"
license=('GPL')
@@ -20,7 +20,7 @@ sha256sums=('2a32e831bcec7d255042a544577559d15eae67696d0e3d30881cedc1112e2387'
'aedba646d1bc4d716031f9ea996e6d99c9bb227e7647138cccf39bdd6c069c3a'
'7aa4a22492f2be37c81fcdc813972a6bde105e183a013d7b814a56f7bcef872c'
'4d02ff0cf1c79d67c440c788d7163c7c873a6e4e2970bab3319cbe29f9b20c14'
- 'efbbe60f2be7f3daf28eec60437d6d2fc24e8b934e24d6b4b35cbc5a270f88c0')
+ 'd3a6e6bcc22ca9aa8f8901774eb58a4df3f2f4d6856a260561568a5a6d9f600e')
optdepends=('nam: Tcl/TK based animation tool for viewing network simulation traces',
'xgraph: X-Windows application for interactive plotting and graphing')
diff --git a/ns-2.35-gcc-compile-errors.patch b/ns-2.35-gcc-compile-errors.patch
index 8ba3785621bf..489f6e4a4b3c 100644
--- a/ns-2.35-gcc-compile-errors.patch
+++ b/ns-2.35-gcc-compile-errors.patch
@@ -1,27 +1,47 @@
-commit 17cab371bcd9bb08c7ffd0f2a4d3b7efafa5ab6b
-Author: Sergio Correia <sergio@correia.cc>
-Date: Tue Jun 28 15:16:04 2016 -0400
-
- Fix the following compile errors in a modern gcc:
-
- - error: reference to ‘hash’ is ambiguous
- > use the global namespace `::', as `::hash'
-
- - narrowing conversion of ‘252’ from ‘int’ to ‘char’ inside { }
- > use a static_cast to convert to `char'
-
+diff --git a/bitmap/ff.xbm b/bitmap/ff.xbm
+index 05579fe..00d6d95 100644
+--- a/bitmap/ff.xbm
++++ b/bitmap/ff.xbm
+@@ -1,5 +1,5 @@
+ #define ff_width 15
+ #define ff_height 12
+-static char ff_bits[] = {
++static unsigned char ff_bits[] = {
+ 0x00, 0x00, 0x04, 0x01, 0x0c, 0x03, 0x1c, 0x07, 0x3c, 0x0f, 0x7c, 0x1f,
+ 0x7c, 0x1f, 0x3c, 0x0f, 0x1c, 0x07, 0x0c, 0x03, 0x04, 0x01, 0x00, 0x00};
diff --git a/bitmap/play.xbm b/bitmap/play.xbm
-index 4d63679..0bda522 100644
+index 4d63679..ea21a06 100644
--- a/bitmap/play.xbm
+++ b/bitmap/play.xbm
@@ -1,5 +1,5 @@
#define play_width 15
#define play_height 12
- static char play_bits[] = {
-- 0x00, 0x00, 0x0c, 0x00, 0x3c, 0x00, 0xfc, 0x00, 0xfc, 0x03, 0xfc, 0x0f,
-- 0xfc, 0x0f, 0xfc, 0x03, 0xfc, 0x00, 0x3c, 0x00, 0x0c, 0x00, 0x00, 0x00};
-+ 0x00, 0x00, 0x0c, 0x00, 0x3c, 0x00, static_cast<char>(0xfc), 0x00, static_cast<char>(0xfc), 0x03, static_cast<char>(0xfc), 0x0f,
-+ static_cast<char>(0xfc), 0x0f, static_cast<char>(0xfc), 0x03, static_cast<char>(0xfc), 0x00, 0x3c, 0x00, 0x0c, 0x00, 0x00, 0x00};
+-static char play_bits[] = {
++static unsigned char play_bits[] = {
+ 0x00, 0x00, 0x0c, 0x00, 0x3c, 0x00, 0xfc, 0x00, 0xfc, 0x03, 0xfc, 0x0f,
+ 0xfc, 0x0f, 0xfc, 0x03, 0xfc, 0x00, 0x3c, 0x00, 0x0c, 0x00, 0x00, 0x00};
+diff --git a/bitmap/rewind.xbm b/bitmap/rewind.xbm
+index 929e7a0..d466abf 100644
+--- a/bitmap/rewind.xbm
++++ b/bitmap/rewind.xbm
+@@ -1,5 +1,5 @@
+ #define rewind_width 15
+ #define rewind_height 12
+-static char rewind_bits[] = {
++static unsigned char rewind_bits[] = {
+ 0x00, 0x00, 0x40, 0x10, 0x60, 0x18, 0x70, 0x1c, 0x78, 0x1e, 0x7c, 0x1f,
+ 0x7c, 0x1f, 0x78, 0x1e, 0x70, 0x1c, 0x60, 0x18, 0x40, 0x10, 0x00, 0x00};
+diff --git a/bitmap/stop.xbm b/bitmap/stop.xbm
+index 01ba707..56150c7 100644
+--- a/bitmap/stop.xbm
++++ b/bitmap/stop.xbm
+@@ -1,5 +1,5 @@
+ #define stop_width 14
+ #define stop_height 12
+-static char stop_bits[] = {
++static unsigned char stop_bits[] = {
+ 0x00, 0x00, 0x38, 0x07, 0x38, 0x07, 0x38, 0x07, 0x38, 0x07, 0x38, 0x07,
+ 0x38, 0x07, 0x38, 0x07, 0x38, 0x07, 0x38, 0x07, 0x38, 0x07, 0x00, 0x00};
diff --git a/mdart/mdart_adp.cc b/mdart/mdart_adp.cc
index a96346e..6bb9225 100644
--- a/mdart/mdart_adp.cc