summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCharles Duffy2016-03-12 23:14:51 -0600
committerCharles Duffy2016-03-12 23:14:51 -0600
commit4e2fd3526f6ca66c9a76162867511e7d8428a619 (patch)
treef6c9d61cd388d07885927010aef13285c8a71def
downloadaur-4e2fd3526f6ca66c9a76162867511e7d8428a619.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b4c949ad28ac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by makepkg 5.0.0
+# Sun Mar 13 05:14:43 UTC 2016
+pkgbase = ns-exec-tools
+ pkgdesc = Lightweight, execline-style tools to build restricted Linux namespaces
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/charles-dyfis-net/ns-exec-tools
+ arch = any
+ license = ISC
+ depends = lxc
+ depends = util-linux
+ conflicts = ns-exec-tools-git
+ source = ns-exec-tools::git+https://github.com/charles-dyfis-net/ns-exec-tools#tag=0.0.1
+ sha1sums = SKIP
+
+pkgname = ns-exec-tools
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ed2a0854c867
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Charles Duffy <charles@dyfis.net>
+pkgname=ns-exec-tools
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="Lightweight, execline-style tools to build restricted Linux namespaces"
+arch=( any )
+url="https://github.com/charles-dyfis-net/ns-exec-tools"
+license=( ISC )
+depends=( lxc util-linux )
+conflicts=( "${pkgname}-git" )
+source=( "ns-exec-tools::git+https://github.com/charles-dyfis-net/ns-exec-tools#tag=$pkgver" )
+sha1sums=( SKIP )
+
+build() { :; }
+
+package() {
+ cd "${pkgname%-git}"
+ mkdir -p \
+ "$pkgdir/usr/share/doc/$pkgname" \
+ "$pkgdir/usr/share/licenses/$pkgname" \
+ "$pkgdir/usr/bin"
+ cp README.md "$pkgdir/usr/share/doc/$pkgname/"
+ cp LICENSE "$pkgdir/usr/share/licenses/$pkgname/"
+ cp [[:lower:]]* "$pkgdir/usr/bin/"
+}