summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2016-03-29 20:30:45 +0200
committerMichel Zou2016-03-29 20:30:45 +0200
commit222501c5f531b943e7fb224c30c64bbc43f4e44a (patch)
tree4526b407adf4d0f3f12983b7da4a28d52874bbb0
parent18fc2e136f43119ee30efaeebfab6d20ce8c3462 (diff)
downloadaur-222501c5f531b943e7fb224c30c64bbc43f4e44a.tar.gz
add patch from rhel bugzilla #948074
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
-rw-r--r--nsis-948074.patch29
3 files changed, 41 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a24bf1b80de7..28e18cb208ac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Feb 4 17:40:51 UTC 2016
+# Tue Mar 29 18:30:45 UTC 2016
pkgbase = nsis
pkgdesc = A professional open source system to create Windows installers
pkgver = 2.50
- pkgrel = 1
+ pkgrel = 2
url = http://nsis.sourceforge.net
arch = i686
arch = x86_64
@@ -18,12 +18,14 @@ pkgbase = nsis
source = nsis-2.46-missing-unistd-include.patch
source = nsis-2.46-static-libstdc++.patch
source = nsis-add-mingw-w64-support.patch
+ source = nsis-948074.patch
md5sums = 076850a971589a787d30224bfde936aa
md5sums = 9eead3b78da54e3afda8f6a5b663aea9
md5sums = 28f1002dd3c6a57cd3e1f8bb09c81fc5
md5sums = c4f912f0ca7fa455948f9f6a73314d93
md5sums = 3d41bf574cd3bed0c4f14afca9bc4819
md5sums = d72c910fa1e9b8372fadf1ba905139ab
+ md5sums = 9b94bfb75b4dcfd3872c7fa2573d2ee5
pkgname = nsis
diff --git a/PKGBUILD b/PKGBUILD
index 280f73658f04..3ae493e1f739 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=nsis
pkgver=2.50
-pkgrel=1
+pkgrel=2
pkgdesc='A professional open source system to create Windows installers'
arch=('i686' 'x86_64')
url='http://nsis.sourceforge.net'
@@ -16,13 +16,15 @@ source=(http://downloads.sourceforge.net/project/nsis/NSIS%202/$pkgver/$pkgname-
nsis-2.45-static-libgcc.patch
nsis-2.46-missing-unistd-include.patch
nsis-2.46-static-libstdc++.patch
- nsis-add-mingw-w64-support.patch)
+ nsis-add-mingw-w64-support.patch
+ nsis-948074.patch)
md5sums=('076850a971589a787d30224bfde936aa'
'9eead3b78da54e3afda8f6a5b663aea9'
'28f1002dd3c6a57cd3e1f8bb09c81fc5'
'c4f912f0ca7fa455948f9f6a73314d93'
'3d41bf574cd3bed0c4f14afca9bc4819'
- 'd72c910fa1e9b8372fadf1ba905139ab')
+ 'd72c910fa1e9b8372fadf1ba905139ab'
+ '9b94bfb75b4dcfd3872c7fa2573d2ee5')
prepare() {
cd "$srcdir/$pkgname-$pkgver-src"
@@ -32,6 +34,9 @@ prepare() {
patch -p1 -i "$srcdir/nsis-2.46-missing-unistd-include.patch"
patch -p1 -i "$srcdir/nsis-2.46-static-libstdc++.patch"
patch -p1 -i "$srcdir/nsis-add-mingw-w64-support.patch"
+
+ # https://bugzilla.redhat.com/show_bug.cgi?id=948074
+ patch -p1 -i "$srcdir/nsis-948074.patch"
}
build() {
diff --git a/nsis-948074.patch b/nsis-948074.patch
new file mode 100644
index 000000000000..fc91f539494d
--- /dev/null
+++ b/nsis-948074.patch
@@ -0,0 +1,29 @@
+--- a/Source/ResourceEditor.h.64bit 2009-02-01 09:44:30.000000000 -0500
++++ b/Source/ResourceEditor.h 2014-07-23 17:12:20.000000000 -0400
+@@ -180,7 +180,7 @@
+
+ void Destroy();
+
+- DWORD m_dwWrittenAt;
++ long m_dwWrittenAt;
+
+ private:
+ IMAGE_RESOURCE_DIRECTORY m_rdDir;
+@@ -204,7 +204,7 @@
+
+ CResourceDataEntry* GetDataEntry();
+
+- DWORD m_dwWrittenAt;
++ long m_dwWrittenAt;
+
+ private:
+ bool m_bHasName;
+@@ -232,7 +232,7 @@
+ DWORD GetCodePage();
+ DWORD GetOffset();
+
+- DWORD m_dwWrittenAt;
++ long m_dwWrittenAt;
+
+ private:
+ BYTE* m_pbData;