summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2016-10-22 16:40:25 +0200
committerMichel Zou2016-10-22 16:40:25 +0200
commit614d4b9630313cd7c7b35e13056f7d59b25941f0 (patch)
tree636a23dea02cdfb9a78a52c46f675f740d7c0a54
parent40a0354197d7236cb78f4e29c823a5ea74495518 (diff)
downloadaur-614d4b9630313cd7c7b35e13056f7d59b25941f0.tar.gz
3.0
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD37
-rw-r--r--nsis-2.43-64bit-fixes.patch211
-rw-r--r--nsis-2.45-static-libgcc.patch12
-rw-r--r--nsis-2.46-missing-unistd-include.patch11
-rw-r--r--nsis-2.46-static-libstdc++.patch11
-rw-r--r--nsis-948074.patch29
-rw-r--r--nsis-add-mingw-w64-support.patch64
8 files changed, 32 insertions, 363 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a1cda042e80..a73ae3172fc6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Jul 13 21:23:12 UTC 2016
+# Sat Oct 22 14:40:25 UTC 2016
pkgbase = nsis
pkgdesc = A professional open source system to create Windows installers
- pkgver = 2.51
+ pkgver = 3.0
pkgrel = 1
url = http://nsis.sourceforge.net
arch = i686
@@ -12,20 +12,10 @@ pkgbase = nsis
makedepends = mingw-w64-gcc
depends = gcc-libs
options = !strip
- source = http://downloads.sourceforge.net/project/nsis/NSIS%202/2.51/nsis-2.51-src.tar.bz2
- source = nsis-2.43-64bit-fixes.patch
- source = nsis-2.45-static-libgcc.patch
- source = nsis-2.46-missing-unistd-include.patch
- source = nsis-2.46-static-libstdc++.patch
+ source = http://downloads.sourceforge.net/project/nsis/NSIS%203/3.0/nsis-3.0-src.tar.bz2
source = nsis-add-mingw-w64-support.patch
- source = nsis-948074.patch
- md5sums = 002538226a72a38ba1abb0d5d4ffdc45
- md5sums = 9eead3b78da54e3afda8f6a5b663aea9
- md5sums = 28f1002dd3c6a57cd3e1f8bb09c81fc5
- md5sums = c4f912f0ca7fa455948f9f6a73314d93
- md5sums = 3d41bf574cd3bed0c4f14afca9bc4819
- md5sums = d72c910fa1e9b8372fadf1ba905139ab
- md5sums = 9b94bfb75b4dcfd3872c7fa2573d2ee5
+ md5sums = 23d2e0f58e7ea3b2df2c16791896a6f1
+ md5sums = 39c4d9f24fd18b999c2a487e2bbcb788
pkgname = nsis
diff --git a/PKGBUILD b/PKGBUILD
index bd18fcff2ddd..b7c4cf22e591 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Andre Klitzing <andre () incubo () de>
pkgname=nsis
-pkgver=2.51
+pkgver=3.0
pkgrel=1
pkgdesc='A professional open source system to create Windows installers'
arch=('i686' 'x86_64')
@@ -11,44 +11,25 @@ license=('custom:zlib')
depends=('gcc-libs')
makedepends=('scons' 'mingw-w64-gcc')
options=(!strip)
-source=(http://downloads.sourceforge.net/project/nsis/NSIS%202/$pkgver/$pkgname-$pkgver-src.tar.bz2
- nsis-2.43-64bit-fixes.patch
- nsis-2.45-static-libgcc.patch
- nsis-2.46-missing-unistd-include.patch
- nsis-2.46-static-libstdc++.patch
- nsis-add-mingw-w64-support.patch
- nsis-948074.patch)
-md5sums=('002538226a72a38ba1abb0d5d4ffdc45'
- '9eead3b78da54e3afda8f6a5b663aea9'
- '28f1002dd3c6a57cd3e1f8bb09c81fc5'
- 'c4f912f0ca7fa455948f9f6a73314d93'
- '3d41bf574cd3bed0c4f14afca9bc4819'
- 'd72c910fa1e9b8372fadf1ba905139ab'
- '9b94bfb75b4dcfd3872c7fa2573d2ee5')
+source=(http://downloads.sourceforge.net/project/nsis/NSIS%203/$pkgver/$pkgname-$pkgver-src.tar.bz2
+ nsis-add-mingw-w64-support.patch)
+md5sums=('23d2e0f58e7ea3b2df2c16791896a6f1'
+ '39c4d9f24fd18b999c2a487e2bbcb788')
prepare() {
cd "$srcdir/$pkgname-$pkgver-src"
- # http://pkgs.fedoraproject.org/cgit/mingw-nsis.git/tree/
- patch -p1 -i "$srcdir/nsis-2.43-64bit-fixes.patch"
- patch -p1 -i "$srcdir/nsis-2.45-static-libgcc.patch"
- patch -p1 -i "$srcdir/nsis-2.46-missing-unistd-include.patch"
- patch -p1 -i "$srcdir/nsis-2.46-static-libstdc++.patch"
- patch -p1 -i "$srcdir/nsis-add-mingw-w64-support.patch"
-
- # https://bugzilla.redhat.com/show_bug.cgi?id=948074
- patch -p1 -i "$srcdir/nsis-948074.patch"
- # https://github.com/kichik/nsis/pull/4
- sed -i "s|__attribute__((__stdcall__))|\"__attribute__((__stdcall__))\"|g" SCons/Config/gnu
+ # https://github.com/kichik/nsis/commit/4677332
+ patch -p1 -i "$srcdir/nsis-add-mingw-w64-support.patch"
}
build() {
cd "$srcdir/$pkgname-$pkgver-src"
- scons VERSION=$pkgver PREFIX=/usr PREFIX_CONF=/etc SKIPUTILS='NSIS Menu' STRIP_CP=false
+ scons VERSION=$pkgver PREFIX=/usr PREFIX_CONF=/etc SKIPUTILS='NSIS Menu' STRIP_CP=false ZLIB_W32=/usr/i686-w64-mingw32/
}
package() {
cd "$srcdir/$pkgname-$pkgver-src"
- scons VERSION=$pkgver PREFIX=/usr PREFIX_CONF=/etc SKIPUTILS='NSIS Menu' STRIP_CP=false PREFIX_DEST="$pkgdir" install
+ scons VERSION=$pkgver PREFIX=/usr PREFIX_CONF=/etc SKIPUTILS='NSIS Menu' STRIP_CP=false ZLIB_W32=/usr/i686-w64-mingw32/ PREFIX_DEST="$pkgdir" install
install -Dm644 ${srcdir}/$pkgname-$pkgver-src/Docs/src/license.but "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
diff --git a/nsis-2.43-64bit-fixes.patch b/nsis-2.43-64bit-fixes.patch
deleted file mode 100644
index 342396d77210..000000000000
--- a/nsis-2.43-64bit-fixes.patch
+++ /dev/null
@@ -1,211 +0,0 @@
-diff -ur nsis-2.43-src/SCons/Config/gnu nsis-2.43-src-64bit-fixes/SCons/Config/gnu
---- nsis-2.43-src/SCons/Config/gnu 2009-02-05 01:52:28.000000000 +0100
-+++ nsis-2.43-src-64bit-fixes/SCons/Config/gnu 2009-02-25 07:59:44.000000000 +0100
-@@ -95,8 +95,6 @@
- makensis_env.Append(CXXFLAGS = ['-Wall']) # all warnings
-
- conf = FlagsConfigure(makensis_env)
--conf.CheckCompileFlag('-m32') #
--conf.CheckLinkFlag('-m32') #
- conf.CheckLinkFlag('$MAP_FLAG') # generate map file
- if not defenv['DEBUG'] and defenv['STRIP'] and defenv['STRIP_CP']:
- TestStrip(conf) # strip
-@@ -149,8 +147,6 @@
- ### cross-platform util environment adjustments
-
- conf = FlagsConfigure(cp_util_env)
--conf.CheckCompileFlag('-m32')
--conf.CheckLinkFlag('-m32')
- if not defenv['DEBUG'] and defenv['STRIP'] and defenv['STRIP_CP']:
- TestStrip(conf) # strip
- conf.Finish()
-@@ -160,8 +156,6 @@
- test_env = defenv.Clone()
- test_env.Append(CPPPATH = ['#$BUILD_CONFIG'])
- conf = FlagsConfigure(test_env)
--conf.CheckCompileFlag('-m32')
--conf.CheckLinkFlag('-m32')
- conf.Finish()
-
- ### weird GCC requirements
-diff -ur nsis-2.43-src/Source/DialogTemplate.cpp nsis-2.43-src-64bit-fixes/Source/DialogTemplate.cpp
---- nsis-2.43-src/Source/DialogTemplate.cpp 2007-11-30 10:54:13.000000000 +0100
-+++ nsis-2.43-src-64bit-fixes/Source/DialogTemplate.cpp 2009-02-25 07:59:44.000000000 +0100
-@@ -74,7 +74,7 @@
- if (IS_INTRESOURCE(x)) { \
- *(WORD*)seeker = 0xFFFF; \
- seeker += sizeof(WORD); \
-- *(WORD*)seeker = ConvertEndianness(WORD(DWORD(x))); \
-+ *(WORD*)seeker = ConvertEndianness(WORD(long(x))); \
- seeker += sizeof(WORD); \
- } \
- else { \
-@@ -622,7 +622,7 @@
- }
- }
-
-- assert((DWORD) seeker - (DWORD) pbDlg == dwSize);
-+ assert((long) seeker - (long) pbDlg == dwSize);
-
- // DONE!
- return pbDlg;
-diff -ur nsis-2.43-src/Source/mmap.cpp nsis-2.43-src-64bit-fixes/Source/mmap.cpp
---- nsis-2.43-src/Source/mmap.cpp 2009-02-01 15:44:30.000000000 +0100
-+++ nsis-2.43-src-64bit-fixes/Source/mmap.cpp 2009-02-25 07:59:44.000000000 +0100
-@@ -322,7 +322,7 @@
- if (!pView)
- return;
-
-- unsigned int alignment = ((unsigned int)pView) % m_iAllocationGranularity;
-+ unsigned int alignment = ((unsigned long)pView) % m_iAllocationGranularity;
- pView = (char *)pView - alignment;
- size += alignment;
- #ifdef _WIN32
-diff -ur nsis-2.43-src/Source/Platform.h nsis-2.43-src-64bit-fixes/Source/Platform.h
---- nsis-2.43-src/Source/Platform.h 2009-02-01 15:44:30.000000000 +0100
-+++ nsis-2.43-src-64bit-fixes/Source/Platform.h 2009-02-25 07:59:44.000000000 +0100
-@@ -166,7 +166,7 @@
- # define MAKEINTRESOURCE MAKEINTRESOURCEA
- # endif
- # ifndef IMAGE_FIRST_SECTION
--# define IMAGE_FIRST_SECTION(h) ( PIMAGE_SECTION_HEADER( (DWORD) h + \
-+# define IMAGE_FIRST_SECTION(h) ( PIMAGE_SECTION_HEADER( (long) h + \
- FIELD_OFFSET(IMAGE_NT_HEADERS, OptionalHeader) + \
- FIX_ENDIAN_INT16(PIMAGE_NT_HEADERS(h)->FileHeader.SizeOfOptionalHeader) ) )
- # endif
-@@ -198,7 +198,7 @@
- #endif
-
- #ifndef ULONG_PTR
--# define ULONG_PTR DWORD
-+# define ULONG_PTR ULONG
- #endif
-
- #ifndef IDC_HAND
-@@ -703,7 +703,7 @@
- WORD e_oemid;
- WORD e_oeminfo;
- WORD e_res2[10];
-- LONG e_lfanew;
-+ DWORD e_lfanew;
- } IMAGE_DOS_HEADER,*PIMAGE_DOS_HEADER;
- # pragma pack()
- # pragma pack(4)
-diff -ur nsis-2.43-src/Source/Plugins.cpp nsis-2.43-src-64bit-fixes/Source/Plugins.cpp
---- nsis-2.43-src/Source/Plugins.cpp 2009-02-01 15:44:30.000000000 +0100
-+++ nsis-2.43-src-64bit-fixes/Source/Plugins.cpp 2009-02-25 07:59:44.000000000 +0100
-@@ -136,7 +136,7 @@
- DWORD prd = FIX_ENDIAN_INT32(sections[i].PointerToRawData);
- PIMAGE_EXPORT_DIRECTORY exports = PIMAGE_EXPORT_DIRECTORY(&dlldata[0] + prd + ExportDirVA - va);
- DWORD na = FIX_ENDIAN_INT32(exports->AddressOfNames);
-- unsigned long *names = (unsigned long*)((unsigned long) exports + (char *) na - ExportDirVA);
-+ unsigned int *names = (unsigned int*)((unsigned long) exports + (char *) na - ExportDirVA);
- for (unsigned long j = 0; j < FIX_ENDIAN_INT32(exports->NumberOfNames); j++)
- {
- const string name = string((char*)exports + FIX_ENDIAN_INT32(names[j]) - ExportDirVA);
-diff -ur nsis-2.43-src/Source/ResourceEditor.cpp nsis-2.43-src-64bit-fixes/Source/ResourceEditor.cpp
---- nsis-2.43-src/Source/ResourceEditor.cpp 2009-02-05 01:50:12.000000000 +0100
-+++ nsis-2.43-src-64bit-fixes/Source/ResourceEditor.cpp 2009-02-25 07:59:44.000000000 +0100
-@@ -684,7 +684,7 @@
- rdDir.NumberOfIdEntries = ConvertEndianness(rdDir.NumberOfIdEntries);
-
- CopyMemory(seeker, &rdDir, sizeof(IMAGE_RESOURCE_DIRECTORY));
-- crd->m_dwWrittenAt = DWORD(seeker);
-+ crd->m_dwWrittenAt = long(seeker);
- seeker += sizeof(IMAGE_RESOURCE_DIRECTORY);
-
- for (int i = 0; i < crd->CountEntries(); i++) {
-@@ -705,7 +705,7 @@
- rDirE.UName.NameString.NameIsString = (crd->GetEntry(i)->HasName()) ? 1 : 0;
-
- CopyMemory(seeker, &rDirE, sizeof(MY_IMAGE_RESOURCE_DIRECTORY_ENTRY));
-- crd->GetEntry(i)->m_dwWrittenAt = DWORD(seeker);
-+ crd->GetEntry(i)->m_dwWrittenAt = long(seeker);
- seeker += sizeof(MY_IMAGE_RESOURCE_DIRECTORY_ENTRY);
- }
- qDirs.pop();
-@@ -721,7 +721,7 @@
- rDataE.Size = ConvertEndianness(cRDataE->GetSize());
-
- CopyMemory(seeker, &rDataE, sizeof(IMAGE_RESOURCE_DATA_ENTRY));
-- cRDataE->m_dwWrittenAt = DWORD(seeker);
-+ cRDataE->m_dwWrittenAt = long(seeker);
- seeker += sizeof(IMAGE_RESOURCE_DATA_ENTRY);
-
- qDataEntries.pop();
-@@ -733,7 +733,7 @@
- while (!qStrings.empty()) {
- CResourceDirectoryEntry* cRDirE = qStrings.front();
-
-- PMY_IMAGE_RESOURCE_DIRECTORY_ENTRY(cRDirE->m_dwWrittenAt)->UName.NameString.NameOffset = ConvertEndianness(DWORD(seeker) - DWORD(pbRsrcSec));
-+ PMY_IMAGE_RESOURCE_DIRECTORY_ENTRY(cRDirE->m_dwWrittenAt)->UName.NameString.NameOffset = ConvertEndianness(long(seeker) - long(pbRsrcSec));
-
- WCHAR* szName = cRDirE->GetName();
- WORD iLen = winchar_strlen(szName) + 1;
-@@ -764,7 +764,7 @@
- /*
- * Set all of the directory entries offsets.
- */
-- SetOffsets(m_cResDir, DWORD(pbRsrcSec));
-+ SetOffsets(m_cResDir, long(pbRsrcSec));
- }
-
- // Sets the offsets in directory entries
-@@ -887,7 +887,7 @@
- // Returns -1 if can not be found
- int CResourceDirectory::Find(WCHAR* szName) {
- if (IS_INTRESOURCE(szName))
-- return Find((WORD) (DWORD) szName);
-+ return Find((WORD) (long) szName);
- else
- if (szName[0] == '#')
- return Find(WORD(winchar_stoi(szName + 1)));
-@@ -965,7 +965,7 @@
- if (IS_INTRESOURCE(szName)) {
- m_bHasName = false;
- m_szName = 0;
-- m_wId = (WORD) (DWORD) szName;
-+ m_wId = (WORD) (long) szName;
- }
- else {
- m_bHasName = true;
-@@ -979,7 +979,7 @@
- if (IS_INTRESOURCE(szName)) {
- m_bHasName = false;
- m_szName = 0;
-- m_wId = (WORD) (DWORD) szName;
-+ m_wId = (WORD) (long) szName;
- }
- else {
- m_bHasName = true;
-diff -ur nsis-2.43-src/Source/util.cpp nsis-2.43-src-64bit-fixes/Source/util.cpp
---- nsis-2.43-src/Source/util.cpp 2009-02-01 15:44:30.000000000 +0100
-+++ nsis-2.43-src-64bit-fixes/Source/util.cpp 2009-02-25 07:59:44.000000000 +0100
-@@ -77,9 +77,9 @@
- }
-
- if (width != 0) {
-- LONG biWidth;
-+ DWORD biWidth;
- fseek(f, 18, SEEK_SET); // Seek to the width member of the header
-- fread(&biWidth, sizeof(LONG), 1, f);
-+ fread(&biWidth, sizeof(DWORD), 1, f);
- FIX_ENDIAN_INT32_INPLACE(biWidth);
- if (width != biWidth) {
- fclose(f);
-@@ -88,12 +88,12 @@
- }
-
- if (height != 0) {
-- LONG biHeight;
-+ DWORD biHeight;
- fseek(f, 22, SEEK_SET); // Seek to the height member of the header
-- fread(&biHeight, sizeof(LONG), 1, f);
-+ fread(&biHeight, sizeof(DWORD), 1, f);
- FIX_ENDIAN_INT32_INPLACE(biHeight);
- // Bitmap height can be negative too...
-- if (height != abs(biHeight)) {
-+ if (height != abs((long int)biHeight)) {
- fclose(f);
- return -3;
- }
diff --git a/nsis-2.45-static-libgcc.patch b/nsis-2.45-static-libgcc.patch
deleted file mode 100644
index 0ad2f979e3f6..000000000000
--- a/nsis-2.45-static-libgcc.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/SCons/Config/gnu b/SCons/Config/gnu
-index 7b64ccc..ef9e94b 100755
---- a/SCons/Config/gnu
-+++ b/SCons/Config/gnu
-@@ -117,6 +117,7 @@ if not defenv['DEBUG'] and defenv['STRIP'] and defenv['STRIP_W32']:
- plugin_env.Append(LINKFLAGS = ['-mwindows']) # build windows executables
- plugin_env.Append(LINKFLAGS = ['$ALIGN_FLAG']) # 512 bytes align
- plugin_env.Append(LINKFLAGS = ['$MAP_FLAG']) # generate map file
-+plugin_env.Append(LINKFLAGS = ['-static-libgcc']) # remove libgcc*.dll dependency
-
- ### cross-platform util environment
-
diff --git a/nsis-2.46-missing-unistd-include.patch b/nsis-2.46-missing-unistd-include.patch
deleted file mode 100644
index 4f4fdd2189b7..000000000000
--- a/nsis-2.46-missing-unistd-include.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- nsis-2.46-src.old/Source/util.h 2009-03-28 09:47:26.000000000 +0000
-+++ nsis-2.46-src/Source/util.h 2012-01-16 12:22:14.967416817 +0000
-@@ -17,6 +17,8 @@
- #ifndef _UTIL_H_
- #define _UTIL_H_
-
-+#include <unistd.h>
-+
- #include <string> // for std::string
-
- #include "boost/scoped_ptr.hpp" // for boost::scoped_ptr
diff --git a/nsis-2.46-static-libstdc++.patch b/nsis-2.46-static-libstdc++.patch
deleted file mode 100644
index 8bd770250c1b..000000000000
--- a/nsis-2.46-static-libstdc++.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -u a/SCons/Config/gnu b/SCons/Config/gnu
---- a/SCons/Config/gnu
-+++ b/SCons/Config/gnu
-@@ -118,6 +118,7 @@
- plugin_env.Append(LINKFLAGS = ['$ALIGN_FLAG']) # 512 bytes align
- plugin_env.Append(LINKFLAGS = ['$MAP_FLAG']) # generate map file
- plugin_env.Append(LINKFLAGS = ['-static-libgcc']) # remove libgcc*.dll dependency
-+plugin_env.Append(LINKFLAGS = ['-static-libstdc++'])
-
- ### cross-platform util environment
-
diff --git a/nsis-948074.patch b/nsis-948074.patch
deleted file mode 100644
index fc91f539494d..000000000000
--- a/nsis-948074.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- a/Source/ResourceEditor.h.64bit 2009-02-01 09:44:30.000000000 -0500
-+++ b/Source/ResourceEditor.h 2014-07-23 17:12:20.000000000 -0400
-@@ -180,7 +180,7 @@
-
- void Destroy();
-
-- DWORD m_dwWrittenAt;
-+ long m_dwWrittenAt;
-
- private:
- IMAGE_RESOURCE_DIRECTORY m_rdDir;
-@@ -204,7 +204,7 @@
-
- CResourceDataEntry* GetDataEntry();
-
-- DWORD m_dwWrittenAt;
-+ long m_dwWrittenAt;
-
- private:
- bool m_bHasName;
-@@ -232,7 +232,7 @@
- DWORD GetCodePage();
- DWORD GetOffset();
-
-- DWORD m_dwWrittenAt;
-+ long m_dwWrittenAt;
-
- private:
- BYTE* m_pbData;
diff --git a/nsis-add-mingw-w64-support.patch b/nsis-add-mingw-w64-support.patch
index 8b6bed214c8f..02d119af22f1 100644
--- a/nsis-add-mingw-w64-support.patch
+++ b/nsis-add-mingw-w64-support.patch
@@ -1,53 +1,25 @@
-diff -ur nsis-2.46-src.orig/Contrib/InstallOptions/InstallerOptions.cpp nsis-2.46-src/Contrib/InstallOptions/InstallerOptions.cpp
---- nsis-2.46-src.orig/Contrib/InstallOptions/InstallerOptions.cpp 2015-04-27 12:13:50.407400959 +0000
-+++ nsis-2.46-src/Contrib/InstallOptions/InstallerOptions.cpp 2015-04-27 12:14:09.627400134 +0000
-@@ -16,6 +16,12 @@
-
- #include <nsis/pluginapi.h> // nsis plugin
-
-+#ifdef __MINGW64_VERSION_MAJOR
-+#ifndef min
-+#define min(a,b) (((a) < (b)) ? (a) : (b))
-+#endif
-+#endif
-+
- // Use for functions only called from one place to possibly reduce some code
- // size. Allows the source code to remain readable by leaving the function
- // intact.
-diff -ur nsis-2.46-src.orig/Contrib/Makensisw/makensisw.h nsis-2.46-src/Contrib/Makensisw/makensisw.h
---- nsis-2.46-src.orig/Contrib/Makensisw/makensisw.h 2015-04-27 12:13:50.414067625 +0000
-+++ nsis-2.46-src/Contrib/Makensisw/makensisw.h 2015-04-27 12:14:09.627400134 +0000
-@@ -22,7 +22,11 @@
- #ifndef MAKENSIS_H
- #define MAKENSIS_H
-
-+#include <stdio.h> /* Needed to get __MINGW64_VERSION_MAJOR set */
-+#ifndef __MINGW64_VERSION_MAJOR
- #define _WIN32_IE 0x0400
-+#endif
-+
- #include <windows.h>
- #include <commctrl.h>
- #include "utils.h"
-diff -ur nsis-2.46-src.orig/SCons/Tools/crossmingw.py nsis-2.46-src/SCons/Tools/crossmingw.py
---- nsis-2.46-src.orig/SCons/Tools/crossmingw.py 2015-04-27 12:13:50.434067625 +0000
-+++ nsis-2.46-src/SCons/Tools/crossmingw.py 2015-04-27 12:14:09.624066801 +0000
-@@ -58,6 +58,7 @@
+From 4677332e1cded26606698fdb3f291cdc3e5eb9ef Mon Sep 17 00:00:00 2001
+From: Amir Szekely <kichik@users.sourceforge.net>
+Date: Fri, 30 Sep 2016 23:32:40 +0000
+Subject: [PATCH] more mingw versions https://github.com/kichik/nsis/pull/5/
+
+git-svn-id: https://svn.code.sf.net/p/nsis/code/NSIS/trunk@6784 212acab6-be3b-0410-9dea-997c60f758d6
+---
+ SCons/Tools/crossmingw.py | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/SCons/Tools/crossmingw.py b/SCons/Tools/crossmingw.py
+index 6140a2d..106f403 100644
+--- a/SCons/Tools/crossmingw.py
++++ b/SCons/Tools/crossmingw.py
+@@ -58,6 +58,10 @@
i486-pc-mingw32-
i586-pc-mingw32-
i686-pc-mingw32-
++ i386-w64-mingw32-
++ i486-w64-mingw32-
++ i586-w64-mingw32-
+ i686-w64-mingw32-
""")
def find(env):
-diff -ur nsis-2.46-src.orig/Source/exehead/Ui.c nsis-2.46-src/Source/exehead/Ui.c
---- nsis-2.46-src.orig/Source/exehead/Ui.c 2015-04-27 12:13:50.437400958 +0000
-+++ nsis-2.46-src/Source/exehead/Ui.c 2015-04-27 12:16:25.057394348 +0000
-@@ -14,6 +14,7 @@
- * warranty.
- */
-
-+#include <windows.h>
- #include <windowsx.h>
- #include <shlobj.h>
- #include <shellapi.h>