summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoboron30422022-01-11 18:24:56 +0100
committerRoboron30422022-01-11 18:24:56 +0100
commit85498406ca544a3d8a38cd40f1b524b6e749c961 (patch)
treed0f142807ee73d4168f1a9ece1a92a97c3145ff9
downloadaur-nsis-cabx-bin.tar.gz
Initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD16
3 files changed, 29 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..93c82d0fb872
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = nsis-cabx-bin
+ pkgdesc = NSIS plugin which allows you to extract .cab files
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://nsis.sourceforge.io/CabX_plug-in
+ arch = any
+ license = custom
+ depends = nsis
+ source = CabX-1.0.zip::https://nsis.sourceforge.io/mediawiki/images/c/c7/CabX.zip
+ sha256sums = 5c42e0af34bc29d61dc8d84cb74f3e541e1133f9d35f147792e424503abd1fe6
+
+pkgname = nsis-cabx-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b23c29326704
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,16 @@
+# Maintainer: Roboron <robertoms258 at gmail dot com>
+
+pkgname=nsis-cabx-bin
+pkgver=1.0
+pkgrel=1
+pkgdesc="NSIS plugin which allows you to extract .cab files"
+arch=('any') # Does not contain any code that's executed on the host system
+url="https://nsis.sourceforge.io/CabX_plug-in"
+license=('custom')
+depends=('nsis')
+source=("CabX-$pkgver.zip::https://nsis.sourceforge.io/mediawiki/images/c/c7/CabX.zip")
+sha256sums=('5c42e0af34bc29d61dc8d84cb74f3e541e1133f9d35f147792e424503abd1fe6')
+
+package() {
+ install -D "$srcdir"/Plugins/x86-unicode/CabX.dll "$pkgdir"/usr/share/nsis/Plugins/x86-unicode/CabX.dll
+}