summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVladimir Panteleev2020-01-15 10:19:07 +0000
committerVladimir Panteleev2020-01-15 10:33:51 +0000
commit8a78ef5a2bd2d60c103163c801ad5803851afd51 (patch)
tree90150e66e681dc682d8f6647757d0cc58f9e7b91
downloadaur-8a78ef5a2bd2d60c103163c801ad5803851afd51.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--LICENSE11
-rw-r--r--PKGBUILD18
4 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5e40b53bbf78
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = nsis-inetload-bin
+ pkgdesc = MS WinInet API based plug-in for http and ftp downloads with better proxy support
+ pkgver = 200801091822
+ pkgrel = 1
+ url = https://nsis.sourceforge.io/InetLoad_plug-in
+ arch = any
+ license = custom
+ source = InetLoad-200801091822.zip::https://nsis.sourceforge.io/mediawiki/images/b/b4/InetLoad.zip
+ source = LICENSE
+ sha256sums = c749b6651936f7d48dba964aa37d8a4ad58dd7960240a0030a819a752eb4e6db
+ sha256sums = 640cbe6013506905233100b357c24bdcdd08bbe277fd7cf7a5c892effe18208e
+
+pkgname = nsis-inetload-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..fb906a76ab59
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/*.pkg.tar.xz
+/InetLoad-*.zip
+/pkg/
+/src/
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..c79106007064
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,11 @@
+Copyright © 2006 Takhir Bedertdinov ineum@narod.ru
+
+Permission to use, copy, modify, distribute and sell this software or any part
+thereof and/or its documentation for any purpose is granted without fee provided
+that the above copyright notice and this permission notice appear in all
+copies.
+
+This software is provided "as is" without express or implied warranty of any kind.
+The author shall have no liability with respect to the infringement of copyrights
+or patents that any modification to the content of this file or this file itself
+may incur.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3d02bc876a91
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Vladimir Panteleev <arch-pkg at thecybershadow.net>
+
+pkgname=nsis-inetload-bin
+pkgver=200801091822
+pkgrel=1
+pkgdesc="MS WinInet API based plug-in for http and ftp downloads with better proxy support"
+arch=('any') # Does not contain any code that's executed on the host system
+url="https://nsis.sourceforge.io/InetLoad_plug-in"
+license=('custom')
+source=("InetLoad-$pkgver.zip::https://nsis.sourceforge.io/mediawiki/images/b/b4/InetLoad.zip"
+ 'LICENSE')
+sha256sums=('c749b6651936f7d48dba964aa37d8a4ad58dd7960240a0030a819a752eb4e6db'
+ '640cbe6013506905233100b357c24bdcdd08bbe277fd7cf7a5c892effe18208e')
+
+package() {
+ install -D "$srcdir"/InetLoad.dll "$pkgdir"/usr/share/nsis/Plugins/x86-ansi/InetLoad.dll
+ install -D "$srcdir"/LICENSE "$pkgdir"/usr/share/licenses/nsis-inetload-bin/LICENSE
+}