summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoranthraxx2015-06-18 18:01:39 +0200
committeranthraxx2015-06-18 18:01:39 +0200
commit0d1f0fb8bd91721072d581fac622ac93688cd660 (patch)
tree1e0f383f293d4c55c4f2e6e1c245212b132699de
downloadaur-0d1f0fb8bd91721072d581fac622ac93688cd660.tar.gz
addpkg: nsoq-git 1.9.5.31.494143a-1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD34
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1ab6e439255a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = nsoq-git
+ pkgdesc = Network Security Tool for packet manipulation that allows a large number of options
+ pkgver = 1.9.5.31.494143a
+ pkgrel = 1
+ url = http://www.nsoq.org/
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = GPL3
+ makedepends = git
+ depends = glibc
+ provides = nsoq
+ conflicts = nsoq
+ source = nsoq-git::git+https://github.com/FelipeEcker/nsoq
+ sha512sums = SKIP
+
+pkgname = nsoq-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..21484823d812
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Levente Polyak <levente[at]leventepolyak[dot]net>
+
+pkgname=nsoq-git
+pkgver=1.9.5.31.494143a
+pkgrel=1
+pkgdesc="Network Security Tool for packet manipulation that allows a large number of options"
+url="http://www.nsoq.org/"
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+license=('GPL3')
+depends=('glibc')
+makedepends=('git')
+provides=('nsoq')
+conflicts=('nsoq')
+source=(${pkgname}::git+https://github.com/FelipeEcker/nsoq)
+sha512sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname}
+ printf "%s.%s.%s" "$(git describe --tags --abbrev=0|cut -dv -f2)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd ${pkgname}
+ make
+}
+
+package() {
+ cd ${pkgname}
+ install -Dm 755 bin/nsoq "${pkgdir}/usr/bin/nsoq"
+ install -Dm 644 CHANGELOG README.md docs/nsoq.txt -t "${pkgdir}/usr/share/doc/nsoq"
+ install -Dm 644 docs/nsoq.8.gz "${pkgdir}/usr/share/man/man8/nsoq.8.gz"
+}
+
+# vim: ts=2 sw=2 et: