summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Gamble2016-12-30 14:39:15 +1100
committerMatthew Gamble2016-12-30 14:39:15 +1100
commit6f1e91d9f962208cd182613ed534fe9822ae290d (patch)
tree98ad44cb5c90a2ceaf6c53d601ed3ecd0fd4be52
downloadaur-6f1e91d9f962208cd182613ed534fe9822ae290d.tar.gz
Initial commit of v1.0.0 of nspawn-tools
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD19
3 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..695d848bcf88
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Fri Dec 30 03:39:05 UTC 2016
+pkgbase = nspawn-tools
+ pkgdesc = Convenience code for dealing with systemd-nspawn machines
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/djmattyg007/nspawn-tools
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ depends = python
+ depends = python-executor
+ depends = python-humanfriendly
+ depends = python-parse
+ depends = python-proc
+ source = https://github.com/djmattyg007/nspawn-tools/archive/1.0.0.tar.gz
+ sha512sums = 6479dee3c471d1743e3caa982d999b06b955fac3bad3f37df3bd3db9ddb25bcf3a62ce5447b8562ab9ac646130cca358eb722509f67f132d4bc4b69d8ae023d0
+
+pkgname = nspawn-tools
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2d72b4cd24ca
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.pkg.tar.xz
+/pkg/
+/src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8aa27e827fee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Matthew Gamble <git@matthewgamble.net>
+
+pkgname=nspawn-tools
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Convenience code for dealing with systemd-nspawn machines"
+arch=("any")
+url="https://github.com/djmattyg007/nspawn-tools"
+license=("GPL3")
+depends=("python" "python-executor" "python-humanfriendly" "python-parse" "python-proc")
+makedepends=("python-setuptools")
+source=("https://github.com/djmattyg007/nspawn-tools/archive/${pkgver}.tar.gz")
+sha512sums=("6479dee3c471d1743e3caa982d999b06b955fac3bad3f37df3bd3db9ddb25bcf3a62ce5447b8562ab9ac646130cca358eb722509f67f132d4bc4b69d8ae023d0")
+
+package() {
+ cd "nspawn-tools-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+ install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/nspawn-tools/LICENSE.txt"
+}