summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFranziskus Kiefer2017-06-09 10:59:40 +0200
committerFranziskus Kiefer2017-06-09 10:59:40 +0200
commit256dd18125dbc2cd5db456203034f3269698084c (patch)
tree8663517b78de3ebeb7fb34cc6be3850bb0f588b7
parentadcd469897d93870fc07d84b268be8f08a52dd34 (diff)
downloadaur-256dd18125dbc2cd5db456203034f3269698084c.tar.gz
disable tests in build; some fixes
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD16
2 files changed, 12 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b1bef1f8cbf0..1adf94f67e62 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = nss-hg
pkgdesc = Mozilla Network Security Services
- pkgver = r13365.209329be2d0c
+ pkgver = r13423.431af1a9435a
pkgrel = 1
url = https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSS
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 969dd9c49433..f29400876715 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname=nss
pkgname=nss-hg
-pkgver=r13365.209329be2d0c
+pkgver=r13423.431af1a9435a
pkgrel=1
pkgdesc="Mozilla Network Security Services"
arch=(i686 x86_64)
@@ -20,12 +20,14 @@ conflicts=('nss')
provides=('nss')
pkgver() {
- cd nss
+ cd "$_pkgname"
printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
}
prepare() {
- git clone https://chromium.googlesource.com/external/gyp
+ if [ ! -d gyp ]; then
+ git clone https://chromium.googlesource.com/external/gyp
+ fi
python2 -m virtualenv python-env
cd gyp
../python-env/bin/python setup.py install
@@ -34,9 +36,13 @@ prepare() {
}
build() {
- ln -s /usr/bin/python2 python
+ if [ ! -f python ]; then
+ ln -s /usr/bin/python2 python
+ fi
cd nss
- PATH=$PWD/../python-env/bin/:$PWD/../:$PATH ./build.sh --opt --system-sqlite --system-nspr
+ PATH=$PWD/../python-env/bin/:$PWD/../:$PATH ./build.sh --opt --system-sqlite \
+ --system-nspr \
+ --disable-tests
}
package() {