summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFranziskus Kiefer2016-08-25 15:46:57 +0200
committerFranziskus Kiefer2016-08-25 15:59:14 +0200
commitdbe69d11ecde1fd58559710b5cc90055c53ffc5a (patch)
tree8e6e6a0d27fea5bb737209f029c5fd67252861b4
parent09e02126055d6a224be2c1ef7a3644d92505773a (diff)
downloadaur-dbe69d11ecde1fd58559710b5cc90055c53ffc5a.tar.gz
clean up; in-tree pkg config files; updated dependencies
server hooks want these files...
-rw-r--r--PKGBUILD14
-rw-r--r--nss-config.in145
-rw-r--r--nss.pc.in11
3 files changed, 5 insertions, 165 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b0a45759a1aa..0bbfb075d902 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
# $Id$
-# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Maintainer: Franziskus Kiefer <arch@franziskuskiefer.de>
pkgbase=nss-hg
pkgname=nss-hg
@@ -13,11 +13,8 @@ _nsprver=4.12
depends=("nspr>=${_nsprver}" 'sqlite' 'zlib' 'sh' 'p11-kit')
makedepends=('perl' 'python2')
options=('!strip' '!makeflags' 'staticlibs')
-source=("hg+https://hg.mozilla.org/projects/nss"
- nss.pc.in nss-config.in)
-sha256sums=('SKIP'
- 'b9f1428ca2305bf30b109507ff335fa00bce5a7ce0434b50acd26ad7c47dd5bd'
- 'e44ac5095b4d88f24ec7b2e6a9f1581560bd3ad41a3d198596d67ef22f67adb9')
+source=("hg+https://hg.mozilla.org/projects/nss")
+sha256sums=('SKIP')
prepare() {
# Respect LDFLAGS
@@ -33,7 +30,6 @@ build() {
export NSS_ENABLE_ECC=1
export NSPR_INCLUDE_DIR="`nspr-config --includedir`"
export NSPR_LIB_DIR="`nspr-config --libdir`"
- export NSS_ENABLE_TLS_1_3=1
export XCFLAGS="${CFLAGS}"
[ "$CARCH" = "x86_64" ] && export USE_64=1
@@ -50,7 +46,7 @@ package() {
NSS_VMINOR=$(grep '#define.*NSS_VMINOR' nss/lib/nss/nss.h | awk '{print $3}')
NSS_VPATCH=$(grep '#define.*NSS_VPATCH' nss/lib/nss/nss.h | awk '{print $3}')
- sed ../nss.pc.in \
+ sed nss/pkg/pkg-config/nss.pc.in \
-e "s,%libdir%,/usr/lib,g" \
-e "s,%prefix%,/usr,g" \
-e "s,%exec_prefix%,/usr/bin,g" \
@@ -60,7 +56,7 @@ package() {
> "$pkgdir/usr/lib/pkgconfig/nss.pc"
ln -s nss.pc "$pkgdir/usr/lib/pkgconfig/mozilla-nss.pc"
- sed ../nss-config.in \
+ sed nss/pkg/pkg-config/nss-config.in \
-e "s,@libdir@,/usr/lib,g" \
-e "s,@prefix@,/usr/bin,g" \
-e "s,@exec_prefix@,/usr/bin,g" \
diff --git a/nss-config.in b/nss-config.in
index f8f893e71a70..e69de29bb2d1 100644
--- a/nss-config.in
+++ b/nss-config.in
@@ -1,145 +0,0 @@
-#!/bin/sh
-
-prefix=@prefix@
-
-major_version=@MOD_MAJOR_VERSION@
-minor_version=@MOD_MINOR_VERSION@
-patch_version=@MOD_PATCH_VERSION@
-
-usage()
-{
- cat <<EOF
-Usage: nss-config [OPTIONS] [LIBRARIES]
-Options:
- [--prefix[=DIR]]
- [--exec-prefix[=DIR]]
- [--includedir[=DIR]]
- [--libdir[=DIR]]
- [--version]
- [--libs]
- [--cflags]
-Dynamic Libraries:
- nss
- nssutil
- ssl
- smime
-EOF
- exit $1
-}
-
-if test $# -eq 0; then
- usage 1 1>&2
-fi
-
-lib_ssl=yes
-lib_smime=yes
-lib_nss=yes
-lib_nssutil=yes
-
-while test $# -gt 0; do
- case "$1" in
- -*=*) optarg=`echo "$1" | sed 's/[-_a-zA-Z0-9]*=//'` ;;
- *) optarg= ;;
- esac
-
- case $1 in
- --prefix=*)
- prefix=$optarg
- ;;
- --prefix)
- echo_prefix=yes
- ;;
- --exec-prefix=*)
- exec_prefix=$optarg
- ;;
- --exec-prefix)
- echo_exec_prefix=yes
- ;;
- --includedir=*)
- includedir=$optarg
- ;;
- --includedir)
- echo_includedir=yes
- ;;
- --libdir=*)
- libdir=$optarg
- ;;
- --libdir)
- echo_libdir=yes
- ;;
- --version)
- echo ${major_version}.${minor_version}.${patch_version}
- ;;
- --cflags)
- echo_cflags=yes
- ;;
- --libs)
- echo_libs=yes
- ;;
- ssl)
- lib_ssl=yes
- ;;
- smime)
- lib_smime=yes
- ;;
- nss)
- lib_nss=yes
- ;;
- nssutil)
- lib_nssutil=yes
- ;;
- *)
- usage 1 1>&2
- ;;
- esac
- shift
-done
-
-# Set variables that may be dependent upon other variables
-if test -z "$exec_prefix"; then
- exec_prefix=`pkg-config --variable=exec_prefix nss`
-fi
-if test -z "$includedir"; then
- includedir=`pkg-config --variable=includedir nss`
-fi
-if test -z "$libdir"; then
- libdir=`pkg-config --variable=libdir nss`
-fi
-
-if test "$echo_prefix" = "yes"; then
- echo $prefix
-fi
-
-if test "$echo_exec_prefix" = "yes"; then
- echo $exec_prefix
-fi
-
-if test "$echo_includedir" = "yes"; then
- echo $includedir
-fi
-
-if test "$echo_libdir" = "yes"; then
- echo $libdir
-fi
-
-if test "$echo_cflags" = "yes"; then
- echo -I$includedir
-fi
-
-if test "$echo_libs" = "yes"; then
- libdirs="-Wl,-rpath-link,$libdir -L$libdir"
- if test -n "$lib_ssl"; then
- libdirs="$libdirs -lssl${major_version}"
- fi
- if test -n "$lib_smime"; then
- libdirs="$libdirs -lsmime${major_version}"
- fi
- if test -n "$lib_nss"; then
- libdirs="$libdirs -lnss${major_version}"
- fi
- if test -n "$lib_nssutil"; then
- libdirs="$libdirs -lnssutil${major_version}"
- fi
- echo $libdirs
-fi
-
diff --git a/nss.pc.in b/nss.pc.in
index d47b9e14699f..e69de29bb2d1 100644
--- a/nss.pc.in
+++ b/nss.pc.in
@@ -1,11 +0,0 @@
-prefix=%prefix%
-exec_prefix=%exec_prefix%
-libdir=%libdir%
-includedir=%includedir%
-
-Name: NSS
-Description: Network Security Services
-Version: %NSS_VERSION%
-Requires: nspr >= %NSPR_VERSION%
-Libs: -lssl3 -lsmime3 -lnss3 -lnssutil3
-Cflags: -I${includedir}