summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Armbruster2020-04-19 16:18:34 +0200
committerMichael Armbruster2020-04-19 16:18:34 +0200
commit0b33debc4092c3c877e8f0de1746493faf1a1469 (patch)
treecb52fcb6107516c74a373535c9f4377f75253551
parentf4e6684c46b61236a44b1edb42c3c710f512fcc1 (diff)
downloadaur-0b33debc4092c3c877e8f0de1746493faf1a1469.tar.gz
Fix missing make dependency
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD18
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7711bf3e02fb..630d99184d9f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = nsz-git
pkgdesc = Switch Homebrew compatible NSP/XCI compressor/decompressor
pkgver = 3.1.1.r25.g571147e
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/nicoboss/nsz
arch = any
license = MIT
makedepends = git
+ makedepends = python-setuptools
depends = python>=3.6
depends = python-pycryptodome>=3.9.0
depends = python-zstandard
diff --git a/PKGBUILD b/PKGBUILD
index 8bcd340dbc22..f6f142f6f861 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: Michael Armbruster <michael at armbrust dot me>
pkgname=nsz-git
-pkgrel=1
+pkgrel=2
pkgver=3.1.1.r25.g571147e
-pkgdesc="Switch Homebrew compatible NSP/XCI compressor/decompressor"
+pkgdesc='Switch Homebrew compatible NSP/XCI compressor/decompressor'
conflicts=("${pkgname%-*}")
provides=("${pkgname%-*}=$pkgver")
-arch=("any")
-url="https://github.com/nicoboss/nsz"
-license=("MIT")
-depends=("python>=3.6" "python-pycryptodome>=3.9.0" "python-zstandard" "python-enlighten")
-optdepends=("python-pygame" "python-kivy==1.11.1")
-makedepends=("git")
+arch=('any')
+url='https://github.com/nicoboss/nsz'
+license=('MIT')
+depends=('python>=3.6' 'python-pycryptodome>=3.9.0' 'python-zstandard' 'python-enlighten')
+optdepends=('python-pygame' 'python-kivy==1.11.1')
+makedepends=('git' 'python-setuptools')
source=("${pkgname}::git+https://github.com/nicoboss/${pkgname%-*}.git")
-sha256sums=("SKIP")
+sha256sums=('SKIP')
pkgver() {
cd "${pkgname}"