summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Armbruster2020-04-20 16:51:03 +0200
committerMichael Armbruster2020-04-20 16:51:03 +0200
commitd0f9bc1b204b59ec520e4019ee532e2fc5b4a361 (patch)
tree8aaeef4a11eff973e374ad4d0ffe59b4f6ee9fda
parent0b33debc4092c3c877e8f0de1746493faf1a1469 (diff)
downloadaur-d0f9bc1b204b59ec520e4019ee532e2fc5b4a361.tar.gz
Prevent broken shell after application exits
-rw-r--r--.SRCINFO4
-rw-r--r--0001-Stopping-the-bar-manager-is-needed-to-properly-reset.patch33
-rw-r--r--PKGBUILD12
3 files changed, 45 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 630d99184d9f..54cd4de3d8c3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nsz-git
pkgdesc = Switch Homebrew compatible NSP/XCI compressor/decompressor
pkgver = 3.1.1.r25.g571147e
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/nicoboss/nsz
arch = any
license = MIT
@@ -16,7 +16,9 @@ pkgbase = nsz-git
provides = nsz=3.1.1.r25.g571147e
conflicts = nsz
source = nsz-git::git+https://github.com/nicoboss/nsz.git
+ source = 0001-Stopping-the-bar-manager-is-needed-to-properly-reset.patch
sha256sums = SKIP
+ sha256sums = 55171dd660017e425ddcd73cb76ce684d3ce41cb997d8fd6e50263a91a2c4997
pkgname = nsz-git
diff --git a/0001-Stopping-the-bar-manager-is-needed-to-properly-reset.patch b/0001-Stopping-the-bar-manager-is-needed-to-properly-reset.patch
new file mode 100644
index 000000000000..57515c3077b9
--- /dev/null
+++ b/0001-Stopping-the-bar-manager-is-needed-to-properly-reset.patch
@@ -0,0 +1,33 @@
+From 300b63e73d27f8ee686a76b5fa14bf88486a0287 Mon Sep 17 00:00:00 2001
+From: Michael Armbruster <michael@armbrust.me>
+Date: Mon, 20 Apr 2020 16:45:56 +0200
+Subject: [PATCH] Stopping the bar manager is needed to properly reset the
+ shell
+
+---
+ nsz/__init__.py | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/nsz/__init__.py b/nsz/__init__.py
+index d6a44cd..b018ffe 100644
+--- a/nsz/__init__.py
++++ b/nsz/__init__.py
+@@ -199,7 +199,7 @@ def main():
+
+ for i in range(parallelTasks):
+ bars[i].close(clear=True)
+- #barManager.stop() #We aren’t using stop because of it printing garbage to the console.
++ barManager.stop()
+
+ for filePath in sourceFileToDelete:
+ delete_source_file(filePath)
+@@ -279,4 +279,4 @@ def main():
+
+ if __name__ == '__main__':
+ freeze_support()
+- main()
+\ No newline at end of file
++ main()
+--
+2.26.1
+
diff --git a/PKGBUILD b/PKGBUILD
index f6f142f6f861..497b2f9517be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Michael Armbruster <michael at armbrust dot me>
pkgname=nsz-git
-pkgrel=2
+pkgrel=3
pkgver=3.1.1.r25.g571147e
pkgdesc='Switch Homebrew compatible NSP/XCI compressor/decompressor'
conflicts=("${pkgname%-*}")
@@ -12,14 +12,20 @@ license=('MIT')
depends=('python>=3.6' 'python-pycryptodome>=3.9.0' 'python-zstandard' 'python-enlighten')
optdepends=('python-pygame' 'python-kivy==1.11.1')
makedepends=('git' 'python-setuptools')
-source=("${pkgname}::git+https://github.com/nicoboss/${pkgname%-*}.git")
-sha256sums=('SKIP')
+source=("${pkgname}::git+https://github.com/nicoboss/${pkgname%-*}.git"
+ '0001-Stopping-the-bar-manager-is-needed-to-properly-reset.patch')
+sha256sums=('SKIP'
+ '55171dd660017e425ddcd73cb76ce684d3ce41cb997d8fd6e50263a91a2c4997')
pkgver() {
cd "${pkgname}"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ patch -d "${pkgname}" -Np1 -i "${srcdir}/0001-Stopping-the-bar-manager-is-needed-to-properly-reset.patch"
+}
+
build() {
cd "${pkgname}"
python setup.py build