summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Armbruster2020-04-19 16:13:49 +0200
committerMichael Armbruster2020-04-19 16:13:49 +0200
commitf4e6684c46b61236a44b1edb42c3c710f512fcc1 (patch)
tree37aeb71037940d0990d942e1f90cb8b43f764cd2
downloadaur-f4e6684c46b61236a44b1edb42c3c710f512fcc1.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD31
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7711bf3e02fb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = nsz-git
+ pkgdesc = Switch Homebrew compatible NSP/XCI compressor/decompressor
+ pkgver = 3.1.1.r25.g571147e
+ pkgrel = 1
+ url = https://github.com/nicoboss/nsz
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python>=3.6
+ depends = python-pycryptodome>=3.9.0
+ depends = python-zstandard
+ depends = python-enlighten
+ optdepends = python-pygame
+ optdepends = python-kivy==1.11.1
+ provides = nsz=3.1.1.r25.g571147e
+ conflicts = nsz
+ source = nsz-git::git+https://github.com/nicoboss/nsz.git
+ sha256sums = SKIP
+
+pkgname = nsz-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8bcd340dbc22
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Michael Armbruster <michael at armbrust dot me>
+
+pkgname=nsz-git
+pkgrel=1
+pkgver=3.1.1.r25.g571147e
+pkgdesc="Switch Homebrew compatible NSP/XCI compressor/decompressor"
+conflicts=("${pkgname%-*}")
+provides=("${pkgname%-*}=$pkgver")
+arch=("any")
+url="https://github.com/nicoboss/nsz"
+license=("MIT")
+depends=("python>=3.6" "python-pycryptodome>=3.9.0" "python-zstandard" "python-enlighten")
+optdepends=("python-pygame" "python-kivy==1.11.1")
+makedepends=("git")
+source=("${pkgname}::git+https://github.com/nicoboss/${pkgname%-*}.git")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "${pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${pkgname}"
+ python setup.py build
+}
+
+package() {
+ cd "${pkgname}"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}