summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteven Honeyman2015-06-09 19:16:09 +0100
committerSteven Honeyman2015-06-09 19:16:09 +0100
commit799e5b4d1e4d422adf0d9aeac8bc6d74fb442f15 (patch)
treeb5721db70166183affdfe9e8e885ebbbd9c43f27
downloadaur-799e5b4d1e4d422adf0d9aeac8bc6d74fb442f15.tar.gz
Initial import
-rw-r--r--.AURINFO15
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
3 files changed, 57 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..3e6cbffcbdb6
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,15 @@
+pkgbase = ntdsxtract
+ pkgdesc = A framework for offline forensic analysis of NTDS.DIT
+ pkgver = 1.3.1
+ pkgrel = 1
+ url = http://www.ntdsxtract.com/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = python2
+ depends = python2-crypto
+ depends = libesedb
+ source = ntdsxtract-1.3.1.zip::http://www.ntdsxtract.com/downloads/ntdsxtract/ntdsxtract_v1_3_1_beta.zip
+
+pkgname = ntdsxtract
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..83ab5b05fc8f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ntdsxtract
+ pkgdesc = A framework for offline forensic analysis of NTDS.DIT
+ pkgver = 1.3.1
+ pkgrel = 1
+ url = http://www.ntdsxtract.com/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = python2
+ depends = python2-crypto
+ depends = libesedb
+ source = ntdsxtract-1.3.1.zip::http://www.ntdsxtract.com/downloads/ntdsxtract/ntdsxtract_v1_3_1_beta.zip
+ md5sums = 0057e137ced55a2e16b9c5d681f6f8ee
+
+pkgname = ntdsxtract
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..47b5e12ddd46
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Steven Honeyman <stevenhoneyman at gmail com>
+
+pkgname=ntdsxtract
+pkgver=1.3.1
+pkgrel=1
+pkgdesc="A framework for offline forensic analysis of NTDS.DIT"
+arch=('i686' 'x86_64')
+url="http://www.ntdsxtract.com/"
+license=('GPL2')
+depends=('python2' 'python2-crypto' 'libesedb')
+source=($pkgname-$pkgver.zip::http://www.ntdsxtract.com/downloads/ntdsxtract/ntdsxtract_v1_3_1_beta.zip)
+md5sums=('0057e137ced55a2e16b9c5d681f6f8ee')
+
+prepare() {
+ cd "$srcdir"
+ sed -i '1s/^/#!\/usr\/bin\/python2\n/' *.py
+}
+
+package() {
+ cd "$srcdir"
+ mkdir -p "$pkgdir"/usr/lib/python2.7/site-packages
+ cp -ar {ntds,framework} "$pkgdir"/usr/lib/python2.7/site-packages
+ for f in *.py; do
+ install -Dm755 "$f" "$pkgdir"/usr/bin/${f%.py}
+ done
+}