summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2023-07-10 21:34:13 +0200
committerhaawda2023-07-10 21:34:13 +0200
commite7d67ed13c88738eb414393ac1d9608c38ae9479 (patch)
tree731895bd04dc0fdf1aa7ce5442b831360b1e7a14
parent657c4422132b489b2a750c694a7e8d72c6261201 (diff)
downloadaur-nted.tar.gz
apply new debian patches
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f9535c8ed11d..4c7c6ec55bcd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
pkgbase = nted
pkgdesc = A free music score editor for Linux.
pkgver = 1.10.18
- pkgrel = 6
+ pkgrel = 7
url = http://http.debian.net/debian/pool/main/n/nted/
arch = i686
arch = x86_64
license = GPL
- makedepends = gcc6
depends = harfbuzz
depends = gdk-pixbuf2
depends = pango
@@ -15,10 +14,9 @@ pkgbase = nted
options = !libtool
options = !strip
options = !makeflags
- source = http://urchlay.naptime.net/~urchlay/src/nted-1.10.18.tar.gz
- source = http://http.debian.net/debian/pool/main/n/nted/nted_1.10.18-12.debian.tar.xz
+ source = http://deb.debian.org/debian/pool/main/n/nted/nted_1.10.18.orig.tar.gz
+ source = http://http.debian.net/debian/pool/main/n/nted/nted_1.10.18-13.debian.tar.xz
sha256sums = 808df3c851dbc4b24efdbf96c4e6ed28152deb301c4373268831f2a243e8f1ac
- sha256sums = 715e5acfb986f0b5b9c898c1a22f06e1da4b58713616c8e525b668e2f16fd074
+ sha256sums = c9e6bc6e213641cd4f08964b36e2192c2ec6710d473088e2d1d4fc9e8e34108f
pkgname = nted
-
diff --git a/PKGBUILD b/PKGBUILD
index b5682af807cd..b70095c7725f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,23 +4,23 @@
pkgname=nted
pkgver=1.10.18
-pkgrel=6
+pkgrel=7
pkgdesc="A free music score editor for Linux."
arch=('i686' 'x86_64')
depends=('harfbuzz' 'gdk-pixbuf2' 'pango' 'gtk2' 'alsa-lib')
-makedepends=('gcc6')
+makedepends=()
license=('GPL')
url="http://http.debian.net/debian/pool/main/n/nted/"
options=('!libtool' '!strip' '!makeflags')
-source=("http://urchlay.naptime.net/~urchlay/src/nted-$pkgver.tar.gz"
- "http://http.debian.net/debian/pool/main/n/nted/nted_$pkgver-12.debian.tar.xz")
+source=("http://deb.debian.org/debian/pool/main/n/$pkgname/${pkgname}_$pkgver.orig.tar.gz"
+ "http://http.debian.net/debian/pool/main/n/$pkgname/${pkgname}_$pkgver-13.debian.tar.xz")
sha256sums=('808df3c851dbc4b24efdbf96c4e6ed28152deb301c4373268831f2a243e8f1ac'
- '715e5acfb986f0b5b9c898c1a22f06e1da4b58713616c8e525b668e2f16fd074')
+ 'c9e6bc6e213641cd4f08964b36e2192c2ec6710d473088e2d1d4fc9e8e34108f')
prepare() {
cd $pkgname-$pkgver
- for i in `head -10 $srcdir/debian/patches/series`
+ for i in `cat "$srcdir"/debian/patches/series`
do
patch -p1 < "$srcdir"/debian/patches/$i || true
done
@@ -32,7 +32,7 @@ build() {
aclocal
automake --add-missing
autoreconf
- CXX=g++-6 CXXFLAGS=" -O2 -std=c++11 -Wno-narrowing" ./configure --prefix=/usr
+ CXXFLAGS=" -O2 -std=c++11 -Wno-narrowing" ./configure --prefix=/usr
make
}