summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2018-04-24 20:17:58 +0200
committerhaawda2018-04-24 20:17:58 +0200
commit26675cdf3b42625f538fca661af00d013025f542 (patch)
treeac144a824e6f815456eb7046c963d72c96572a57
parent46dbd72b2114310e8cd5e4c6fd36942c4916a0d9 (diff)
downloadaur-26675cdf3b42625f538fca661af00d013025f542.tar.gz
fix download url
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD19
2 files changed, 15 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 844454b3462f..03862b44684e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = nted
pkgdesc = A free music score editor for Linux.
pkgver = 1.10.18
- pkgrel = 3
- url = https://vsr.informatik.tu-chemnitz.de/staff/jan/nted/nted.xhtml
+ pkgrel = 4
+ url = http://vsr.informatik.tu-chemnitz.de/staff/jan/nted/nted.xhtml
arch = i686
arch = x86_64
license = GPL
@@ -15,10 +15,10 @@ pkgbase = nted
options = !libtool
options = !strip
options = !makeflags
- source = https://vsr.informatik.tu-chemnitz.de/staff/jan/nted/sources/nted-1.10.18.tar.gz
- source = http://http.debian.net/debian/pool/main/n/nted/nted_1.10.18-11.debian.tar.xz
+ source = http://urchlay.naptime.net/~urchlay/src/nted-1.10.18.tar.gz
+ source = http://http.debian.net/debian/pool/main/n/nted/nted_1.10.18-12.debian.tar.xz
md5sums = 0ca7aa23109171ab643a9b552487bd4b
- md5sums = aceb0ce35f2f8df09262d7b1c8b3d91b
+ md5sums = ca741156f6633603c84fe3e8e74d0555
pkgname = nted
diff --git a/PKGBUILD b/PKGBUILD
index b870a9a02092..e3e3645bd5eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,38 +4,39 @@
pkgname=nted
pkgver=1.10.18
-pkgrel=3
+pkgrel=4
pkgdesc="A free music score editor for Linux."
arch=('i686' 'x86_64')
depends=('harfbuzz' 'gdk-pixbuf2' 'pango' 'gtk2' 'alsa-lib')
makedepends=('gcc49')
license=('GPL')
-url="https://vsr.informatik.tu-chemnitz.de/staff/jan/nted/nted.xhtml"
+url="http://vsr.informatik.tu-chemnitz.de/staff/jan/nted/nted.xhtml"
options=('!libtool' '!strip' '!makeflags')
-source=(https://vsr.informatik.tu-chemnitz.de/staff/jan/nted/sources/nted-1.10.18.tar.gz http://http.debian.net/debian/pool/main/n/nted/nted_1.10.18-11.debian.tar.xz)
+source=("http://urchlay.naptime.net/~urchlay/src/nted-$pkgver.tar.gz"
+ "http://http.debian.net/debian/pool/main/n/nted/nted_$pkgver-12.debian.tar.xz")
md5sums=('0ca7aa23109171ab643a9b552487bd4b'
- 'aceb0ce35f2f8df09262d7b1c8b3d91b')
+ 'ca741156f6633603c84fe3e8e74d0555')
prepare() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd $pkgname-$pkgver
for i in `head -10 $srcdir/debian/patches/series`
do
- patch -p1 < $srcdir/debian/patches/$i
+ patch -p1 < "$srcdir"/debian/patches/$i || true
done
mv configure.in configure.ac
}
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd $pkgname-$pkgver
aclocal
automake --add-missing
autoreconf
- CXX=g++-4.9 CXXFLAGS=" -std=c++11 -Wno-narrowing" ./configure --prefix=/usr
+ CXX=g++-4.9 CXXFLAGS=" -O2 -std=c++11 -Wno-narrowing" ./configure --prefix=/usr
make
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd $pkgname-$pkgver
make DESTDIR="$pkgdir" install
}