summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2018-04-24 15:08:38 +0200
committerhaawda2018-04-24 15:08:38 +0200
commit46dbd72b2114310e8cd5e4c6fd36942c4916a0d9 (patch)
tree1896634090857dbf229772ed208457d0684435c4
parentfd857ea41aa3d8253babc0355311ab51438b26a3 (diff)
downloadaur-46dbd72b2114310e8cd5e4c6fd36942c4916a0d9.tar.gz
initial reupload with gcc49 as makedependency
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2f03f005548f..844454b3462f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = nted
pkgdesc = A free music score editor for Linux.
pkgver = 1.10.18
- pkgrel = 2
+ pkgrel = 3
url = https://vsr.informatik.tu-chemnitz.de/staff/jan/nted/nted.xhtml
arch = i686
arch = x86_64
license = GPL
+ makedepends = gcc49
depends = harfbuzz
depends = gdk-pixbuf2
depends = pango
@@ -15,9 +16,9 @@ pkgbase = nted
options = !strip
options = !makeflags
source = https://vsr.informatik.tu-chemnitz.de/staff/jan/nted/sources/nted-1.10.18.tar.gz
- source = http://http.debian.net/debian/pool/main/n/nted/nted_1.10.18-8.debian.tar.xz
+ source = http://http.debian.net/debian/pool/main/n/nted/nted_1.10.18-11.debian.tar.xz
md5sums = 0ca7aa23109171ab643a9b552487bd4b
- md5sums = fc234858017b6174b1a6f8d2a9179d47
+ md5sums = aceb0ce35f2f8df09262d7b1c8b3d91b
pkgname = nted
diff --git a/PKGBUILD b/PKGBUILD
index b2f1b5a3c4db..b870a9a02092 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,16 +4,17 @@
pkgname=nted
pkgver=1.10.18
-pkgrel=2
+pkgrel=3
pkgdesc="A free music score editor for Linux."
arch=('i686' 'x86_64')
depends=('harfbuzz' 'gdk-pixbuf2' 'pango' 'gtk2' 'alsa-lib')
+makedepends=('gcc49')
license=('GPL')
url="https://vsr.informatik.tu-chemnitz.de/staff/jan/nted/nted.xhtml"
options=('!libtool' '!strip' '!makeflags')
-source=(https://vsr.informatik.tu-chemnitz.de/staff/jan/nted/sources/nted-1.10.18.tar.gz http://http.debian.net/debian/pool/main/n/nted/nted_1.10.18-8.debian.tar.xz)
+source=(https://vsr.informatik.tu-chemnitz.de/staff/jan/nted/sources/nted-1.10.18.tar.gz http://http.debian.net/debian/pool/main/n/nted/nted_1.10.18-11.debian.tar.xz)
md5sums=('0ca7aa23109171ab643a9b552487bd4b'
- 'fc234858017b6174b1a6f8d2a9179d47')
+ 'aceb0ce35f2f8df09262d7b1c8b3d91b')
prepare() {
cd "$srcdir/$pkgname-$pkgver"
@@ -30,7 +31,7 @@ build() {
aclocal
automake --add-missing
autoreconf
- CXXFLAGS=" -std=c++11 -Wno-narrowing" ./configure --prefix=/usr
+ CXX=g++-4.9 CXXFLAGS=" -std=c++11 -Wno-narrowing" ./configure --prefix=/usr
make
}