summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2015-09-27 22:51:05 +0200
committerStefan Husmann2015-09-27 22:51:05 +0200
commit49b4c40d2e7ac4b215ce6fdde2d30c3204cfadfb (patch)
tree14dcfe4456e7589506b41f2fcc121882eb01e658
downloadaur-49b4c40d2e7ac4b215ce6fdde2d30c3204cfadfb.tar.gz
initial upload
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD40
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b408766a83e4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = nted
+ pkgdesc = A free music score editor for Linux.
+ pkgver = 1.10.18
+ pkgrel = 1
+ url = https://vsr.informatik.tu-chemnitz.de/staff/jan/nted/nted.xhtml
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = harfbuzz
+ depends = gdk-pixbuf2
+ depends = pango
+ depends = gtk2
+ depends = alsa-lib
+ options = !libtool
+ options = !strip
+ options = !makeflags
+ source = https://vsr.informatik.tu-chemnitz.de/staff/jan/nted/sources/nted-1.10.18.tar.gz
+ source = http://http.debian.net/debian/pool/main/n/nted/nted_1.10.18-8.debian.tar.xz
+ md5sums = 0ca7aa23109171ab643a9b552487bd4b
+ md5sums = fc234858017b6174b1a6f8d2a9179d47
+
+pkgname = nted
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fb75c6f8b9b4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Wael Nasreddine <gandalf@siemens-mobiles.org>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=nted
+pkgver=1.10.18
+pkgrel=1
+pkgdesc="A free music score editor for Linux."
+arch=('i686' 'x86_64')
+depends=('harfbuzz' 'gdk-pixbuf2' 'pango' 'gtk2' 'alsa-lib')
+license=('GPL')
+url="https://vsr.informatik.tu-chemnitz.de/staff/jan/nted/nted.xhtml"
+options=('!libtool' '!strip' '!makeflags')
+source=(https://vsr.informatik.tu-chemnitz.de/staff/jan/nted/sources/nted-1.10.18.tar.gz http://http.debian.net/debian/pool/main/n/nted/nted_1.10.18-8.debian.tar.xz)
+md5sums=('0ca7aa23109171ab643a9b552487bd4b'
+ 'fc234858017b6174b1a6f8d2a9179d47')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ for i in `head -10 $srcdir/debian/patches/series`
+ do
+ patch -p1 < $srcdir/debian/patches/$i
+ done
+ mv configure.in configure.ac
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ aclocal
+ automake --add-missing
+ autoreconf
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}