summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDwi Mulia Mokoginta2022-06-07 08:08:30 +0700
committerDwi Mulia Mokoginta2022-06-07 08:08:30 +0700
commit3daeecf83a74aefe7add0c7c2d3a952c9ac7de07 (patch)
tree1d178c9cd00d592d411b118035408239b2e77f79
parent66dc90fdda7c57999a73c5624ed2873ac49abfe4 (diff)
downloadaur-3daeecf83a74aefe7add0c7c2d3a952c9ac7de07.tar.gz
Fixing source directory
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8ccd6256d73c..0e42d4c24607 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -23,7 +23,9 @@ pkgbase = nteract
conflicts = nteract-bin
source = v0.28.0.tar.gz::https://github.com/nteract/nteract/archive/refs/tags/v0.28.0.tar.gz
source = LICENSE::https://raw.githubusercontent.com/nteract/nteract/main/LICENSE
+ source = nteract.desktop
sha256sums = 5132a05ca269aa3b1b0a96cbe4a7b9956454069029173f6f1cb3d73a59a83073
sha256sums = 866e6fa48cb8810d36d8d85a3085d7aa1c4317d3731f0ef84919428fee87bf71
+ sha256sums = b2d43d3d75ca35ccbacbf4db73cbd64a6e5b2346218152731df0de39d58a7fa1
pkgname = nteract
diff --git a/PKGBUILD b/PKGBUILD
index 0165d89b8a23..c6af087ecd24 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,9 +18,11 @@ optdepends=('ihaskell-git: support for Haskell'
'r: support for R (requires the "IRkernel" package)'
'sagemath-jupyter: support for SageMath')
source=(v${pkgver}.tar.gz::https://github.com/nteract/nteract/archive/refs/tags/v${pkgver}.tar.gz
- 'LICENSE::https://raw.githubusercontent.com/nteract/nteract/main/LICENSE')
+ 'LICENSE::https://raw.githubusercontent.com/nteract/nteract/main/LICENSE'
+ 'nteract.desktop')
sha256sums=('5132a05ca269aa3b1b0a96cbe4a7b9956454069029173f6f1cb3d73a59a83073'
- '866e6fa48cb8810d36d8d85a3085d7aa1c4317d3731f0ef84919428fee87bf71')
+ '866e6fa48cb8810d36d8d85a3085d7aa1c4317d3731f0ef84919428fee87bf71'
+ 'b2d43d3d75ca35ccbacbf4db73cbd64a6e5b2346218152731df0de39d58a7fa1')
conflicts=('nteract-bin')
prepare() {
@@ -54,5 +56,6 @@ package() {
ln -s /opt/$pkgname/$pkgname "$pkgdir"/usr/bin/$pkgname
install -Dm 644 ${pkgname}.desktop "$pkgdir"/usr/share/applications/${pkgname}.desktop
+
install -Dm 644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}