summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorConor Anderson2018-01-27 21:42:59 -0500
committerConor Anderson2018-01-27 21:42:59 -0500
commit6959e65795ee61ba210b7944c52a655def3e9747 (patch)
tree7364a3cf5a9a4d6c1663f55639c7246e6baa9a61
parenta5c33e1298c3e937a3a754edfbe56e8f60815495 (diff)
downloadaur-6959e65795ee61ba210b7944c52a655def3e9747.tar.gz
Version bump.
-rw-r--r--.SRCINFO11
-rw-r--r--LICENSE3
-rw-r--r--PKGBUILD16
3 files changed, 12 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a561b7b8d9b3..4682c2170786 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,11 @@
-# Generated by mksrcinfo v8
-# Mon Dec 18 16:34:11 UTC 2017
pkgbase = nteract-bin
pkgdesc = Interactive literate coding notebook
- pkgver = 0.4.3
+ pkgver = 0.6.2
pkgrel = 1
url = https://nteract.io
install = nteract-bin.install
arch = x86_64
license = BSD-3-Clause
- makedepends = gendesk
depends = alsa-lib
depends = gconf
depends = gtk2
@@ -23,10 +20,10 @@ pkgbase = nteract-bin
optdepends = python2-ipykernel: support for Python 2
optdepends = r: support for R (requires the "IRkernel" package)
optdepends = sagemath-jupyter: support for SageMath
- source = nteract_0.4.3_amd64.deb::https://github.com/nteract/nteract/releases/download/v0.4.3/nteract_0.4.3_amd64.deb
+ source = nteract_0.6.2_amd64.deb::https://github.com/nteract/nteract/releases/download/v0.6.2/nteract_0.6.2_amd64.deb
source = LICENSE
- sha256sums = 5a2fab27241082d6fe4d1375ee8a3a33eefdc2cf5e0df0624ad8ab8adc475980
- sha256sums = 9810f3d57c552d3b3f6c82cb3b6f3402d6faf94fc5a63067fe28360fb3b8b688
+ sha256sums = 05b86b032a689f6ac8919a1d18a9cb7ec920130805db1cc98b5201440f80774f
+ sha256sums = 866e6fa48cb8810d36d8d85a3085d7aa1c4317d3731f0ef84919428fee87bf71
pkgname = nteract-bin
diff --git a/LICENSE b/LICENSE
index 1064cce07305..79d2e86e15b4 100644
--- a/LICENSE
+++ b/LICENSE
@@ -11,7 +11,7 @@ modification, are permitted provided that the following conditions are met:
this list of conditions and the following disclaimer in the documentation
and/or other materials provided with the distribution.
-* Neither the name of transformime-react nor the names of its
+* Neither the name of nteract nor the names of its
contributors may be used to endorse or promote products derived from
this software without specific prior written permission.
@@ -25,3 +25,4 @@ SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
diff --git a/PKGBUILD b/PKGBUILD
index 60fd7d9af206..a2f20f376eac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,13 @@
pkgname=nteract-bin
_pkgname=${pkgname%-bin}
-pkgver=0.4.3
+pkgver=0.6.2
pkgrel=1
pkgdesc="Interactive literate coding notebook"
url='https://nteract.io'
arch=('x86_64')
license=('BSD-3-Clause')
depends=('alsa-lib' 'gconf' 'gtk2' 'libxss' 'libxtst' 'nodejs' 'nss' 'python')
-makedepends=('gendesk')
optdepends=('ihaskell-git: support for Haskell'
'julia: support for Julia (requires the "IJulia" package)'
'python-ipykernel: support for Python 3'
@@ -19,14 +18,10 @@ optdepends=('ihaskell-git: support for Haskell'
'sagemath-jupyter: support for SageMath')
install=$pkgname.install
-source=("${_pkgname}_${pkgver}_amd64.deb::https://github.com/nteract/nteract/releases/download/v0.4.3/nteract_0.4.3_amd64.deb"
+source=("${_pkgname}_${pkgver}_amd64.deb::https://github.com/nteract/nteract/releases/download/v${pkgver}/nteract_${pkgver}_amd64.deb"
"LICENSE")
-sha256sums=('5a2fab27241082d6fe4d1375ee8a3a33eefdc2cf5e0df0624ad8ab8adc475980'
- '9810f3d57c552d3b3f6c82cb3b6f3402d6faf94fc5a63067fe28360fb3b8b688')
-
-prepare() {
- gendesk -f -n --name="${_pkgname}" --pkgname="${_pkgname}" --pkgdesc="${pkgdesc}" --exec="${_pkgname}" --categories="Development"
-}
+sha256sums=('05b86b032a689f6ac8919a1d18a9cb7ec920130805db1cc98b5201440f80774f'
+ '866e6fa48cb8810d36d8d85a3085d7aa1c4317d3731f0ef84919428fee87bf71')
package() {
cd "$srcdir"
@@ -42,7 +37,8 @@ package() {
ln -s "/usr/lib/${_pkgname}/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
# Place desktop entry and icons
- desktop-file-install -m 644 --dir "${pkgdir}/usr/share/applications/" "${srcdir}/${_pkgname}.desktop"
+ sed -i 's/opt/usr\/lib/' "${srcdir}/usr/share/applications/${_pkgname}.desktop"
+ desktop-file-install -m 644 --dir "${pkgdir}/usr/share/applications/" "${srcdir}/usr/share/applications/${_pkgname}.desktop"
install -dm755 "${pkgdir}/usr/share/icons/hicolor/"
cp -R "${srcdir}/usr/share/icons/hicolor/"* "${pkgdir}/usr/share/icons/hicolor/"