summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Chen2016-10-11 15:40:57 -0400
committerDaniel Chen2016-10-11 15:40:57 -0400
commit87f0464247f5f03c03c44a8f63eea9adea3075dc (patch)
tree1cc1db55fc8a3a23a8ee3c399c37ab0ca57571e6
downloadaur-87f0464247f5f03c03c44a8f63eea9adea3075dc.tar.gz
v0.0.13 inital aur submission
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
-rw-r--r--nteract.desktop18
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3ca89a90022a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+# Generated by mksrcinfo v8
+# Tue Oct 11 19:39:21 UTC 2016
+pkgbase = nteract-bin
+ pkgdesc = Interactive literate coding notebook
+ pkgver = 0.0.13
+ pkgrel = 1
+ url = https://nteract.io
+ arch = x86_64
+ license = BSD-3-Clause
+ source_x86_64 = https://github.com/nteract/nteract/releases/download/v0.0.13/nteract-linux-x64.tar.gz
+ md5sums_x86_64 = c7389edaa93aa178ddd4bb025937bb25
+
+pkgname = nteract-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9fa8eae7581c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Original Author: chendaniely<chendaniely@gmail.com>
+
+pkgname=nteract-bin
+pkgver=0.0.13
+pkgrel=1
+pkgdesc="Interactive literate coding notebook"
+url='https://nteract.io'
+arch=('x86_64')
+depends=('')
+license=('BSD-3-Clause')
+md5sums_x86_64=('c7389edaa93aa178ddd4bb025937bb25')
+source_x86_64=("https://github.com/nteract/nteract/releases/download/v$pkgver/nteract-linux-x64.tar.gz")
+
+build() {
+ cd "${srcdir}"
+ bsdtar -xf nteract-linux-x64.tar.gz
+}
+
+package() {
+ mv $srcdir/ $pkgdir/opt
+ rm $pkgdir/opt/nteract-linux-x64.tar.gz
+}
diff --git a/nteract.desktop b/nteract.desktop
new file mode 100644
index 000000000000..533c4e067d0a
--- /dev/null
+++ b/nteract.desktop
@@ -0,0 +1,18 @@
+[Desktop Entry]
+Comment=nteract: Interactive literate coding notebook
+Exec=/opt/nteract-linux-x64/nteract
+GenericName[en_US]=nteract
+GenericName=nteract
+Icon=/opt/nteract-linux-x64/resources/app/static/icon.png
+MimeType=
+Name[en_US]=nteract
+Name=nteract
+Path=/opt/nteract-linux-x64/
+StartupNotify=true
+Terminal=false
+Type=Application
+X-DBUS-ServiceName=
+X-DBUS-StartupType=
+X-KDE-SubstituteUID=false
+X-KDE-Username=
+Categories=Science;Development;