summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-01-06 17:29:07 -0700
committerMark Wagie2022-01-06 17:29:07 -0700
commitd9c6bdefc9943a9ed384997e7a30baf6394965c3 (patch)
tree0bde42f4d3c6995d8bafa2ff70d6498f90220dec
parent85ec7313b37c8d371bda62d6b752c4922cfd4f16 (diff)
downloadaur-d9c6bdefc9943a9ed384997e7a30baf6394965c3.tar.gz
minor PKGBUILD improvements
-rw-r--r--.SRCINFO3
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD32
3 files changed, 25 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3837e074365f..b1a5ff211420 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ntfix-git
pkgdesc = Fixes the problem of Proton games not running on NTFS partitions
- pkgver = 0.2.1.r1.g090af2e
+ pkgver = 0.2.1.r6.g48f4bc1
pkgrel = 1
url = https://github.com/benjamimgois/ntfix
arch = x86_64
@@ -16,4 +16,3 @@ pkgbase = ntfix-git
sha256sums = 1ef509b7f32723e2ee41d33dbc0c8460b1e12f34ca52a7fc0fd7f74985a1a71b
pkgname = ntfix-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..28debd37a6cd
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!ntfix.desktop
diff --git a/PKGBUILD b/PKGBUILD
index 8f211cf8185f..eb0224793132 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=ntfix-git
-pkgver=0.2.1.r1.g090af2e
+pkgver=0.2.1.r6.g48f4bc1
pkgrel=1
pkgdesc="Fixes the problem of Proton games not running on NTFS partitions"
arch=('x86_64')
@@ -16,25 +16,25 @@ sha256sums=('SKIP'
'1ef509b7f32723e2ee41d33dbc0c8460b1e12f34ca52a7fc0fd7f74985a1a71b')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "$srcdir/${pkgname%-git}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "$srcdir/${pkgname%-git}"
- lazbuild \
- --lazarusdir=/usr/lib/lazarus \
- --build-all \
- "${pkgname%-git}.lpi"
+ cd "$srcdir/${pkgname%-git}"
+ lazbuild \
+ --lazarusdir=/usr/lib/lazarus \
+ --build-all \
+ "${pkgname%-git}.lpi"
}
package() {
- cd "$srcdir/${pkgname%-git}"
- install -Dm755 "${pkgname%-git}" -t "$pkgdir/usr/bin"
- install -Dm644 "data/icons/${pkgname%-git}48.png" \
- "$pkgdir/usr/share/icons/hicolor/48x48/apps/${pkgname%-git}.png"
- install -Dm644 "data/icons/${pkgname%-git}_128.png" \
- "$pkgdir/usr/share/icons/hicolor/128x128/apps/${pkgname%-git}.png"
- install -Dm644 "$srcdir/${pkgname%-git}.desktop" -t \
- "$pkgdir/usr/share/applications"
+ cd "$srcdir/${pkgname%-git}"
+ install -Dm755 "${pkgname%-git}" -t "$pkgdir/usr/bin"
+ install -Dm644 "data/icons/${pkgname%-git}48.png" \
+ "$pkgdir/usr/share/icons/hicolor/48x48/apps/${pkgname%-git}.png"
+ install -Dm644 "data/icons/${pkgname%-git}_128.png" \
+ "$pkgdir/usr/share/icons/hicolor/128x128/apps/${pkgname%-git}.png"
+ install -Dm644 "$srcdir/${pkgname%-git}.desktop" -t \
+ "$pkgdir/usr/share/applications"
}