summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHanabishi2021-08-30 23:21:29 +0500
committerHanabishi2021-08-30 23:21:29 +0500
commit1e878532333dd21eb3c41067c8e4de2fbcf421f6 (patch)
tree4cf5eb48a6c5adca284a7a85d9a41cbc969d4848
parent8143622038e9493a0202f3f8977ca389a39a1d62 (diff)
downloadaur-1e878532333dd21eb3c41067c8e4de2fbcf421f6.tar.gz
Update patches
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--kernel-5.12-backport.patch116
-rw-r--r--kernel-5.14-backport.patch2
4 files changed, 63 insertions, 63 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ff8232b4289a..682dc29e7d5b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -18,8 +18,8 @@ pkgbase = ntfs3-dkms-git
source = ntfs3-v27.0.0.patch::https://github.com/torvalds/linux/compare/master...Paragon-Software-Group:master.diff
sha512sums = 533c249f0f6bd4833faf02d0d92ca1b5802a49afc5feb2e46a7d37275cfca7896db76cd83593f4f313977d278a9a7e92eda550667be2b93910c49cfb68ead4fb
sha512sums = ac00adb4a6d7fc685c39af054474631c930455e9ad0838338e6b3622b72451e81397506866b83a4a51dd0e34ed7752963c0fed9e8b017da5122e0dca3d345fb6
- sha512sums = 366f972fd3f118b537986d8e42af525d63e20b96aea0a9ec4181af4be79ef607b818ededadbde58b620c4c05ea2f02e067c72d6ad8e7ea6ff270c5c5c6fdfea7
- sha512sums = 5f04690f57fea1b4db18dd7723d9e21c23ed382935988fd9e192e07a80216efbcb06e1ff6a2ff3286bd824c19da5de1ccad68667dd06d7cc686611c0a93d6691
+ sha512sums = 60dac24871a5da1c2649e47af5fa215efcc74949e15130cdd2b240fa7ae6d5c557b10be2b1c2b6871e2cb49b578e63e144dea5b16945e5b90361abd229821c06
+ sha512sums = 7a438bdc8bf8d1a681c3277ce6ed263c5bdf77c5986ccd66a35ca7111d8c673c5d59250ba9607b07157452c2337eb9aa68fac8c7bc300b79aa22c453f34c4550
sha512sums = SKIP
pkgname = ntfs3-dkms-git
diff --git a/PKGBUILD b/PKGBUILD
index 7cfe088ef749..4164f92105fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,8 +22,8 @@ source=(
sha512sums=(
'533c249f0f6bd4833faf02d0d92ca1b5802a49afc5feb2e46a7d37275cfca7896db76cd83593f4f313977d278a9a7e92eda550667be2b93910c49cfb68ead4fb'
'ac00adb4a6d7fc685c39af054474631c930455e9ad0838338e6b3622b72451e81397506866b83a4a51dd0e34ed7752963c0fed9e8b017da5122e0dca3d345fb6'
- '60da0421ca01517e5641a99c9aaf230b65483b67d963198677b9d69cac8ef5d4055583f121ffb5be5cc8e6f47fe2bba1a9ce30c0d2c01a66bc9bb2f728c3fa21'
- '5f04690f57fea1b4db18dd7723d9e21c23ed382935988fd9e192e07a80216efbcb06e1ff6a2ff3286bd824c19da5de1ccad68667dd06d7cc686611c0a93d6691'
+ '60dac24871a5da1c2649e47af5fa215efcc74949e15130cdd2b240fa7ae6d5c557b10be2b1c2b6871e2cb49b578e63e144dea5b16945e5b90361abd229821c06'
+ '7a438bdc8bf8d1a681c3277ce6ed263c5bdf77c5986ccd66a35ca7111d8c673c5d59250ba9607b07157452c2337eb9aa68fac8c7bc300b79aa22c453f34c4550'
'SKIP'
)
diff --git a/kernel-5.12-backport.patch b/kernel-5.12-backport.patch
index e9fdad85a759..8f6dbf5ea4d0 100644
--- a/kernel-5.12-backport.patch
+++ b/kernel-5.12-backport.patch
@@ -1,15 +1,15 @@
--- a/file.c
+++ b/file.c
-@@ -76,7 +76,7 @@
+@@ -78,7 +78,7 @@
/*
- * inode_operations::getattr
+ * ntfs_getattr - inode_operations::getattr
*/
-int ntfs_getattr(struct user_namespace *mnt_userns, const struct path *path,
+int ntfs_getattr(const struct path *path,
struct kstat *stat, u32 request_mask, u32 flags)
{
struct inode *inode = d_inode(path->dentry);
-@@ -90,7 +90,7 @@
+@@ -92,7 +92,7 @@
stat->attributes_mask |= STATX_ATTR_COMPRESSED | STATX_ATTR_ENCRYPTED;
@@ -18,16 +18,16 @@
stat->result_mask |= STATX_BTIME;
stat->btime = ni->i_crtime;
-@@ -732,7 +732,7 @@
+@@ -734,7 +734,7 @@
/*
- * inode_operations::setattr
+ * ntfs3_setattr - inode_operations::setattr
*/
-int ntfs3_setattr(struct user_namespace *mnt_userns, struct dentry *dentry,
+int ntfs3_setattr(struct dentry *dentry,
struct iattr *attr)
{
struct super_block *sb = dentry->d_sb;
-@@ -751,7 +751,7 @@
+@@ -753,7 +753,7 @@
ia_valid = attr->ia_valid;
}
@@ -36,7 +36,7 @@
if (err)
goto out;
-@@ -776,10 +776,10 @@
+@@ -778,10 +778,10 @@
ni->ni_flags |= NI_FLAG_UPDATE_PARENT;
}
@@ -52,7 +52,7 @@
--- a/fsntfs.c
+++ b/fsntfs.c
-@@ -1629,7 +1629,7 @@
+@@ -1619,7 +1619,7 @@
lbo = (u64)lcn << cluster_bits;
len = (u64)clen << cluster_bits;
new_bio:
@@ -64,7 +64,7 @@
--- a/inode.c
+++ b/inode.c
-@@ -1155,7 +1155,7 @@
+@@ -1165,7 +1165,7 @@
return ERR_PTR(err);
}
@@ -73,7 +73,7 @@
struct inode *dir, struct dentry *dentry,
const struct cpu_str *uni, umode_t mode,
dev_t dev, const char *symname, u32 size,
-@@ -1268,7 +1168,7 @@
+@@ -1278,7 +1278,7 @@
goto out3;
}
inode = &ni->vfs_inode;
@@ -82,7 +82,7 @@
inode->i_atime = inode->i_mtime = inode->i_ctime = ni->i_crtime =
current_time(inode);
-@@ -1568,7 +1568,7 @@
+@@ -1578,7 +1578,7 @@
#ifdef CONFIG_NTFS3_FS_POSIX_ACL
if (!S_ISLNK(mode) && (sb->s_flags & SB_POSIXACL)) {
@@ -94,16 +94,16 @@
--- a/namei.c
+++ b/namei.c
-@@ -102,7 +102,7 @@
- *
- * inode_operations::create
+@@ -96,7 +96,7 @@
+ /*
+ * ntfs_create - inode_operations::create
*/
-static int ntfs_create(struct user_namespace *mnt_userns, struct inode *dir,
+static int ntfs_create(struct inode *dir,
struct dentry *dentry, umode_t mode, bool excl)
{
struct ntfs_inode *ni = ntfs_i(dir);
-@@ -110,7 +110,7 @@
+@@ -104,7 +104,7 @@
ni_lock_dir(ni);
@@ -112,7 +112,7 @@
0, NULL, 0, NULL);
ni_unlock(ni);
-@@ -123,7 +123,7 @@
+@@ -117,7 +117,7 @@
*
* inode_operations::mknod
*/
@@ -121,7 +121,7 @@
struct dentry *dentry, umode_t mode, dev_t rdev)
{
struct ntfs_inode *ni = ntfs_i(dir);
-@@ -131,7 +131,7 @@
+@@ -125,7 +125,7 @@
ni_lock_dir(ni);
@@ -130,16 +130,16 @@
NULL, 0, NULL);
ni_unlock(ni);
-@@ -205,7 +205,7 @@
- *
- * inode_operations::symlink
+@@ -193,7 +193,7 @@
+ /*
+ * ntfs_symlink - inode_operations::symlink
*/
-static int ntfs_symlink(struct user_namespace *mnt_userns, struct inode *dir,
+static int ntfs_symlink(struct inode *dir,
struct dentry *dentry, const char *symname)
{
u32 size = strlen(symname);
-@@ -214,7 +214,7 @@
+@@ -202,7 +202,7 @@
ni_lock_dir(ni);
@@ -148,16 +148,16 @@
0, symname, size, NULL);
ni_unlock(ni);
-@@ -227,7 +227,7 @@
- *
- * inode_operations::mkdir
+@@ -213,7 +213,7 @@
+ /*
+ * ntfs_mkdir- inode_operations::mkdir
*/
-static int ntfs_mkdir(struct user_namespace *mnt_userns, struct inode *dir,
+static int ntfs_mkdir(struct inode *dir,
struct dentry *dentry, umode_t mode)
{
struct inode *inode;
-@@ -235,7 +235,7 @@
+@@ -221,7 +221,7 @@
ni_lock_dir(ni);
@@ -166,9 +166,9 @@
0, NULL, 0, NULL);
ni_unlock(ni);
-@@ -267,7 +267,7 @@
- *
- * inode_operations::rename
+@@ -249,7 +249,7 @@
+ /*
+ * ntfs_rename - inode_operations::rename
*/
-static int ntfs_rename(struct user_namespace *mnt_userns, struct inode *old_dir,
+static int ntfs_rename(struct inode *old_dir,
@@ -181,7 +181,7 @@
@@ -459,11 +459,11 @@
extern const struct file_operations ntfs_dir_operations;
- /* globals from file.c*/
+ /* Globals from file.c */
-int ntfs_getattr(struct user_namespace *mnt_userns, const struct path *path,
+int ntfs_getattr(const struct path *path,
struct kstat *stat, u32 request_mask, u32 flags);
@@ -226,7 +226,7 @@
--- a/super.c
+++ b/super.c
-@@ -545,10 +545,10 @@
+@@ -557,10 +557,10 @@
if (opts->uid)
seq_printf(m, ",uid=%u",
@@ -239,7 +239,7 @@
if (opts->fmask)
seq_printf(m, ",fmask=%04o", ~opts->fs_fmask_inv);
if (opts->dmask)
-@@ -1422,7 +1422,7 @@
+@@ -1440,7 +1440,7 @@
.name = "ntfs3",
.mount = ntfs_mount,
.kill_sb = kill_block_super,
@@ -251,7 +251,7 @@
--- a/xattr.c
+++ b/xattr.c
-@@ -486,7 +486,7 @@
+@@ -485,7 +485,7 @@
kfree(acl);
}
@@ -260,16 +260,16 @@
struct inode *inode, int type,
int locked)
{
-@@ -522,7 +522,7 @@
+@@ -521,7 +521,7 @@
- /* Translate extended attribute to acl */
+ /* Translate extended attribute to acl. */
if (err >= 0) {
- acl = posix_acl_from_xattr(mnt_userns, buf, err);
+ acl = posix_acl_from_xattr(&init_user_ns, buf, err);
if (!IS_ERR(acl))
set_cached_acl(inode, type, acl);
} else {
-@@ -542,10 +542,10 @@
+@@ -539,10 +539,10 @@
struct posix_acl *ntfs_get_acl(struct inode *inode, int type)
{
/* TODO: init_user_ns? */
@@ -282,7 +282,7 @@
struct inode *inode, struct posix_acl *acl,
int type, int locked)
{
-@@ -603,7 +603,7 @@
+@@ -600,7 +600,7 @@
if (!value)
return -ENOMEM;
@@ -291,9 +291,9 @@
if (err < 0)
goto out;
}
-@@ -624,13 +624,13 @@
- *
- * inode_operations::set_acl
+@@ -619,13 +619,13 @@
+ /*
+ * ntfs_set_acl - inode_operations::set_acl
*/
-int ntfs_set_acl(struct user_namespace *mnt_userns, struct inode *inode,
+int ntfs_set_acl(struct inode *inode,
@@ -308,7 +308,7 @@
struct inode *inode, int type, void *buffer,
size_t size)
{
-@@ -647,13 +647,13 @@
+@@ -642,13 +642,13 @@
if (!acl)
return -ENODATA;
@@ -324,7 +324,7 @@
struct inode *inode, int type, const void *value,
size_t size)
{
-@@ -663,24 +663,24 @@
+@@ -658,24 +658,24 @@
if (!(inode->i_sb->s_flags & SB_POSIXACL))
return -EOPNOTSUPP;
@@ -353,16 +353,16 @@
release_and_out:
ntfs_posix_acl_release(acl);
-@@ -690,7 +690,7 @@
- /*
- * Initialize the ACLs of a new inode. Called from ntfs_create_inode.
+@@ -687,7 +687,7 @@
+ *
+ * Called from ntfs_create_inode().
*/
-int ntfs_init_acl(struct user_namespace *mnt_userns, struct inode *inode,
+int ntfs_init_acl(struct inode *inode,
struct inode *dir)
{
struct posix_acl *default_acl, *acl;
-@@ -702,7 +702,7 @@
+@@ -699,7 +699,7 @@
*/
inode->i_default_acl = NULL;
@@ -371,7 +371,7 @@
if (!default_acl || default_acl == ERR_PTR(-EOPNOTSUPP)) {
inode->i_mode &= ~current_umask();
-@@ -730,13 +730,13 @@
+@@ -727,13 +727,13 @@
}
if (default_acl)
@@ -387,16 +387,16 @@
1);
posix_acl_release(acl);
-@@ -753,7 +753,7 @@
- *
- * helper for 'ntfs3_setattr'
+@@ -748,7 +748,7 @@
+ /*
+ * ntfs_acl_chmod - Helper for ntfs3_setattr().
*/
-int ntfs_acl_chmod(struct user_namespace *mnt_userns, struct inode *inode)
+int ntfs_acl_chmod(struct inode *inode)
{
struct super_block *sb = inode->i_sb;
-@@ -763,7 +763,7 @@
+@@ -758,7 +758,7 @@
if (S_ISLNK(inode->i_mode))
return -EOPNOTSUPP;
@@ -405,16 +405,16 @@
}
/*
-@@ -771,7 +771,7 @@
- *
- * inode_operations::permission
+@@ -764,7 +764,7 @@
+ /*
+ * ntfs_permission - inode_operations::permission
*/
-int ntfs_permission(struct user_namespace *mnt_userns, struct inode *inode,
+int ntfs_permission(struct inode *inode,
int mask)
{
if (ntfs_sb(inode->i_sb)->options.no_acs_rules) {
-@@ -779,7 +779,7 @@
+@@ -772,7 +772,7 @@
return 0;
}
@@ -423,7 +423,7 @@
}
/*
-@@ -893,7 +893,7 @@
+@@ -884,7 +884,7 @@
sizeof(XATTR_NAME_POSIX_ACL_DEFAULT)))) {
/* TODO: init_user_ns? */
err = ntfs_xattr_get_acl(
@@ -432,8 +432,8 @@
name_len == sizeof(XATTR_NAME_POSIX_ACL_ACCESS) - 1
? ACL_TYPE_ACCESS
: ACL_TYPE_DEFAULT,
-@@ -914,7 +914,7 @@
- * inode_operations::setxattr
+@@ -903,7 +903,7 @@
+ * ntfs_setxattr - inode_operations::setxattr
*/
static noinline int ntfs_setxattr(const struct xattr_handler *handler,
- struct user_namespace *mnt_userns,
@@ -441,7 +441,7 @@
struct dentry *de, struct inode *inode,
const char *name, const void *value,
size_t size, int flags)
-@@ -1024,6 +1024,6 @@
+@@ -1013,6 +1013,6 @@
sizeof(XATTR_NAME_POSIX_ACL_DEFAULT)))) {
err = ntfs_xattr_set_acl(
- mnt_userns, inode,
diff --git a/kernel-5.14-backport.patch b/kernel-5.14-backport.patch
index 13da088ca680..12e30582d942 100644
--- a/kernel-5.14-backport.patch
+++ b/kernel-5.14-backport.patch
@@ -1,6 +1,6 @@
--- a/file.c
+++ b/file.c
-@@ -1030,10 +1030,10 @@
+@@ -1038,10 +1038,10 @@
size_t cp, tail = PAGE_SIZE - off;
page = pages[ip];