summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHanabishi2021-09-14 03:29:16 +0500
committerHanabishi2021-09-14 03:29:16 +0500
commit562a746a5c7d73384192a04df15593d5a132a0a7 (patch)
tree8401450e8fa653f1e49d111d0319549b5075f17c
parentb65a8d7e3cb09705d0ef8a643bb78ed9e569bc63 (diff)
downloadaur-562a746a5c7d73384192a04df15593d5a132a0a7.tar.gz
Update patches
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--kernel-5.12-backport.patch80
-rw-r--r--kernel-5.14-backport.patch2
4 files changed, 47 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b1cbb66aed49..7b6f151e29be 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ntfs3-dkms-git
pkgdesc = NTFS read-write driver GPL implementation by Paragon Software. Current version works with NTFS (including v3.1), normal/compressed/sparse files and supports journal replaying.
- pkgver = r45.g15b2ae7
+ pkgver = r57.g8e69212
pkgrel = 1
url = https://github.com/Paragon-Software-Group/linux-ntfs3
arch = any
@@ -19,8 +19,8 @@ pkgbase = ntfs3-dkms-git
source = ntfs3::svn+https://github.com/Paragon-Software-Group/linux-ntfs3/branches/devel/fs/ntfs3
sha512sums = 533c249f0f6bd4833faf02d0d92ca1b5802a49afc5feb2e46a7d37275cfca7896db76cd83593f4f313977d278a9a7e92eda550667be2b93910c49cfb68ead4fb
sha512sums = ac00adb4a6d7fc685c39af054474631c930455e9ad0838338e6b3622b72451e81397506866b83a4a51dd0e34ed7752963c0fed9e8b017da5122e0dca3d345fb6
- sha512sums = 1b428ec1e74c14a4e6840359707625c4dcd9b6a0664fcaa2d7a5d406d7db233834e32e7ae38201cdd0254a05d9c968a93dc960b47fbb2b5f80dc950df9f60145
- sha512sums = 0392b665aced96aa92cd6e0f72c2276c0233e661c7cc3b6fe8e074c2be654f2c8836b1d0468a8a665f43fac08704896d0ef0dcbb8826b4deef88a3a894bdf050
+ sha512sums = 855bb1e9443d4c474e52597f2f41201369ed0fca0dc6212c602cfd75f3129a6708ba7eabcdf7c875d24b71926ac1ca77456e8f19e72ac54525ab6c1f96a71627
+ sha512sums = c4a127bb2214242d0ae23a12c1b2eaa064feeb30d4dd21ed1cecf6d9787723da83491724142f1952e493303ea06669b75054ab476769c3b0db7fe7a1403d6acf
sha512sums = SKIP
pkgname = ntfs3-dkms-git
diff --git a/PKGBUILD b/PKGBUILD
index 45ccc37a1fec..e0e93407a076 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=ntfs3-dkms-git
-pkgver=r45.g15b2ae7
+pkgver=r57.g8e69212
pkgrel=1
pkgdesc="NTFS read-write driver GPL implementation by Paragon Software. Current version works with NTFS (including v3.1), normal/compressed/sparse files and supports journal replaying."
arch=('any')
@@ -22,8 +22,8 @@ source=(
sha512sums=(
'533c249f0f6bd4833faf02d0d92ca1b5802a49afc5feb2e46a7d37275cfca7896db76cd83593f4f313977d278a9a7e92eda550667be2b93910c49cfb68ead4fb'
'ac00adb4a6d7fc685c39af054474631c930455e9ad0838338e6b3622b72451e81397506866b83a4a51dd0e34ed7752963c0fed9e8b017da5122e0dca3d345fb6'
- '1b428ec1e74c14a4e6840359707625c4dcd9b6a0664fcaa2d7a5d406d7db233834e32e7ae38201cdd0254a05d9c968a93dc960b47fbb2b5f80dc950df9f60145'
- '0392b665aced96aa92cd6e0f72c2276c0233e661c7cc3b6fe8e074c2be654f2c8836b1d0468a8a665f43fac08704896d0ef0dcbb8826b4deef88a3a894bdf050'
+ '855bb1e9443d4c474e52597f2f41201369ed0fca0dc6212c602cfd75f3129a6708ba7eabcdf7c875d24b71926ac1ca77456e8f19e72ac54525ab6c1f96a71627'
+ 'c4a127bb2214242d0ae23a12c1b2eaa064feeb30d4dd21ed1cecf6d9787723da83491724142f1952e493303ea06669b75054ab476769c3b0db7fe7a1403d6acf'
'SKIP'
)
diff --git a/kernel-5.12-backport.patch b/kernel-5.12-backport.patch
index 300d6b5624ba..aa448ef50c7e 100644
--- a/kernel-5.12-backport.patch
+++ b/kernel-5.12-backport.patch
@@ -1,6 +1,6 @@
--- a/file.c
+++ b/file.c
-@@ -70,7 +70,7 @@
+@@ -69,7 +69,7 @@
/*
* ntfs_getattr - inode_operations::getattr
*/
@@ -9,7 +9,7 @@
struct kstat *stat, u32 request_mask, u32 flags)
{
struct inode *inode = d_inode(path->dentry);
-@@ -84,7 +84,7 @@
+@@ -83,7 +83,7 @@
stat->attributes_mask |= STATX_ATTR_COMPRESSED | STATX_ATTR_ENCRYPTED;
@@ -18,7 +18,7 @@
stat->result_mask |= STATX_BTIME;
stat->btime = ni->i_crtime;
-@@ -726,7 +726,7 @@
+@@ -725,7 +725,7 @@
/*
* ntfs3_setattr - inode_operations::setattr
*/
@@ -27,7 +27,7 @@
struct iattr *attr)
{
struct super_block *sb = dentry->d_sb;
-@@ -745,7 +745,7 @@
+@@ -744,7 +744,7 @@
ia_valid = attr->ia_valid;
}
@@ -36,7 +36,7 @@
if (err)
goto out;
-@@ -770,10 +770,10 @@
+@@ -769,10 +769,10 @@
ni->ni_flags |= NI_FLAG_UPDATE_PARENT;
}
@@ -52,7 +52,7 @@
--- a/fsntfs.c
+++ b/fsntfs.c
-@@ -1602,7 +1602,7 @@
+@@ -1601,7 +1601,7 @@
lbo = (u64)lcn << cluster_bits;
len = (u64)clen << cluster_bits;
new_bio:
@@ -64,7 +64,7 @@
--- a/inode.c
+++ b/inode.c
-@@ -1171,7 +1171,7 @@
+@@ -1169,7 +1169,7 @@
return ERR_PTR(err);
}
@@ -73,7 +73,7 @@
struct inode *dir, struct dentry *dentry,
const struct cpu_str *uni, umode_t mode,
dev_t dev, const char *symname, u32 size,
-@@ -1284,7 +1284,7 @@
+@@ -1282,7 +1282,7 @@
goto out3;
}
inode = &ni->vfs_inode;
@@ -82,7 +82,7 @@
mode = inode->i_mode;
inode->i_atime = inode->i_mtime = inode->i_ctime = ni->i_crtime =
-@@ -1575,7 +1575,7 @@
+@@ -1573,7 +1573,7 @@
#ifdef CONFIG_NTFS3_FS_POSIX_ACL
if (!S_ISLNK(mode) && (sb->s_flags & SB_POSIXACL)) {
@@ -94,7 +94,7 @@
--- a/namei.c
+++ b/namei.c
-@@ -96,7 +96,7 @@
+@@ -92,7 +92,7 @@
/*
* ntfs_create - inode_operations::create
*/
@@ -103,7 +103,7 @@
struct dentry *dentry, umode_t mode, bool excl)
{
struct ntfs_inode *ni = ntfs_i(dir);
-@@ -104,7 +104,7 @@
+@@ -100,7 +100,7 @@
ni_lock_dir(ni);
@@ -112,7 +112,7 @@
0, NULL, 0, NULL);
ni_unlock(ni);
-@@ -117,7 +117,7 @@
+@@ -113,7 +113,7 @@
*
* inode_operations::mknod
*/
@@ -121,7 +121,7 @@
struct dentry *dentry, umode_t mode, dev_t rdev)
{
struct ntfs_inode *ni = ntfs_i(dir);
-@@ -125,7 +125,7 @@
+@@ -121,7 +121,7 @@
ni_lock_dir(ni);
@@ -130,7 +130,7 @@
NULL, 0, NULL);
ni_unlock(ni);
-@@ -195,7 +195,7 @@
+@@ -191,7 +191,7 @@
/*
* ntfs_symlink - inode_operations::symlink
*/
@@ -139,7 +139,7 @@
struct dentry *dentry, const char *symname)
{
u32 size = strlen(symname);
-@@ -204,7 +204,7 @@
+@@ -200,7 +200,7 @@
ni_lock_dir(ni);
@@ -148,7 +148,7 @@
0, symname, size, NULL);
ni_unlock(ni);
-@@ -215,7 +215,7 @@
+@@ -211,7 +211,7 @@
/*
* ntfs_mkdir- inode_operations::mkdir
*/
@@ -157,7 +157,7 @@
struct dentry *dentry, umode_t mode)
{
struct inode *inode;
-@@ -223,7 +223,7 @@
+@@ -219,7 +219,7 @@
ni_lock_dir(ni);
@@ -166,7 +166,7 @@
0, NULL, 0, NULL);
ni_unlock(ni);
-@@ -251,7 +251,7 @@
+@@ -247,7 +247,7 @@
/*
* ntfs_rename - inode_operations::rename
*/
@@ -178,7 +178,7 @@
--- a/ntfs_fs.h
+++ b/ntfs_fs.h
-@@ -457,11 +457,11 @@
+@@ -488,11 +488,11 @@
extern const struct file_operations ntfs_dir_operations;
/* Globals from file.c */
@@ -192,7 +192,7 @@
struct iattr *attr);
int ntfs_file_open(struct inode *inode, struct file *file);
int ntfs_fiemap(struct inode *inode, struct fiemap_extent_info *fieinfo,
-@@ -666,7 +666,7 @@
+@@ -697,7 +697,7 @@
int ntfs_flush_inodes(struct super_block *sb, struct inode *i1,
struct inode *i2);
int inode_write_data(struct inode *inode, const void *data, size_t bytes);
@@ -201,7 +201,7 @@
struct inode *dir, struct dentry *dentry,
const struct cpu_str *uni, umode_t mode,
dev_t dev, const char *symname, u32 size,
-@@ -808,17 +808,17 @@
+@@ -839,17 +839,17 @@
/* globals from xattr.c */
#ifdef CONFIG_NTFS3_FS_POSIX_ACL
struct posix_acl *ntfs_get_acl(struct inode *inode, int type);
@@ -226,7 +226,7 @@
--- a/super.c
+++ b/super.c
-@@ -520,9 +520,9 @@
+@@ -518,9 +518,9 @@
struct user_namespace *user_ns = seq_user_ns(m);
seq_printf(m, ",uid=%u",
@@ -238,7 +238,7 @@
if (opts->fmask)
seq_printf(m, ",fmask=%04o", ~opts->fs_fmask_inv);
if (opts->dmask)
-@@ -1464,7 +1464,7 @@
+@@ -1462,7 +1462,7 @@
.init_fs_context = ntfs_init_fs_context,
.parameters = ntfs_fs_parameters,
.kill_sb = kill_block_super,
@@ -250,7 +250,7 @@
--- a/xattr.c
+++ b/xattr.c
-@@ -484,7 +484,7 @@
+@@ -481,7 +481,7 @@
kfree(acl);
}
@@ -259,7 +259,7 @@
struct inode *inode, int type,
int locked)
{
-@@ -520,7 +520,7 @@
+@@ -517,7 +517,7 @@
/* Translate extended attribute to acl. */
if (err >= 0) {
@@ -268,7 +268,7 @@
if (!IS_ERR(acl))
set_cached_acl(inode, type, acl);
} else {
-@@ -538,10 +538,10 @@
+@@ -535,10 +535,10 @@
struct posix_acl *ntfs_get_acl(struct inode *inode, int type)
{
/* TODO: init_user_ns? */
@@ -281,7 +281,7 @@
struct inode *inode, struct posix_acl *acl,
int type, int locked)
{
-@@ -599,7 +599,7 @@
+@@ -596,7 +596,7 @@
if (!value)
return -ENOMEM;
@@ -290,7 +290,7 @@
if (err < 0)
goto out;
}
-@@ -617,13 +617,13 @@
+@@ -614,13 +614,13 @@
/*
* ntfs_set_acl - inode_operations::set_acl
*/
@@ -307,7 +307,7 @@
struct inode *inode, int type, void *buffer,
size_t size)
{
-@@ -642,13 +642,13 @@
+@@ -639,13 +639,13 @@
if (!acl)
return -ENODATA;
@@ -323,7 +323,7 @@
struct inode *inode, int type, const void *value,
size_t size)
{
-@@ -660,24 +660,24 @@
+@@ -657,24 +657,24 @@
return -EOPNOTSUPP;
}
@@ -352,7 +352,7 @@
release_and_out:
ntfs_posix_acl_release(acl);
-@@ -689,7 +689,7 @@
+@@ -686,7 +686,7 @@
*
* Called from ntfs_create_inode().
*/
@@ -361,7 +361,7 @@
struct inode *dir)
{
struct posix_acl *default_acl, *acl;
-@@ -701,7 +701,7 @@
+@@ -698,7 +698,7 @@
*/
inode->i_default_acl = NULL;
@@ -370,7 +370,7 @@
if (!default_acl || default_acl == ERR_PTR(-EOPNOTSUPP)) {
inode->i_mode &= ~current_umask();
-@@ -729,13 +729,13 @@
+@@ -726,13 +726,13 @@
}
if (default_acl)
@@ -386,7 +386,7 @@
1);
posix_acl_release(acl);
-@@ -750,7 +750,7 @@
+@@ -747,7 +747,7 @@
/*
* ntfs_acl_chmod - Helper for ntfs3_setattr().
*/
@@ -395,7 +395,7 @@
{
struct super_block *sb = inode->i_sb;
-@@ -760,7 +760,7 @@
+@@ -757,7 +757,7 @@
if (S_ISLNK(inode->i_mode))
return -EOPNOTSUPP;
@@ -404,7 +404,7 @@
}
/*
-@@ -766,7 +766,7 @@
+@@ -763,7 +763,7 @@
/*
* ntfs_permission - inode_operations::permission
*/
@@ -413,7 +413,7 @@
int mask)
{
if (ntfs_sb(inode->i_sb)->options->noacsrules) {
-@@ -774,7 +774,7 @@
+@@ -771,7 +771,7 @@
return 0;
}
@@ -422,7 +422,7 @@
}
/*
-@@ -886,7 +886,7 @@
+@@ -883,7 +883,7 @@
sizeof(XATTR_NAME_POSIX_ACL_DEFAULT)))) {
/* TODO: init_user_ns? */
err = ntfs_xattr_get_acl(
@@ -431,7 +431,7 @@
name_len == sizeof(XATTR_NAME_POSIX_ACL_ACCESS) - 1
? ACL_TYPE_ACCESS
: ACL_TYPE_DEFAULT,
-@@ -905,7 +905,7 @@
+@@ -902,7 +902,7 @@
* ntfs_setxattr - inode_operations::setxattr
*/
static noinline int ntfs_setxattr(const struct xattr_handler *handler,
@@ -440,7 +440,7 @@
struct dentry *de, struct inode *inode,
const char *name, const void *value,
size_t size, int flags)
-@@ -1015,6 +1015,6 @@
+@@ -1012,6 +1012,6 @@
sizeof(XATTR_NAME_POSIX_ACL_DEFAULT)))) {
err = ntfs_xattr_set_acl(
- mnt_userns, inode,
diff --git a/kernel-5.14-backport.patch b/kernel-5.14-backport.patch
index d751e90f98a2..f9b5dc636d0c 100644
--- a/kernel-5.14-backport.patch
+++ b/kernel-5.14-backport.patch
@@ -1,6 +1,6 @@
--- a/file.c
+++ b/file.c
-@@ -1026,10 +1026,10 @@
+@@ -1025,10 +1025,10 @@
size_t cp, tail = PAGE_SIZE - off;
page = pages[ip];