summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHanabishi2022-12-26 23:03:22 +0500
committerHanabishi2022-12-26 23:03:22 +0500
commit7c88084bc2c97dd8820fe3abff90e2cc5e90a1f2 (patch)
treed0734b23002125a1dc69ae6926e606fd5566fd86
parentccdcb0b8e5fd05ae990c4ba545a3554c2cb6a75d (diff)
downloadaur-7c88084bc2c97dd8820fe3abff90e2cc5e90a1f2.tar.gz
New version (6.2)
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore10
-rw-r--r--PKGBUILD24
-rw-r--r--dkms.conf4
4 files changed, 20 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 84ef541fd67f..5bb338c7f886 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ntfs3-dkms-git
pkgdesc = NTFS3 is fully functional NTFS Read-Write driver. The driver works with NTFS versions up to 3.1.
- pkgver = 6.0.r0.gf76349c
+ pkgver = 6.2.r0.g1b929c0
pkgrel = 1
epoch = 1
url = https://github.com/Paragon-Software-Group/linux-ntfs3
@@ -13,9 +13,9 @@ pkgbase = ntfs3-dkms-git
conflicts = ntfs3
options = !strip
options = !emptydirs
- source = Makefile.patch
source = dkms.conf
+ source = Makefile.patch
+ sha256sums = ebb7f7cb975c5ee7a49475190403c11ddffab2664e594ac11d1fc0a5542e872c
sha256sums = fd4cf0e2dc160efecc55d4ea99667669b870599e4e81be435ec2201381b7e2ac
- sha256sums = 87ec3e1fdd50c2218eb93aa73fbcaa018275c12ea2ee6648b815e57207d2e132
pkgname = ntfs3-dkms-git
diff --git a/.gitignore b/.gitignore
index fbaf293afc73..72504b3efbe8 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,6 @@
-pkg/
-src/
-ntfs3/
-*.pkg.tar.* \ No newline at end of file
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!dkms.conf
+!*.patch
diff --git a/PKGBUILD b/PKGBUILD
index cb336acad750..1fb642937e54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=ntfs3-dkms-git
-pkgver=6.0.r0.gf76349c
+pkgver=6.2.r0.g1b929c0
pkgrel=1
epoch=1
pkgdesc="NTFS3 is fully functional NTFS Read-Write driver. The driver works with NTFS versions up to 3.1."
@@ -13,17 +13,17 @@ conflicts=('ntfs3')
options=('!strip' '!emptydirs')
source=(
- "Makefile.patch"
"dkms.conf"
+ "Makefile.patch"
)
sha256sums=(
+ 'ebb7f7cb975c5ee7a49475190403c11ddffab2664e594ac11d1fc0a5542e872c'
'fd4cf0e2dc160efecc55d4ea99667669b870599e4e81be435ec2201381b7e2ac'
- '87ec3e1fdd50c2218eb93aa73fbcaa018275c12ea2ee6648b815e57207d2e132'
)
-_ver="6.0"
-_since="1664139662"
+_ver="6.2"
+_since="1672004499"
# The whole kernel history is very huge, so downloading it is a pain.
# Also commits count is insane and we don't want to see all that in pkgver.
@@ -31,7 +31,7 @@ _since="1664139662"
# Make a shallow clone since the specified timestamp.
pkgver() {
- cd "${srcdir}/repo"
+ cd "repo"
local rev
rev=$(("$(git rev-list --count HEAD)" - 1))
@@ -42,8 +42,6 @@ pkgver() {
}
prepare() {
- cd "${srcdir}"
-
if [ ! -d "repo" ]; then
git clone --shallow-since="${_since}" --filter=tree:0 --no-checkout --single-branch "${url}" "repo"
fi
@@ -58,11 +56,7 @@ prepare() {
}
package() {
- local src="${pkgdir}/usr/src"
- install -dm755 "${src}"
-
- cd "${srcdir}"
- local dest="${src}/ntfs3-${_ver}"
- cp -r "repo/fs/ntfs3" "${dest}"
- install -Dm644 -t "${dest}" "dkms.conf"
+ local dest="${pkgdir}/usr/src/ntfs3-${_ver}"
+ install -Dm644 -t "${dest}" "${source[0]}"
+ cp -rpT "repo/fs/ntfs3" "${dest}"
}
diff --git a/dkms.conf b/dkms.conf
index 449024808f70..65c0d79a539d 100644
--- a/dkms.conf
+++ b/dkms.conf
@@ -1,7 +1,7 @@
PACKAGE_NAME="ntfs3"
-PACKAGE_VERSION="6.0"
+PACKAGE_VERSION="6.2"
BUILT_MODULE_NAME[0]="ntfs3"
DEST_MODULE_LOCATION[0]="/kernel/fs/ntfs3"
AUTOINSTALL="yes"
MAKE[0]="KVERSION=${kernelver} CONFIG_NTFS3_FS=m CONFIG_NTFS3_LZX_XPRESS=y CONFIG_NTFS3_FS_POSIX_ACL=y make KDIR=${kernel_source_dir}"
-BUILD_EXCLUSIVE_KERNEL="^6\.0\.?"
+BUILD_EXCLUSIVE_KERNEL="^6\.2\.?"