summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorteamalpha54412016-05-19 17:47:26 +0200
committerteamalpha54412016-05-19 17:47:26 +0200
commit288c476ab644c9d391156f93606ea9f00f28c916 (patch)
treecb608831e5969b01ecb6619e35acc3979ea26406
downloadaur-288c476ab644c9d391156f93606ea9f00f28c916.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD29
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..193e7606a094
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = ntfy-git
+ pkgdesc = A utility for sending push notifications to different backends (Pushover, Pushbullet, XMPP and various desktop notification systems)
+ pkgver = v2.0.1.r2.g30308ca
+ pkgrel = 1
+ url = https://github.com/dschep/ntfy
+ arch = any
+ license = GPLv3
+ makedepends = python
+ makedepends = git
+ depends = python
+ depends = python-yaml
+ depends = python-requests
+ depends = python-appdirs
+ depends = python-ruamel.yaml
+ depends = python-setuptools
+ provides = ntfy
+ conflicts = ntfy
+ source = ntfy-git::git+https://github.com/dschep/ntfy.git
+ sha256sums = SKIP
+
+pkgname = ntfy-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bcf86906e3ca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+pkgname=ntfy-git
+pkgver=v2.0.1.r2.g30308ca
+pkgrel=1
+pkgdesc="A utility for sending push notifications to different backends (Pushover, Pushbullet, XMPP and various desktop notification systems)"
+url="https://github.com/dschep/ntfy"
+depends=('python' 'python-yaml' 'python-requests' 'python-appdirs' 'python-ruamel.yaml' 'python-setuptools')
+makedepends=('python' 'git')
+license=('GPLv3')
+arch=('any')
+
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("${pkgname}::git+${url}.git");
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ python setup.py install --root="$pkgdir" --optimize=1
+}