summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJack O'Sullivan2017-09-03 22:24:28 +0100
committerJack O'Sullivan2017-09-03 22:24:28 +0100
commite39484587a4d67aef877f68ee276f265ca66726a (patch)
treedc594c44a689a9b78eb6a2ad315f4452e74a4521
parente6a26b480e226754a1d107f7857faca03127054a (diff)
downloadaur-e39484587a4d67aef877f68ee276f265ca66726a.tar.gz
Fix pkgver and add json-c dependency
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 73b031ca0297..89a67141f0bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ntopng-git
pkgdesc = The next generation version of the original ntop, a network traffic probe that shows the network usage
- pkgver = 20161230.8b5205e
- pkgrel = 2
+ pkgver = 3.0.r307.gc4789741
+ pkgrel = 1
url = http://www.ntop.org/
arch = x86_64
arch = i686
@@ -21,6 +21,7 @@ pkgbase = ntopng-git
depends = redis
depends = geoip
depends = libmariadbclient
+ depends = json-c
provides = ntopng
conflicts = ntopng
source = git+https://github.com/ntop/nDPI
diff --git a/PKGBUILD b/PKGBUILD
index 8fab12b2987f..9881018a7fb7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
-# Maintainer: jackos2500 <jackos1998@gmail.com>
+# Maintainer: jackos2500 <jackos1998 at gmail dot com>
pkgname=ntopng-git
_pkgname=ntopng
-pkgver=20161230.8b5205e
-pkgrel=2
+pkgver=3.0.r307.gc4789741
+pkgrel=1
pkgdesc='The next generation version of the original ntop, a network traffic probe that shows the network usage'
arch=('x86_64' 'i686' 'armv7h')
url='http://www.ntop.org/'
license=('GPL3')
-depends=('redis' 'geoip' 'libmariadbclient')
+depends=('redis' 'geoip' 'libmariadbclient' 'json-c')
makedepends=('git' 'glib2' 'automake' 'libtool' 'geoip' 'libpcap' 'wget' 'libxml2' 'sqlite' 'curl' 'libmariadbclient')
provides=('ntopng')
conflicts=('ntopng')
@@ -18,6 +18,11 @@ sha256sums=('SKIP'
'f2269843460307ef58037fa1a194c26650ced0f1d194fb9af6817917b109fe8c'
'8ec08499b1783c3e933429a3a9a4d0d32fb903bbd0b7c3fef82f0233748e3737')
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
build() {
cd "$srcdir/nDPI"
./autogen.sh