summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBidski2021-09-01 12:57:05 +1000
committerBidski2021-09-01 12:57:05 +1000
commit0d980a798f83df21588c4754e0e390316ef82666 (patch)
tree6f66a2d4a7a310052c2909f6c68c99df0bd70397
parent03010f4419285e5fb4024cd4d4bbfd0400ce3672 (diff)
parente401dd3310fa34974f3256af4e691849a802df19 (diff)
downloadaur-0d980a798f83df21588c4754e0e390316ef82666.tar.gz
upgpkg: nuclear-git r876.42d9b0d-1
Merge subtree 'nuclear-git'
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD29
2 files changed, 16 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 287ce5e41f8f..ae2fab274081 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = nuclear-git
pkgdesc = NUClear is a C++ software framework designed to aid in the development of real time modular systems.
- pkgver = r890.f4a60c7
+ pkgver = r876.42d9b0d
pkgrel = 1
url = https://github.com/Fastcode/NUClear
arch = x86_64
@@ -19,3 +19,4 @@ pkgbase = nuclear-git
md5sums = SKIP
pkgname = nuclear-git
+
diff --git a/PKGBUILD b/PKGBUILD
index 6ea902ca4704..9e4642565146 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,6 @@
-# Maintainer: Bidski <bidskii at gmail dot com>
-_pkgname=nuclear
-pkgname=${_pkgname}-git
-pkgver=r890.f4a60c7
+# Maintainer: Alex Biddulph <bidskii@gmail.com>
+pkgname=nuclear-git
+pkgver=r876.42d9b0d
pkgrel=1
pkgdesc="NUClear is a C++ software framework designed to aid in the development of real time modular systems."
arch=('x86_64' 'i686')
@@ -10,20 +9,20 @@ license=('MIT')
groups=('devel')
makedepends=('git' 'make' 'cmake>=3.1', 'gcc>=4.9')
optdepends=('python-sphinx: documentation' 'doxygen: documentation')
-provides=("${_pkgname}")
-conflicts=("${_pkgname}")
-source=("${_pkgname}"::'git+https://github.com/Fastcode/NUClear.git#branch=master')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("${pkgname%-git}"::'git+https://github.com/Fastcode/NUClear.git#branch=master')
md5sums=('SKIP')
# Check for optional dependencies
_installed_pkgs=$(pacman -Qq)
_sphinx_installed=$(echo "${_installed_pkgs}" | grep "python-sphinx" > /dev/null ; echo $?)
_doxygen_installed=$(echo "${_installed_pkgs}" | grep "doxygen" > /dev/null ; echo $?)
pkgver() {
- cd "${srcdir}/${_pkgname}"
+ cd "$srcdir/${pkgname%-git}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "${srcdir}/${_pkgname}"
+ cd "$srcdir/${pkgname%-git}"
# Check to see if we should build documentation
optional_args="-DBUILD_DOCUMENTATION=OFF"
if [[ ( "${_sphinx_installed}" == 0 ) && ( "${_doxygen_installed}" == 0 ) ]];
@@ -37,16 +36,16 @@ build() {
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_TESTS=ON \
${optional_args}
- make
+ make
}
check() {
- cd "${srcdir}/${_pkgname}/build"
+ cd "$srcdir/${pkgname%-git}/build"
./tests/test_nuclear
}
package() {
- cd "${srcdir}/${_pkgname}/build"
- make DESTDIR="${pkgdir}/" install
- cd "${srcdir}/${_pkgname}"
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+ cd "$srcdir/${pkgname%-git}/build"
+ make DESTDIR="$pkgdir/" install
+ cd "$srcdir/${pkgname%-git}"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}