summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-08-07 08:01:12 +1200
committercaltlgin2020-08-07 08:01:12 +1200
commitaa0cdd53f92e0662ae7eeb775b0d0d892e49d421 (patch)
treeaff910261b70beee28e1889613345fd7d5df8f10
downloadaur-aa0cdd53f92e0662ae7eeb775b0d0d892e49d421.tar.gz
Add to AUR
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD34
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..35445f257a2d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = nuclei
+ pkgdesc = Fast tool for configurable targeted scanning based on templates offering massive extensibility and ease of use
+ pkgver = 2.1.0
+ pkgrel = 1
+ url = https://github.com/projectdiscovery/nuclei
+ arch = x86_64
+ license = MIT
+ makedepends = go
+ provides = nuclei
+ source = nuclei-2.1.0.tar.gz::https://github.com/projectdiscovery/nuclei/archive/v2.1.0.tar.gz
+ sha256sums = 744bb5a04e79e74970fe163183d673be58c0a3a3db6a9481cafbaaaa93bbebeb
+
+pkgname = nuclei
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fff45e6ed2ce
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+
+pkgname=nuclei
+pkgver=2.1.0
+pkgrel=1
+pkgdesc='Fast tool for configurable targeted scanning based on templates offering massive extensibility and ease of use'
+arch=('x86_64')
+url='https://github.com/projectdiscovery/nuclei'
+license=('MIT')
+makedepends=('go')
+provides=("${pkgname}")
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('744bb5a04e79e74970fe163183d673be58c0a3a3db6a9481cafbaaaa93bbebeb')
+
+build() {
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
+ export GOPATH="${srcdir}"
+
+ cd "${pkgname}-${pkgver}/v2"
+ go build -v -o "${pkgname}" ."/cmd/${pkgname}"
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ install -Dm755 -t "${pkgdir}/usr/bin" "v2/${pkgname}"
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" 'README.md'
+ install -Dm644 'LICENSE.md' "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim: ts=2 sw=2 et: