summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortaotieren2022-03-20 22:30:39 +0800
committertaotieren2022-03-20 22:30:39 +0800
commiteeb83ee6c86d78b7f620dc498ef2ffc7e2466538 (patch)
treebc6bb699e277dbdbedb4ca82593c7e25d8bd6df1
parent2f5c1d5054f3f8c4ec1a4af6a0d80dd1bb0124ec (diff)
downloadaur-eeb83ee6c86d78b7f620dc498ef2ffc7e2466538.tar.gz
Update PKGBUILD
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a91c9b54c936..e587f821549f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,13 @@
pkgbase = nuclei-openocd
pkgdesc = nuclei-openocd 是 Nuclei Studio IDE 的调试工具。
pkgver = 2022.01
- pkgrel = 1
+ pkgrel = 2
url = https://www.nucleisys.com/download.php
arch = x86_64
license = unknow
+ optdepends = nucleistudioide: Nuclei Studio IDE 是基于 MCU Eclipse IDE 开发的一款针对芯来公司处理器核产品的集成开发环境工具,用于 RISC-V 开发继承了 Eclipse IDE 平台的各种优势。
+ optdepends = jlink-software-and-documentation: Segger JLink software & documentation pack for Linux
+ optdepends = embedded-studio-risc-v: Segger Embedded Studio for RISC-V
options = !strip
source = https://www.nucleisys.com/upload/files/toochain/openocd/nuclei-openocd-2022.01-linux-x64.tgz
sha256sums = 0c55a43a09bf6f75959fab44fcec6f785ed9c1a40f62d746089c654ea3409074
diff --git a/PKGBUILD b/PKGBUILD
index f31508a7d1ad..88c88ac7e374 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,14 @@
pkgname=nuclei-openocd
pkgver=2022.01
-pkgrel=1
+pkgrel=2
pkgdesc="nuclei-openocd 是 Nuclei Studio IDE 的调试工具。"
arch=("x86_64")
makedepends=()
depends=()
-optdepends=()
+optdepends=('nucleistudioide: Nuclei Studio IDE 是基于 MCU Eclipse IDE 开发的一款针对芯来公司处理器核产品的集成开发环境工具,用于 RISC-V 开发继承了 Eclipse IDE 平台的各种优势。'
+ 'jlink-software-and-documentation: Segger JLink software & documentation pack for Linux'
+ 'embedded-studio-risc-v: Segger Embedded Studio for RISC-V')
conflicts=()
url="https://www.nucleisys.com/download.php"
license=('unknow')
@@ -20,12 +22,14 @@ package() {
cd "$srcdir"
msg2 'Installing Nuclei OpenOCD'
- install -dm755 "${pkgdir}/opt/nuclei/NucleiStudio/toolchain"
+ install -dm755 "${pkgdir}/opt/nuclei/NucleiStudio/toolchain" \
+ "${pkgdir}/opt/SEGGER/Embedded-Studio-RISC-V/Nuclei_Toolchain/"
tar zxf "nuclei-openocd-${pkgver}-linux-x64.tgz"
mv "Nuclei/openocd" "${pkgdir}/opt/nuclei"
ln -sf "/opt/nuclei/openocd/${pkgver}" "${pkgdir}/opt/nuclei/NucleiStudio/toolchain/openocd"
+ ln -sf "/opt/nuclei/openocd/${pkgver}" "${pkgdir}/opt/SEGGER/Embedded-Studio-RISC-V/Nuclei_Toolchain/openocd"
}
#